Você não está autenticado.

Anúncio

ANTES DE QUALQUER UPDATE NA DISTRIBUIÇÃO LEIA ESTE LINK PARA INSTRUÇÕES DETALHADAS: http://archlinux-br.org/noticias/212/

Por favor, leia as regras do fórum antes de usá-lo.

#1 11/02/2009 22:28:39

angell
Membro
Registrado: 07/02/2009
Mensagens: 2

Xlib: extension "Generic Event Extension" missing on display ":0.0

Salve, comunidade!

Trabalho a uns 4 anos com edição profissional de vídeo com o Cinelerra, até então com Debian ou Ubuntu. testei e gostei do Arch no último trampo. Com relação ao gnu/linux, me definiria como um usuário autônomo pra instalação, configuração e manutenção do sistema, tenho ajudado a difundir o sistema e a filosofia mas não sou técnico.

Assim espero que me perdoem se for uma coisa bem besta que eu tenha esquecido. Tomara que seja:

Acabo de terminar minha primeira "instalação solo" do Archlinux(64) em um Pentium D com placa Nvidia (lspci: nVidia Corporation NV44 [GeForce 6200 TurboCache(TM)].

Fiz o pacman -S nvidia, configurei pelo nvidia-xconfig e tudo parecia bem. Ta rodando em 2 monitores, configurados pelo nvidia-settings, opção twinview.

Mas se eu rodo qualquer programa pelo terminal ele me mostra:
Xlib: extension "Generic Event Extension" missing on display ":0.0.

Apesar disso, todos os programas parecem rodar normalmente.

Menos o cinelerra!
Ele abre uma janela pequena no canto da tela que fica vazia (com a imagem que estiver por trás) e mais nada. No terminal, infinitas linhas desse erro aí.

Lendo em vários fóruns, ajudado remotamente pelos amigos que me apresentaram o Arch, seguindo essas instruções (http://wiki.archlinux-br.org/NVIDIA) fiz os testes e não cheguei a conclusão. Por exemplo:

glxinfo | grep direct
Xlib: extension "Generic Event Extension" missing on display ":0.0".
Xlib: extension "Generic Event Extension" missing on display ":0.0".
direct rendering: Yes
GL_EXT_direct_state_access, GL_EXT_draw_range_elements, GL_EXT_fog_coord

O glxgears roda entre 900 e 1100 frames/segundo. Meu lap (com arch) com uma placa parecida com metade de memória faz 2000.

Retirei o nvidia e instalei o nvidia-173xxx, reconfigurei, arranquei (pacman-Rusn)  e reinstalei o xorg, reconfigurei...

Peço a ajuda, enquanto instalo o debian pra garantir o trampo.
Antecipados agradecimentos. Garanto que já ta sendo bem instrutivo.

Angell

Offline

#2 12/02/2009 00:39:21

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: Xlib: extension "Generic Event Extension" missing on display ":0.0

Adicione seu usuário no grupo vídeo :

# gpasswd -a seu_usuario video .

Offline

#3 12/02/2009 00:42:46

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: Xlib: extension "Generic Event Extension" missing on display ":0.0

Tenho esta mesma placa , mas não é Turbo Cache .

01:00.0 VGA compatible controller: nVidia Corporation GeForce 6200 A-LE

Minha saída do # glxgears :

[root@Arch-Linux Desktop]# glxgears
6770 frames in 5.0 seconds = 1353.887 FPS
6973 frames in 5.0 seconds = 1394.584 FPS
7090 frames in 5.0 seconds = 1417.900 FPS
7049 frames in 5.0 seconds = 1409.734 FPS
31778 frames in 5.0 seconds = 6355.526 FPS
66486 frames in 5.0 seconds = 13297.200 FPS
65829 frames in 5.0 seconds = 13165.800 FPS
67284 frames in 5.0 seconds = 13456.676 FPS
68431 frames in 5.0 seconds = 13686.014 FPS 
71546 frames in 5.0 seconds = 14309.160 FPS

Offline

#4 13/02/2009 11:13:29

angell
Membro
Registrado: 07/02/2009
Mensagens: 2

Re: Xlib: extension "Generic Event Extension" missing on display ":0.0

Salve!

o usuário já estava no grupo video.

reinstalei o arch todo, com ajuda (presencial, agora) de amigos que usam o arch e entendem melhor, e tudo ficou do mesmo jeito.

é como se faltasse alguma coisa na instalação, todos os programas que dependem de libs gráficas dão essas mesmas mensagens. O xterm, por exemplo, não dá.

Instalei meu velho conhecido debian testing e tive outro problema com o cinelerra: ele não toca som.
Postei aqui:
http://estudiolivre.org/tiki-view_forum … &forumId=2

Estou tentando o ubuntu, enquanto continuo pesquisando.

agradeço qualquer ajuda!

Offline

#5 14/02/2009 15:46:11

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: Xlib: extension "Generic Event Extension" missing on display ":0.0

Aqui está aparecendo essa mesma mensagem, mas como não deu problema nenhum no sistema, simplesmente estou ignorando.

Offline

#6 14/02/2009 15:53:09

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: Xlib: extension "Generic Event Extension" missing on display ":0.0

http://www.nabble.com/Xlib:-extension-% … 09363.html

Veja, o xorg-server versão estável ainda não tem suporte a essa extensão (só a versão 1.6 tem, que vai ser empacotada assim que sair como estável)... Mas a xlib já suporta e fica tentando usar, por isso dá esses warnings.

É chato, mas infelizmente o povo do Xorg comeu bola de novo. Negócio é ignorar as mensagens até sair o xorg-server novo.

Offline

#7 14/02/2009 16:23:52

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: Xlib: extension "Generic Event Extension" missing on display ":0.0

thotypous escreveu:

Aqui está aparecendo essa mesma mensagem, mas como não deu problema nenhum no sistema, simplesmente estou ignorando.

Comigo também .

Offline

#8 14/02/2009 17:14:17

RickDiamond
Banido
Registrado: 17/07/2008
Mensagens: 348

Re: Xlib: extension "Generic Event Extension" missing on display ":0.0

Aqui também aparece essa mensagem de erro da Xlib, mas, pelo que eu andei lendo, pode ser ignorada. Tem até um bug report, que foi fechado por não ser um bug.

Offline

#9 18/02/2009 01:39:46

robmurray
Membro
De: Curitiba - Pr
Registrado: 29/10/2006
Mensagens: 63

Re: Xlib: extension "Generic Event Extension" missing on display ":0.0

Esse Xorg ta cade vez pior.... sad  Aqui tb dá esse warning.


344910.png

Offline

#10 22/02/2009 22:03:54

J0N47H45
Membro
Registrado: 03/08/2008
Mensagens: 26

Re: Xlib: extension "Generic Event Extension" missing on display ":0.0

acho q é geral então esse erro q aparece, né.. aqui tb rola isso..

Offline

#11 23/02/2009 11:22:06

Alexdsan
Membro
Registrado: 10/06/2007
Mensagens: 110

Re: Xlib: extension "Generic Event Extension" missing on display ":0.0

Tem este erro pq a versão atual não tem suporte para o XGE, somente a versão 1.6 terá suporte, é aguardar sair a versão estável.

"Aqui também aparece essa mensagem de erro da Xlib, mas, pelo que eu andei lendo, pode ser ignorada."

Ignorada tem que ser, é a solução, mas que é chato, isto é, programando em java, quando compilo e executo, sai a mensagem na saida do console uhauauuahuhauhua

vlw


Arch Linux x86_64 =)

Offline

Rodapé do site