Você não está autenticado.

Anúncio

ANTES DE QUALQUER UPDATE NA DISTRIBUIÇÃO LEIA ESTE LINK PARA INSTRUÇÕES DETALHADAS: http://archlinux-br.org/noticias/212/

Por favor, leia as regras do fórum antes de usá-lo.

#1 16/04/2012 18:35:34

arniecobra
Membro
Registrado: 13/11/2010
Mensagens: 182

[RESOLVIDO] erro libgtk-x11-2.0.so.0 não abre firefox chromium

Olá pessoal. Instalei o Arch 64bits em uns computadores da empresa mas não funciona nem o firefox nem o chromium. Abrindo o firefox pelo terminal ele dá um erro

"/usr/lib/libgtk-x11-2.0.so.0 undefined symbol: g_datalista_get_data"

Procurei diversas soluções na internet. Uma delas inclusive me mando dar um "pacman -S filesystem --force" que quebrou meu arch e agora ele não dá mais boot, trava e me joga para o shell.

Alguém tem alguma seugestão, de preferência que não tenha que instalar pacotes do multilib? rsss

Última edição por arniecobra (02/05/2012 23:08:49)

Offline

#2 16/04/2012 19:29:57

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 668

Re: [RESOLVIDO] erro libgtk-x11-2.0.so.0 não abre firefox chromium

http://www.archlinux-br.org/noticias/175/

Parace ser um problema com /etc/profile.d/locale.sh

Faça um backup antes
sudo cp  /etc/profile.d/locale.sh  /etc/profile.d/locale.sh.bkp

Remova o arquivo locale.sh
sudo rm  /etc/profile.d/locale.sh

Atualize o pacman

sudo pacman -Syu

E veja se funciona?

Faça alguns testes..

Se estiver tudo ok.

Remova o backup do do arquivo

sudo rm  /etc/profile.d/locale.sh.bkp

Última edição por swatquest (16/04/2012 19:35:21)

Offline

#3 17/04/2012 18:22:29

arniecobra
Membro
Registrado: 13/11/2010
Mensagens: 182

Re: [RESOLVIDO] erro libgtk-x11-2.0.so.0 não abre firefox chromium

Eita, o pacman não quer atualizar o sistema

erro: falha em submeter  a transação
arquivos conflitantes
filesystem: /etc/mtab já existe no sistema de arquivos
ocorreram erros e nehum pacote foi instalado

tentei remover o mtab mas não deu certo também

Última edição por arniecobra (17/04/2012 18:24:57)

Offline

#4 17/04/2012 21:01:25

niquelnausea
Membro
De: Bandeirantes - PR
Registrado: 28/09/2010
Mensagens: 84

Re: [RESOLVIDO] erro libgtk-x11-2.0.so.0 não abre firefox chromium

Offline

#5 18/04/2012 02:40:26

arniecobra
Membro
Registrado: 13/11/2010
Mensagens: 182

Re: [RESOLVIDO] erro libgtk-x11-2.0.so.0 não abre firefox chromium

entao, quando segui esse procedimento quebrou meu sistema todo. Esse problema eu to tentando resolver também em outro tópico rss

http://forum.archlinux-br.org/viewtopic … 319#p24319

Offline

#6 19/04/2012 13:04:30

rdfreitas
Membro
De: São Paulo - SP
Registrado: 06/07/2009
Mensagens: 436

Re: [RESOLVIDO] erro libgtk-x11-2.0.so.0 não abre firefox chromium

arniecobra escreveu:

Eita, o pacman não quer atualizar o sistema

erro: falha em submeter  a transação
arquivos conflitantes
filesystem: /etc/mtab já existe no sistema de arquivos
ocorreram erros e nehum pacote foi instalado

tentei remover o mtab mas não deu certo também

Tem certeza que leu  a noticia ?


arch x64 + Openbox
Email: rdfreitas@archlinux.com.br

Offline

#7 19/04/2012 23:18:21

arniecobra
Membro
Registrado: 13/11/2010
Mensagens: 182

Re: [RESOLVIDO] erro libgtk-x11-2.0.so.0 não abre firefox chromium

rdfreitas, tenho certeza que li a notícia sim, o problema é que quando executei o procedimento meu sistema parou de iniciar, conforme indiquei no outro link.

No entanto, reinstalei e repeti o procedimento e dessa vez deu tudo certo, Não sei porque deu pau quando instalei o filesystem na primeira vez. Mas instalando o filesystem e depois removendo o locale.sh deu tudo certo.

Offline

#8 20/04/2012 19:10:00

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 668

Re: [RESOLVIDO] erro libgtk-x11-2.0.so.0 não abre firefox chromium

arniecobra

tentei remover o mtab mas não deu certo também

Não remova...
http://www.archlinux-br.org/noticias/176/
Na mensagem

É altamente recomendável não usar o --force ou -f, por não serem seguros.
No entanto, neste caso em particular se faz necessário, pois deletar manualmente o /etc/mtab pode quebrar o pacman.

Informações sobre  /etc/mtab e /proc/mounts
http://web.mit.edu/rhel-doc/4/RH-DOCS/r … NTING-MTAB

Criar o /etc/mtab- (ambiente chroot)
http://www.gentoo.org/doc/pt_br/handboo … =1&chap=10
grep -v rootfs /proc/mounts > /etc/mtab

Última edição por swatquest (20/04/2012 19:18:17)

Offline

#9 02/05/2012 23:12:21

arniecobra
Membro
Registrado: 13/11/2010
Mensagens: 182

Re: [RESOLVIDO] erro libgtk-x11-2.0.so.0 não abre firefox chromium

galera, resolvido mesmo.

Era preciso atualizar o 'filesystem --force. O grande problema é que eu tinha removido antes o mtab manualmente, isso quebrou meu sistema e só consegui resolver reinstalando o arch de novo.

Offline

#10 03/05/2012 14:38:30

sistematico
Membro
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 804
Website

Re: [RESOLVIDO] erro libgtk-x11-2.0.so.0 não abre firefox chromium

Resumo: Não leu.

Offline

Rodapé do site