Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#2 Re: Usando o Arch Linux » Steam não abre no Arch linux » 25/06/2016 00:31:08

Muito obrigado amigo, quando tu postou aqui eu já tinha resolvido o problema. kkk
Mas obrigado mesmo assim, editei minha resposta de cima com a maneira que resolveu meu problema pra quem precisar.

#3 Re: Usando o Arch Linux » Steam não abre no Arch linux » 24/06/2016 05:38:28

Já chequei todos os drivers amigo, segui todos os tutoriais e nada, mas resolvi a primeira parte do problema, executando o Steam dava:

[[email protected] ~]$ steam
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
Running Steam on arch  64-bit
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Existem dois erros aí, o primeiro é um erro na linha 161 e o segundo o "libGL". No primeiro caso, dá um erro na linha 161 do "steam.sh", pois tenta iniciar "VERSION_ID" de "/etc/os-lançamento", o Arch possui "/etc/os-lançamento", mas ele não tem um "VERSION_ID".
A solução é alterar a linha 160 de "steam.sh", de:

elif [ -f /etc/os-release ]; then


para algo como isto:

elif $(grep 'VERSION_ID' /etc/os-release > /dev/null 2>&1); then


Isso faz com que "steam.sh" passe a usar o fallback genérico.
Depois de corrigir esse erro acima, pode acontecer de dar esse erro abaixo:

/home/runningdroid/.local/share/Steam/steam.sh: line 710: LD_LIBRARY_PATH: unbound variable


Geralmente "LD_LIBRARY_PATH" não é definido por padrão, então para corrigir isso vamos mudar a linha 710, de:

export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/lib32"


para

export LD_LIBRARY_PATH="${LD_LIBRARY_PATH:-/usr/lib}:/usr/lib32"


Para acessar "steam.sh" basta seguir esse caminho "/home/USUÁRIO/.local/share/Steam" e abrir o steam.sh com o geany para editar as linhas. Eu usei esse processo porque estou com Gnome, não sei se o caminho é o mesmo nas outras interfaces. Mas o princípio é o mesmo e funcionou pra mim. Para o segundo erro, o da libGL, eu achei a solução na wi do arch, estava em inglês então traduzir pra facilitar pra vocês. Quem quiser ir lá mesmo assim, o link está lá no final.

O erro de libGL se dá porque a Steam instala suas próprias versões mais antigas de algumas bibliotecas coletivamente chamadas de "Steam Runtime". Pode acontecer dessas bibliotecas do Steam entrar em conflito com as bibliotecas incluídas no Arch Linux. Para resolver esse problema, você pode forçar a Steam para usar as versões do sistema (aquelas instalados pelo pacman ). Há duas maneiras de fazer isso:

1 - Usando o vinculador dinâmico, rode esse comando no terminal para fazer a Steam rodar imediatamente:

LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' steam


Se você quiser usar esse método em um atalho .desktop, você pode usar este comando no Exec=campo.

Exec=env LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' /usr/bin/steam %U



2 - Excluindo as bibliotecas de tempo de execução, Execute este comando para excluir as bibliotecas de execução conhecidas por causar problemas no Arch Linux:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

Se o comando acima não funciona, execute o comando acima novamente, em seguida, executar este comando.

find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete


Eu rodei o primeiro comando da opção 1 e a Steam rodou na hora, mas pelo terminal. O segundo comando da opção 1 eu não entendi, então parti pra opção dois e o primeiro comando já fez a Steam funcionar pelo atalho.
Link da wi: https://wiki.archlinux.org/index.php/St … leshooting

#4 Re: Usando o Arch Linux » Steam não abre no Arch linux » 23/06/2016 22:50:02

Acabei de chegar no Arch, meu sistema está todo funcionando, apenas a Steam que não roda de jeito nenhum. Já segui vários tutoriais na internet e até agora não consegui rodar. Olhem o erro:

[[email protected] ~]$ steam
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
Running Steam on arch  64-bit
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Alguém tem alguma dica pra resolver esse problema?

#5 Re: Pacman, ABS, AUR & problemas de atualização » Interface gráfica para Pacman e AUR » 22/06/2016 11:04:58

Obrigado. Me ajudou muito com essas dicas. Resolvido meu problema, nem preciso de interface mais. kkk

#6 Re: Dúvidas gerais » ERRO NO ARCH DEMORA 1min e 30s PARA INICIAR » 20/06/2016 12:22:36

Tenta remover a Interface WIFI, remove o wifi e depois instala de novo, vê se isso resolve.

#7 Pacman, ABS, AUR & problemas de atualização » Interface gráfica para Pacman e AUR » 18/06/2016 14:54:53

Filipe Araújol
Respostas: 6

Sou novo no Arch e uma interface gráfica para o Pacman e o AUR me ajudaria bastante. Já segui alguns tutoriais de como instalar o PacmanXG, Wakka, Octopi, gtkpacman, mas tanto pelo comando pacman quanto pelo comando yaourt dá o erro "alvo não encontrado". Se alguém tiver uma interface, uma dica ou um tutorial, por favor posta aqui.

#9 Dúvidas gerais » ERRO NO ARCH DEMORA 1min e 30s PARA INICIAR » 14/06/2016 22:02:56

Filipe Araújol
Respostas: 6

Eu sou novo no Arch, instalei ontem na verdade. depois de uma vida toda no Windows. Li sobre o Arch e quero migrar definitivamente depois que dominar o sistema, eu tenho o Windows 10 e resolvi instalar o Arch em dual boot pra aprender mais. Fiz a instalação normalmente, configurei gnome-extra etc. O Arch está funcionando perfeitamente, internet, som, e todo o resto sem nenhum problema. O fato é que quando inicia, escolho o arch no grub, e quando o sistema começa carregar dá o seguinte erro:

“starting version 230
/dev/sda3: clean,239978/122388 files, 37415899/48937984 blocks
A start job is running for sys-subsystem-net-devices-eth0.device (0s / 1min 30s)".

O contador vai de 0s até 1min e 30s e depois acontece isso:

"starting version 230
/dev/sda3: clean,239978/122388 files, 37415899/48937984 blocks
[   TIME   ] Timed out waiting for device sys-subsystem-net-devices-eth0.device.
[DEPEND] Dependency failed for dhcpcd on eth0.
[     OK    ] Reached target Network.
                 Starting Permit User Sessions…
[     OK    ] Started Permit User Sessions.
[     OK    ] Reached target Multi-User System.
                  Starting GNOME Display Manager... 
[     OK    ] Starting GNOME Display Manager.
[     OK    ] Reached target Graphical Interface.”

Depois disso entra no gnome normalmente com tudo funcionando.

Procurei mas não achei nada parecido na internet, alguém poderia me ajudar? Não sei se é problema de partição, problema de rede ou outra coisa. Meu HD está configurado da seguinte maneira, sda1 criado pelo windows, sda2 o windows em sí, sda3 o arch e sda4 swap linux. Grub tá mostrando tanto windows quanto arch no menu e pro caso de rede, quando o arch inicia, tanto cabeada quanto wifi funcionam perfeitamente de primeira. Quero resolver esse problema porque é chato esperar 1min e 30s toda vez que ligo.

Rodapé do site

Rodando com FluxBB