Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 Re: Usando o Arch Linux » skype e google earth no Arch64, tem como? » 24/02/2008 14:08:25

Se não me engano, o google-earth não é possível... *acho*!

O Skype rola normal aqui no 64bits. Precisa das lib32- mas roda tranquilo!


Abraço!

#3 Re: Usando o Arch Linux » [RESOLVIDO] pane no Arch quando pressionei ctrl+alt+bkspace!! » 14/02/2008 22:13:38

Eu mesmo nunca sofri desse problema, porém, parece que é bem comum viu.

Encontrei algumas coisas aqui ó: http://virtual01.lncc.br/~licht/linux/s … awing.html

Qual gerenciador de login você usa ? Talvez ele tenha dado problema quando você matou o processo do X.


Abraço!

#4 Re: Usando o Arch Linux » [Resolvido] Arch 64, Flash e Java » 14/02/2008 22:07:59

@saci-perere

Se não me engano, você tem um arquivo ae chamado: /etc/pacman.conf.pacnew . Se tiver, coloque ele como pacman.conf e o pacman.conf como pacman.conf.old e rode um pacman -Sy

Sobre o nspluginwrapper, cole a saída do comando:

# find / -name nspluginwrapper

Abraço!

#5 Re: Usando o Arch Linux » [Resolvido] Arch 64, Flash e Java » 11/02/2008 19:06:54

saci-perere,

Pois é! Eu ia comentar sobre esse erro no seu pacman.conf... o current foi desativado faz tempo! O ideal mesmo, é que você rode um:

# pacman -Sy pacman

e depois um:

# pacman --version

Com isso, provavelmente ele terá que retornar: v3.1.x (o meu é 3.1.1) daí estando up-to-date, rode um:

# pacman -Sy

e instale aqueles pacotes que citei no meu primeiro replay deste post, as lib32 lá... e tente novamente instalar o nspluginwrapper !


Abraço!

#6 Re: Usando o Arch Linux » [Resolvido] Arch 64, Flash e Java » 10/02/2008 11:12:12

@saci-perere,

Várias coisas podem acontecer:

1. Seu Arch é 64bits né ? smile

2. Talvez um dos pacotes que você baixou e compilou com makepkg -ci --asroot podem não ter sido instalado por algum problema de dependencia e etc., neste caso, precisaria da saída do makepkg para vermos o que pega. Melhor, nos dê a saída do comando:

$ pacman -Q | grep -i nsplugin

Terá que ser similar a minha ó:

pacman -Q | grep -i nsplugin
nspluginwrapper 0.9.91.5-3
nspluginwrapper-flash 9.0.115.0-1

PS: o comando acima lista os pacotes que tenham "nsplugin" em seu nome smile Serve para você buscar por pacotes instalados em seu Arch Linux!


Abraço!

#7 Re: Instalação e configuração do sistema básico » Arch impressoes! » 10/02/2008 11:08:51

saci-perere

É como o leoarcher falou. Sua placa é uma broadcom logo, precisará do ndiswrapper para fazê-la funcionar. A Dell vende placas de wifi com o nome ficticio "Dell wireless", mas o chip delas todas são broadcom. funciona perfeitamente, mas precisa do ndiswrapper.

Abraço!

#8 Re: Hardware e notebooks » [Notebook] Vostro 1400 - compatibilidade com o Arch » 10/02/2008 11:06:52

marcoprimeiro,

Funcionou tudo normal no meu Vostro 1400 com Arch Linux. Tenho um amigo que tem o Vostro 1500 e funciona tudo ok também.

Veja: eu comprei o meu sem a camera embutida hahah, então não sei quanto andas isso. O que posso afirmar é que o microfone interno não tem suporte ainda no vostro 1400, só que me parece que no Vostro 1500 tem pois o chipset é diferente. Porém, no alsa 1.0.16 o mic interno irá funcionar no vostro 1400 smile

#9 Re: Usando o Arch Linux » [Resolvido] Arch 64, Flash e Java » 08/02/2008 18:01:09

hahaha... me desculpe, confundi os pacotes smile Mas é isso ae! Só usar seu flash agora.

Quanto ao Java no browser, sorry, mas eu mesmo nem uso... mas talvez você encontre algo no Wiki (http://wiki.archlinux-br.org)


Abraço!

#10 Re: Usando o Arch Linux » [Resolvido] Arch 64, Flash e Java » 08/02/2008 17:24:54

Felipe,

Você mesmo colocou o erro e a resposta dele big_smile

[[email protected] nspluginwrapper]# dir
nspluginwrapper.install  PKGBUILD.htm  rpmextract.sh

[[email protected] nspluginwrapper]# makepkg -ci --asroot
==> ERRO: PKGBUILD não existe.
[[email protected] nspluginwrapper]#

O firefox salvou como PKGBUILD.htm sendo que é PKGBUILD apenas. wink


Abraço

#11 Re: Usando o Arch Linux » [Resolvido] Arch 64, Flash e Java » 08/02/2008 11:36:20

Olá, Felipe!

De acordo com o Wiki do Arch Linux em inglês (http://wiki.archlinux.org/index.php/Ins … _on_Arch64) você precisa fazer o seguinte:

1. Instalar os pacotes 32bits de algumas várias aplicações: (precisa do repositório community habilitado)

pacman -Sy --asdeps gtk2 lib32-atk lib32-cairo lib32-expat lib32-fontconfig lib32-freetype2 lib32-gcc-libs lib32-glib2 lib32-glibc lib32-gtk2 lib32-libice lib32-libpng lib32-libsm lib32-libx11 lib32-libxau lib32-libxcb lib32-libxcursor lib32-libxext lib32-libxfixes lib32-libxft lib32-libxi lib32-libxinerama lib32-libxmu lib32-libxrandr lib32-libxrender lib32-libxt lib32-pango lib32-pcre lib32-zlib libxt util-linux-ng lib32-alsa-lib

2. Agora, baixe esses dois pacotes do AUR.

De forma simples, acesse o primeiro link acima: clique no link "files" e salve todos os arquivos que estiverem dentro do diretório. Crie um diretório com o nome do pacote na sua $HOME e salve dentro... depois mova ambos pacotes (cada link é um pacote) para /var/abs/local

Vai ficar mais ou menos assim:

/var/abs/local/nspluginwrapper
/var/abs/local/nspluginwrapper-flash

Agora entre no primeiro diretório e rode:

# makepkg -ci --asroot

Se ele der erro, provavelmente será pedindo arquivos não instalados. Neste caso é só baixar o pacote que ele reclama a falta com o pacman mesmo.
(Tem gente que vai querer me matar por estar sugerindo rodar makepkg como root, mas não tem tanto problema - nunca me ferrei hahaha)

Dando certo no primeiro, volte um diretório e entre no segundo pacote (/var/abs/local/nspluginwrapper-flash) e dê permissão de execução no arquivo rpmextract.sh (chmod +x rpmextract.sh). Isso é fundamental, caso contrário não dará certo! Depois, faça a mesma coisa que fez no pacote anterior:

# makepkg -ci --asroot

Dando tudo certo, saia do root e como usuário comum rode:

$ nspluginwrapper -v -a -i

Com isso ele irá instalar o plugin do flash para seu Gecko (Firefox) e Opera (acho eu hehe)

Reinicie o firefox e voilá! Flash funcionando.

Observações:

1. Aqui quando a página tem flash e o plugin começa a trabalhar, o uso do proc aumenta um pouco até sairmos da página.
2. As vezes (raras vezes) o Firefox trava neutral
3. O plugin estará emulado a 32bits no Firefox 64bits.
--

Sobre o Java, eu nem instalei pois não achei o "custo vs beneficio" ideal para instalar mais e mais bibliotecas 32bits no meu Arch64. Com isso, fiquei apenas sem o plugin Java no browser, mas como eu não uso para nada, nem sinto falta smile - Java no desktop rola normal com o jre/jdk nativo para 64 bits!

Espero que consiga wink


Abraço!

[1] Referência: http://wiki.archlinux.org/index.php/Ins … _on_Arch64

#12 Re: Instalação e configuração do sistema básico » Arch impressoes! » 07/02/2008 18:47:08

Sobre o teclado, infelizmente eu não sei te informar qual seria o mais adequado pra ti pois o meu é abnt2 com cedilha normal ...

Sobre o wireless, qual sua placa wifi ? Bom, para conectar na rede wifi, você precisa de um front-end que escaneia e conecta a redes wifi. Um bom é  o wifi-radar (feito em python)... caso use KDE tem o kwifimanager.

# pacman -Sy wifi-radar

Inicia ele como root que fica tudo lindo. Conecte-se a rede e veja se funciona big_smile O mais complexo aconteceu: foi detectada sua placa wifi.

HD e DVD ok né ?


Abraço!

OBS: sempre que for jogar uma saída de algo no fórum, coloque entre as tags "quote"

tipo assim

Assim fica mais fácil de ler big_smile

#13 Re: Off-Topic » Qual distro você usaria como distro secundária depois do Arch Linux? » 07/02/2008 18:15:07

Windows Vista.

Pensei que a galera ia reclamar, xingar ou esperniar, mas pelo visto hiuaeiae... na real mesmo eu usaria: Slackware.

#14 Re: Instalação e configuração do sistema básico » Arch impressoes! » 06/02/2008 12:16:47

Seja bem-vindo a comunidade saci-perere! O Arch Linux é realmente sensacional smile

bom, vamos ao que interessa: sua pós instalação.

1. Acentuação do teclado.
Diz uma coisa, no shell (fora do X) você consegue digitar coisas acentuadas ? tipo "éééé" ? Talvez o problema seja apenas no xorg.conf. Veja a sessão do meu teclado no Xorg.conf:

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"

    Option      "XkbLayout" "br"
    Option        "XkbModel"  "abnt2"
EndSection

Lembre-se: após fazer a alteração no arquivo (/etc/X11/xorg.conf) reinicie o X.


2. Sua partição de dados

Acho que você esqueceu de colocar lá no fstab o caminho da onde sua partição de dados será montada. Veja:

/dev/sda2 ext3 defaults 0 1

Tente assim:

/dev/sda2 /compartilhados ext3 defaults 0 1

e depois de alterar o arquivo /etc/fstab crie o diretório como root: # mkdir /compartilhados
Para montar, use: # mount /dev/sda2


3. DVD não lê

Bom, precisamos de mais detalhes... que tipo de mídia dá o erro era CD de música, DVD... tentou montar como root ? As vezes, é problema de permissão! Para resolver isso, tente:

# gpasswd -a seuUser optical
# gpasswd -a seuUser storage
# gpasswd -a seuUser wheel
# gpasswd -a seuUser hal
# gpasswd -a seuUser dbus

Boa sorte wink

#15 Re: Usando o Arch Linux » Opera não mostra flash [RESOLVIDO] » 31/01/2008 17:52:51

Opera é mais leve. Pra desenvolvimento ele não é tão bom quanto o firefox (pois FF tem plugins excelentes pra web developer), mas tirando isso, o Opera é mais leve... smile

#16 Re: Ambientes gráficos » [Resolvido] KDEmod e Arch64 - ainda com problemas » 29/01/2008 12:17:15

Tinha um muito bom do Memphix (acho que é assim que se esscreve o nick dele)... ele descreveu passo-a-passo a instalação do Arch Linux 64bits... agora se fala do KDEmod apenas, tem um do Hugo Dória...

Sim, vou atualizar smile


Abraço!

#17 Re: Ambientes gráficos » [Resolvido] KDEmod e Arch64 - ainda com problemas » 28/01/2008 21:28:56

Exato! Você poderá usar o link oficial do KDEmod em 64bits smile

#18 Re: Ambientes gráficos » [Resolvido] KDEmod e Arch64 - ainda com problemas » 28/01/2008 11:51:40

@havocz

O kdemod para 64bits foi arrumado poucos dias após meu post por lá smile
Agora é possível instalar tudo normalmente!

Para ter um sistema funcional em 2 dias é perfeitamente possível! Instale o Arch64 na máquina, e após o primeiro boot, já instale o KDEmod! smile Depois enquanto você baixa os demais pacotes (navegadores, programas de sua utilidade em especial e etc) você tem tempo para ir personalizando o ambiente KDE com temas, cores, icones, widgets (com superkaramba) e etc...

Aqui tudo funciona normal com 64bits! Sem nenhum pau nem nada... a única excessão é para o microfone embutido que tenho no note... o alsa ainda não possui um driver especial para a placa (Sigmatel alguma coisa) e então temos que usar a "genérica" hda-intel que funciona em vários modelos de pl de som smile

Fora o mic, tudo funciona perfeitamente! wifi, bluetooth, rede, vídeo, som, aplicações e zaz!
ah! Meu Firefox não tem JRE, mas como não uso o Java no browser mesmo, nem faz falta! O flash é emulado 32bits, também é só. 6 dúzia de bibliotecas lib32 resolvem o problema... para funcionar o JRE 32bits precisaria de várias lib32 daí nem compensa!

Tenta instalar ae e qualquer problema vai postando que vamos tentanto te ajudar!


Abraço!

#19 Re: Usando o Arch Linux » [RESOLVIDO] Erro ao montar CD » 27/01/2008 12:17:15

Yeah!

hal e depois o dbus dá uma mensagem de fail no dbus, mas aparentemente é só isso que ocorre... não sei qual o ideal, mas creio que colocando: (dbus hal) ou então (hal) [como eu faço aqui] está certíssimo smile

#20 Re: Ambientes gráficos » [Resolvido] KDEmod e Arch64 - ainda com problemas » 26/01/2008 11:13:47

Pois é! Rolei uma mensagem no fórum do kdemod e me disseram que a versão 64bits ainda não foi mexida... o jeito por enquanto é esperar, pois parece que o kdemod não é o único a conflitar com o novo pacman neutral Muita coisa ainda precisa ser mexida para ficar estável como era antes!

#21 Re: Instalação e configuração do sistema básico » Naum consigo subir o X » 26/01/2008 11:12:10

andreg,

Nada do vídeo subir ? Seu hardware é igual ao meu (pela sua descrição)... então não pode ser um problema de suporte, creio que seja problema nos pacotes mesmo neutral Se for isso, não tem o que fazer a não ser esperar updates!

#22 Re: Instalação e configuração do sistema básico » Naum consigo subir o X » 25/01/2008 23:38:29

Sim, instalei o xf86-video-intel. Não precisei recompilar meu kernel nem nada além do velho X --configure!
Acho que os pacotes do Arch estão ficando doidos... muita instabilidade no pacman neutral


Abraço!

#23 Ambientes gráficos » [Resolvido] KDEmod e Arch64 - ainda com problemas » 25/01/2008 13:42:27

hlegius
Respostas: 11

Salve!

É impressão minha ou o pessoal do KDEmod esqueceu de arrumar o conflito do KDEmod com o KDE normal na compilação 64bits ? Parece que tem alguns dias que foi arrumado o mesmo problema na compilação 32bits, mas a compilação 64bits não teve updates neutral Tá acontecendo o mesmo com vocês usuários de KDEmod ?

--
Está normalizado novamente. KDEmod 64bits está funcionando sem conflitos com o novo pacman smile

#24 Re: Instalação e configuração do sistema básico » Naum consigo subir o X » 25/01/2008 13:36:45

Opa, André!

Para enviar logs e códigos extensos temos disponível hoje o pastebin no Arch Linux br, daí fica mais fácil, ou então coloque o código entre quote no próprio fórum big_smile

bom, vamos ao que interessa... tenho o mesmo hardware que você, e estou com o X rodando aqui neste momento! Para facilitar, botei a saída do meu Xorg.conf no paste, segue link:

http://paste.archlinux-br.org/50


Detalhe o defaultDepth é 24 com resolução "1280x800", talvez um erro de Vblank pode ser isso. Olhe o meu e se preciso, copie-o (salvando o seu original antes) e teste!


Abraço!

#25 Re: Pacman, ABS, AUR & problemas de atualização » Pacman ñ resolvendo conflitos... [Resolvido] » 22/01/2008 21:18:21

Yeah!

Só para constar, problema similar ainda ocorre com a versão 64 bits. Parece que o povo do KDEmod ainda não arrumou os repositórios da compilação x86_64 smile

Rodapé do site

Rodando com FluxBB