Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 08/10/2008 23:19:05

cezar
Membro
Registrado: 15/07/2006
Mensagens: 274

(RESOLVIDO!)wireless não está conectando no Arch 64

Olá a todos, parti agora para configurar wireless no meu Arch64 - Achei bem interessante este artigo e segui os passos indicados, mas algo de errado houve quando fui fazer o perfil de rede wireless. Fiquei em dúvida onde era o local correto para a key (utilizo wireless wpa) etc etc. Mas com o netcfg estou conseguindo conectar à internet mas à cabeada, por ora nada de wireless. Coloquei um comentário-pergunta (rsrs) no site do artigo, mas se alguem puder dar uma força, agradeço, a dúvida é como  configurar o perfil wireless, pois fiz todas as modificações para a cabeada (eth0) e tudo deu certo. Minha placa é uma d-link  Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband. Se for o caso de configurar de outra maneira, sem problema, desfaço o netcfg :-) Obrigado a todos.


"Perfis de rede com o netcfg
April 25th, 2008 | by cecampos |

Sei que existem gerenciadores de rede muito bons, com interfaces gráficas, e aquela frescura toda. Até tentei me acostumar com eles, testei o (k)networkmanager e o wicd mas para mim não há nada como a simplicidade de bons shell scritps. E foi aí que descobri mais uma maravilha do Arch Linux: o pacote netcfg. Com ele é possível gerenciar vários perfis de rede (cabeado dinâmico, fixo, wireless wep, wpa, etc.) permitindo que você coloque-os em ordem de preferência no boot, ou então faça essa escolha através de um menu.

Vamos ao que interessa:

Instale o pacote:

# pacman -Sy netcfg

Agora verifique no diretório /etc/network.d/examples os modelos de perfil de rede que acompanham o pacote, eu por exemplo utilizei como base o ethernet.example, e copiei-o para o /etc/network.d

# cp /etc/network.d/examples/ethernet.example /etc/network.d/dhcp-eth

Os exemplos são muito fáceis de personalizar, veja como ficou o meu:

[[email protected] network.d]$ more dhcp-eth
SCAN=”yes”
CONNECTION=”ethernet”
DESCRIPTION=”A very basic ethernet profile, using dhcp”
INTERFACE=eth0
IP=”dhcp”
DHCP_TIMEOUT=10

Criei também um perfil para a rede wireless WPA no meu serviço, e o coloquei no mesmo diretório.

Agora, a última parte, a configuração do rc.conf:

A configuração das interfaces não é mais necessária, logo comentei:

#lo=”lo 127.0.0.1?
#eth0=”dhcp”
#ath0=”dhcp”
#INTERFACES=(lo eth0 ath0)

Observação: não é necessário criar um perfil para a interface de loopback pois ela é inicializada automaticamente pelo rc.sysinit

Decomentei a linha de NETWORKS:

NETWORKS=(dhcp-eth wireless-ud)

Lembrando que dhcp-eth e wireless-ud são os nomes dos perfis (arquivos) salvos no /etc/network.d e serão executados na ordem que aparecem no array NETWORKS.

Por último uma alteração no DAEMONS, remova o “network” e adicione o “net-profiles” a minha linha ficou assim:

DAEMONS=(@syslog-ng @crond @cpufreq dbus acpid hal alsa slmodem-alsa @net-profiles @gpm @sshd @cups @noip @iptables @atieventsd @xinetd kdm)

Com esse esquema, no próximo boot o sistema tenta por 10 segundos (tempo configurado como timeout do perfil) estabelecer conexão de rede com o perfil dhcp-eth e caso não consiga passa para o próximo perfil. Se você quiser fazer essa escolha manualmente, no array NETWORKS escreva a palavra “menu” no lugar dos perfis, deixando-a assim:

NETWORKS=(menu)

Se você quiser/precisar alterar as configurações de rede em tempo real, não há problemas, o netcfg serve para isso também, veja o help:

[[email protected] ~]$ sudo netcfg2
netcfg v2.0.6
Usage:
Start specified profile: netcfg profile
Other functions: netcfg argument profile
Arguments:
-c, check-iface Do not start profile if interface is already up
-d, down Take specified profile down
-a, all-down Take all active profiles down
-i, iface-down Take down profile active on specified interface
all-resume Resume previously suspended profiles and reconnect them
all-suspend Store a list of current running profiles and suspend them

Ou seja, você pode utilizá-lo para baixar ou levantar qualquer um dos perfis configurado!

Baixando a configuração cabeada e subindo o wireless (no meu caso)

# netcfg2 -d dhcp-eth
# netcfg2 wireless-ud

Há ainda no AUR e no repo archlinux.fr uma ferramenta chamada “archassistant” que é uma GUI em QT de configuração de vários arquivos do Arch, inclusive gerenciando os perfis de rede, caso você prefira uma interface gráfica."

Última edição por cezar (09/10/2008 23:51:56)

Offline

#2 08/10/2008 23:20:08

cezar
Membro
Registrado: 15/07/2006
Mensagens: 274

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

desculpem a fonte do site é : http://cecampos.archlinux-br.org

Offline

#3 09/10/2008 09:46:37

leoarcher
Admin
De: Arapiraca - AL
Registrado: 13/07/2006
Mensagens: 1.256
Website

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

Aproveitando aqui...

Também estou com problemas (mas no i686)...
Se faço na mão usando iwconfig retornar esse erro:

Error for wireless request "set ESSID"

Se tento usar o netcfg2, dá esse problema:

home-wireless up - Network unavailable

meu arquivo: home-wireless

CONNECTION="wireless"
INTERFACE=ath0
SCAN="yes"
SECURITY="wpa"
ESSID="Leandro SA"
KEY="12345"
IP="dhcp"
TIMEOUT=10

[email protected] ~ $ lspci
ath0      Link encap:Ethernet  HWaddr 00:22:69:20:F4:AA 
          inet6 addr: fe80::222:69ff:fe20:f4aa/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth0      Link encap:Ethernet  HWaddr 00:1E:68:BB:54:93 
          inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21e:68ff:febb:5493/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:899 errors:0 dropped:500443943 overruns:0 frame:0
          TX packets:988 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:922430 (900.8 Kb)  TX bytes:328068 (320.3 Kb)
          Interrupt:17

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:42 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2180 (2.1 Kb)  TX bytes:2180 (2.1 Kb)

wifi0     Link encap:UNSPEC  HWaddr 00-22-69-20-F4-AA-00-00-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2183 errors:0 dropped:0 overruns:0 frame:116
          TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:280
          RX bytes:264658 (258.4 Kb)  TX bytes:2070 (2.0 Kb)
          Interrupt:18

Esse é o meu lspci, segui o tutorial que foi falado acima... Se alguém tiver uma solução fico grato. E sem contar que se botar wifi0 no lugar do ath0, ele não funfa!

Última edição por leoarcher (09/10/2008 10:01:35)


Se copiarem, forneçam a fonte de origem. Se alguma resposta te ajudou a solucionar o problema, por favor edite o título do tópico e adicione "[Resolvido]" a ele (sem as aspas). Obrigado!

asa_tempo.jpg

Offline

#4 09/10/2008 10:13:45

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

O profile do Leandro parece estar correto. Se não estiver funcionando, provavelmente a placa de rede de vocês tem algum bug no driver e precisa de "quirks" pra funcionar. Na wiki do Arch tem uma lista:

http://wiki.archlinux.org/index.php/Net … d_later.29

Offline

#5 09/10/2008 10:45:41

cezar
Membro
Registrado: 15/07/2006
Mensagens: 274

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

MInhas configurações estão assim, mas não estou conseguindo conexão. Minha placa de rede é uma d-link  Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband
Fico em dúvida com relação à ath0 e wlan0. Seria isso? Li que em se tratando de placa como a acima o correto seria ath0. Fico na dúvida...

Offline

#6 09/10/2008 10:46:38

cezar
Membro
Registrado: 15/07/2006
Mensagens: 274

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

assim estão as configurações:

bash-3.2# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11  ESSID:"MINHA_REDE" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

bash-3.2# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1B:FC:E8:39:35 
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21b:fcff:fee8:3935/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1455 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1333 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1413631 (1.3 Mb)  TX bytes:255060 (249.0 Kb)
          Interrupt:19

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:22 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1180 (1.1 Kb)  TX bytes:1180 (1.1 Kb)

Última edição por cezar (09/10/2008 10:47:20)

Offline

#7 09/10/2008 11:43:11

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

Se aparece "wlan0" no iwconfig, então é wlan0

Offline

#8 09/10/2008 12:08:51

cezar
Membro
Registrado: 15/07/2006
Mensagens: 274

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

ok mas ha mais um detalhe alem dessa placa (PCI) tem outra onboard (RTL8187) que esta desativada no setup valeu

Offline

#9 09/10/2008 15:59:54

leoarcher
Admin
De: Arapiraca - AL
Registrado: 13/07/2006
Mensagens: 1.256
Website

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

Consegui resolver...

Usei networkmanager (gnome-network-manager). wicd, etc...

Só com o netcfg2 que consegui usar satisfatoriamente a ethernet e a wireless... A wireless deu um pouco de trabalho, por não saber que precisava do wpa_supplicant, configurei e foi de boa.

De resto, valeu a quebra de cabeça pra deixar funfando...

Só descobri que era por conta do wpa_supplicant, com a ajuda do underguiz, valeu pela ajuda. big_smile


Se copiarem, forneçam a fonte de origem. Se alguma resposta te ajudou a solucionar o problema, por favor edite o título do tópico e adicione "[Resolvido]" a ele (sem as aspas). Obrigado!

asa_tempo.jpg

Offline

#10 09/10/2008 19:00:23

cezar
Membro
Registrado: 15/07/2006
Mensagens: 274

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

Leoarcher se nao for um abuso vc poderia fazer a gentileza de repassar a dica do wpa_supplicant? Basta configurar ele e pronto? Valeu!

Offline

#11 09/10/2008 20:20:06

cecampos
Membro
De: Itajai/SC
Registrado: 21/10/2007
Mensagens: 124
Website

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

cezar, respondi seu questionamento por email.


Carlos Eduardo Campos Silva
cecampos @ irc.freenode.net
#archlinux-br
http://carloscampos.org

Offline

#12 09/10/2008 23:17:58

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

Pensei que qualquer coisa que usasse WPA precisasse de wpa_supplicant (mesmo networkmanager e etc.).

É só instalar o pacote wpa_supplicant que deve funcionar.

Offline

#13 09/10/2008 23:48:01

leoarcher
Admin
De: Arapiraca - AL
Registrado: 13/07/2006
Mensagens: 1.256
Website

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

thotypous escreveu:

Pensei que qualquer coisa que usasse WPA precisasse de wpa_supplicant (mesmo networkmanager e etc.).

É só instalar o pacote wpa_supplicant que deve funcionar.

Não... tem que confar. big_smile

Usei isso aqui: http://wiki.archlinux.org/index.php/Wpa_supplicant

Vê se ajuda.


Se copiarem, forneçam a fonte de origem. Se alguma resposta te ajudou a solucionar o problema, por favor edite o título do tópico e adicione "[Resolvido]" a ele (sem as aspas). Obrigado!

asa_tempo.jpg

Offline

#14 09/10/2008 23:51:00

cezar
Membro
Registrado: 15/07/2006
Mensagens: 274

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

RESOLVIDISSIMO! basta seguir os passos de cima do netcfg mas tem que ser junto com a configuração do wpa_supplicant no seguinte link: http://wiki.archlinux.org/index.php/Wpa_supplicant com os seguinte passos:

1)#pacman -S wpa_supplicant
2)# wpa_passphrase mywireless secretpassphrase

e...pronto, wireless bombando!

No meu caso, houve um outro complicador, como disse, tenho duas placas, uma pci e outra onboard, a que foi reconhecida como wlan0 foi a onboard. Assim, depois de configurar o wpa_supplicant, conecetei a antena na placa onboard  e pronto, wireless funcionando

Offline

#15 10/10/2008 00:08:42

cezar
Membro
Registrado: 15/07/2006
Mensagens: 274

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

Obrigado ao todos agradecendo a atenção do Campos pela atenção do e-mail. O Arch é a Distro, não tem jeito :-)

Offline

#16 10/10/2008 20:36:07

leoarcher
Admin
De: Arapiraca - AL
Registrado: 13/07/2006
Mensagens: 1.256
Website

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

Só para completar...

Tive problemas e quebrei a cabeça com SSID desconhecido, ou seja, quando alguém esconde o SSID... Aqui vai a config:

Meu profile do netcfg

CONNECTION="wireless"
DESCRIPTION="A simple WPA wireless home connection"
INTERFACE=ath0
HOSTNAME=arch0n3
IP="dhcp"
ESSID="Leandro"
SECURITY="wpa"
KEY="hixwxpbt55xltfif12"
SCAN="NO"
TIMEOUT=10

E meu arquivo de config do wpa_supplicant

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=2

network={
        disabled=0
        ssid="Leandro"
        identity="aa1"
        #psk="hixwxpbt55xltfif12"
        psk=b3b0918c8c0bcd8d94be43ec3b6fc91f809f12ea45c40b2967f267322e5a9ee7
        scan_ssid=1
        priority=1
}

Dessa forma, a minha ath0 consegue se conectar... Se eu botar, wpa-config no lugar de wpa no SECURITY, não vai, mesmo especificando o arquivo de config com, WPA_CONF=/etc/wpa_supplicant.

Essas configs são básicas e necessárias para conectar,  e também varia de placa pra placa.


Se copiarem, forneçam a fonte de origem. Se alguma resposta te ajudou a solucionar o problema, por favor edite o título do tópico e adicione "[Resolvido]" a ele (sem as aspas). Obrigado!

asa_tempo.jpg

Offline

#17 12/10/2008 17:57:43

cecampos
Membro
De: Itajai/SC
Registrado: 21/10/2007
Mensagens: 124
Website

Re: (RESOLVIDO!)wireless não está conectando no Arch 64

apenas para documentar:

Eu estava usando o wicd mas depois de tanta discussao resolvi voltar pro netcfg pra ver o que esta pegando...

Leandro, eu nao deixo fixo o wpa_supplicant.conf como vc... veja minha configuracao:

CONNECTION="wireless"
WPA_OPTS="-Dmadwifi"
INTERFACE=ath0
SCAN="no"
SECURITY="wpa"
ESSID="ssid"
KEY="chave"
IP="dhcp"
TIMEOUT=20
QUIRKS=(preessid predown postsleep)

Tenho meu ssid oculto tambem (dlink) di-524, e meu adaptador é:

Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Veja:

[[email protected] ~]$ ps xa | grep wpa
4503 ?        Ss     0:00 wpa_supplicant -wB -P/var/run/wpa_supplicant_ath0.pid -iath0 -c /tmp/wpa.N3JMl8gg -Dmadwifi

Meu .conf do wpa é gerado "automaticamente" pelo netcfg smile

Abraços

Última edição por cecampos (12/10/2008 17:58:27)


Carlos Eduardo Campos Silva
cecampos @ irc.freenode.net
#archlinux-br
http://carloscampos.org

Offline

Rodapé do site