Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 11/10/2008 18:19:10

leoarcher
Admin
De: Arapiraca - AL
Registrado: 13/07/2006
Mensagens: 1.252
Website

[Resolvido] Conectar wireless com ESSID oculto em Roteador Linksys.

Bom, não estou conseguindo conectar meu Acer Aspire One via wireless no meu roteador linksys WRT54G.

Essa é a minha placa de rede:

03:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

E nesse link: http://forum.archlinux-br.org/viewtopic.php?id=1150

Tem as configs, que estou usando (netcfg + wpa_supplicant), nesse tópico também, falei que consegui, mas agora não conecto mais. O roteador está configurado para não mostrar o SSID, está com WPA e filtro por MAC.

Se ativar o SSID, conecta de boa.

Alguma sugestão???

Última edição por leoarcher (12/10/2008 11:28:55)


Se copiarem, forneçam a fonte de origem. Se alguma resposta te ajudou a solucionar o problema, por favor edite o título do tópico e adicione "[Resolvido]" a ele (sem as aspas). Obrigado!

asa_tempo.jpg

Offline

#2 11/10/2008 20:41:37

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: [Resolvido] Conectar wireless com ESSID oculto em Roteador Linksys.

Ah, então era isso!

Se colocar para não mostrar o SSID, ele não aparece no "iwlist scan", e o netcfg tenta procurar lá por padrão antes de conectar. Para desabilitar esse comportamento do netcfg, coloque no profile:

SCAN="NO"

Offline

#3 11/10/2008 20:43:58

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: [Resolvido] Conectar wireless com ESSID oculto em Roteador Linksys.

Ah, agora vi no último item do tópico que você já estava usando o SCAN="NO".

Tente usar os quirks prescan e preessid para ver se funciona

Offline

#4 12/10/2008 10:09:54

leoarcher
Admin
De: Arapiraca - AL
Registrado: 13/07/2006
Mensagens: 1.252
Website

Re: [Resolvido] Conectar wireless com ESSID oculto em Roteador Linksys.

thotypous escreveu:

Ah, agora vi no último item do tópico que você já estava usando o SCAN="NO".

Tente usar os quirks prescan e preessid para ver se funciona

É funcionou... Vamos ver até quando ele vai continuar assim...

E pra ajudar mais ainda... Descobri uns probleminhas de configuração no wpa_supplicant...

Aqui está as novas configs:

Meu profile, bom... Mesmo usando o wpa-config, é preciso deixar as variaveis ESSID e KEY, senão ele vai dar erro...

CONNECTION="wireless"
DESCRIPTION="A simple WPA wireless home connection"
INTERFACE=ath0
HOSTNAME=arch0n3
IP="dhcp"
ESSID="Leandro"
SECURITY="wpa-config"
KEY="hixwxpbt55xltfif"
SCAN="no"
TIMEOUT=20
WPA_CONF=/etc/wpa_supplicant.conf
QUIRKS=(prescan preessid)

Meu wpa_supplicant:



ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

network={
        disabled=0
        ssid="Leandro"
        identity="arch0n3"
        #psk="hixwxpbt55xltfif"
        psk=0e7dbe8d9411c050aeb9f37c74dd3750378eaf1cd91a1ccf920879bcec71e3dc
        scan_ssid=1
        priority=1
}

Bom, aqui estão uns problemas.

Estava usando a opção: "ap_scan=2" mas pelo que entendi, ele só usa ndiswrapper and NDIS drivers para funcionar com SSIDs ocultos... Tirando isso, funcionou de boa e também apesar de não funcionar toda vez, apenas com ssid e psk, no wpa_supplicant, teste 4 vezes, com a config acima e está tudo de boa agora.

Para mais opções e saber o porque das opções que usei no wpa_supplicant, vejam o arquivo original no /etc.

Valeu thotypous... Eu tinha testado com as opções que você falou e não estava funcionando, depois vi esse lance do ap_scan e tirei, e voltou a funcionar.

E ele não precisa do: "QUIRKS=(prescan preessid)" ele funciona de boa sem. big_smile

Última edição por leoarcher (13/10/2008 20:26:15)


Se copiarem, forneçam a fonte de origem. Se alguma resposta te ajudou a solucionar o problema, por favor edite o título do tópico e adicione "[Resolvido]" a ele (sem as aspas). Obrigado!

asa_tempo.jpg

Offline

#5 12/10/2008 12:40:49

cecampos
Membro
De: Itajai/SC
Registrado: 21/10/2007
Mensagens: 124
Website

Re: [Resolvido] Conectar wireless com ESSID oculto em Roteador Linksys.

Eu estava usando o wicd mas depois de tanta discussao resolvi voltar pro netcfg pra ver o que esta pegando...

Leandro, eu nao deixo fixo o wpa_supplicant.conf como vc... veja minha configuracao:

CONNECTION="wireless"
WPA_OPTS="-Dmadwifi"
INTERFACE=ath0
SCAN="no"
SECURITY="wpa"
ESSID="ssid"
KEY="chave"
IP="dhcp"
TIMEOUT=20
QUIRKS=(preessid predown postsleep)

Tenho meu ssid oculto tambem (dlink) di-524, e meu adaptador é:

Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Veja:

[[email protected] ~]$ ps xa | grep wpa
4503 ?        Ss     0:00 wpa_supplicant -wB -P/var/run/wpa_supplicant_ath0.pid -iath0 -c /tmp/wpa.N3JMl8gg -Dmadwifi

Meu .conf do wpa é gerado "automaticamente" pelo netcfg smile

Abraços


Carlos Eduardo Campos Silva
cecampos @ irc.freenode.net
#archlinux-br
http://carloscampos.org

Offline

#6 12/10/2008 13:08:22

leoarcher
Admin
De: Arapiraca - AL
Registrado: 13/07/2006
Mensagens: 1.252
Website

Re: [Resolvido] Conectar wireless com ESSID oculto em Roteador Linksys.

Sim, eu sei que ele gera um automatico...

Mas queria deixar tudo funcionando e de todas as formas. big_smile
E tentar descobrir o problema.. Consegui, bom agora fica a dica e vamos esperar pra ver quem vai copiar e colar no VOL.

HAHAHAHAAHAHA


Se copiarem, forneçam a fonte de origem. Se alguma resposta te ajudou a solucionar o problema, por favor edite o título do tópico e adicione "[Resolvido]" a ele (sem as aspas). Obrigado!

asa_tempo.jpg

Offline

Rodapé do site