Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 03/03/2009 16:03:01

djskolman
Membro
Registrado: 03/03/2009
Mensagens: 94

atualização do thunderbird

Ola pessoal, quem pode me ajudar? Eu tenho o tunderbird 2.0.0.14 instalado no meu arch, porem eu gostaria de abrir o gerenciador de perfil dele, então eu digitei thunderbird -p e ele fala q nao pode abrir um arquivo. Pensei em atualizar e digitei pacman -S thunderbird. Só q ai ele pede pra remover um tal de libx11, se eu falo q nao ele sai da instalação, se eu falo que sim ele fala q um monte de programa depende dessa lib e sai do mesmo jeito.

Alguem tem alguma ideia de como podem me ajudar?

Valeu!

Offline

#2 03/03/2009 20:34:57

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: atualização do thunderbird

Tenta postar as saídas dos erros pra ficar mais fácil pra gente amigo.
Abra o thunderbird pelo terminal pra visualizar o que ocorre.

Última edição por phillipe (03/03/2009 20:35:56)


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#3 04/03/2009 15:16:37

djskolman
Membro
Registrado: 03/03/2009
Mensagens: 94

Re: atualização do thunderbird

segue a tela abaixo:

[[email protected] ~]$ thunderbird -p

run-mozilla.sh: Cannot execute /usr/lib/thunderbird-2.0.0.14/thunderbird-bin.pure.

[email protected] ~]$ sudo pacman -S thunderbird
resolvendo dependências...
procurando por conflitos internos...
:: libxcb conflita com libx11. Remover libx11? [S/n] S
erro: falha ao preparar transação (não foi possível satisfazer as dependências)
:: aalib: requer libx11
:: dbus: requer libx11
:: kmplayer: requer libx11
:: libwmf: requer libx11
:: libxext: requer libx11
:: libxfixes: requer libx11
:: libxkbfile: requer libx11
:: libxrender: requer libx11
:: libxt: requer libx11
:: lirc-utils: requer libx11
:: mozplugger: requer libx11
:: rdesktop: requer libx11
:: sdl: requer libx11
:: startup-notification: requer libx11
:: thunderbird-i18n: requer thunderbird=2.0.0.14
:: x264: requer libx11
:: xorg-xinit: requer libx11
[[email protected] ~]$   

Espero que voces possam me ajudar, estou quebrando a cabeça faz tempo!

Offline

#4 04/03/2009 15:36:15

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: atualização do thunderbird

Estranho o libxcb conflitar com o libx11.
Tenta remover primeiro o Thunderbird pra depois instala-lo novamente.


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#5 04/03/2009 16:24:21

djskolman
Membro
Registrado: 03/03/2009
Mensagens: 94

Re: atualização do thunderbird

Eu até pensei em fazer isso. meu medo é depois não conseguir mais instalar o thunderbird!

Offline

#6 04/03/2009 20:01:24

RickDiamond
Banido
Registrado: 17/07/2008
Mensagens: 348

Re: atualização do thunderbird

Há algum motivo para você usar a versão 2.0.0.14? Nos repositórios está a versão 2.0.0.19.

Offline

#7 04/03/2009 20:14:57

djskolman
Membro
Registrado: 03/03/2009
Mensagens: 94

Re: atualização do thunderbird

esse eh o problema RickDiamond nao estou conseguindo atualizar. Como eu faco pra atualiza-lo para essa versao??

Offline

#8 04/03/2009 20:17:22

djskolman
Membro
Registrado: 03/03/2009
Mensagens: 94

Re: atualização do thunderbird

eu desinstalei, agora nao consigo instalar, da o mesmo erro de que a libxcb conflita com a libx11... To perdido !?!

Offline

#9 04/03/2009 20:28:40

RickDiamond
Banido
Registrado: 17/07/2008
Mensagens: 348

Re: atualização do thunderbird

Suponho que seja conflito de versões. Tente atualizar o libx11 primeiro:

pacman -S libx11

Última edição por RickDiamond (04/03/2009 20:30:09)

Offline

#10 04/03/2009 20:44:09

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: atualização do thunderbird

E não esquece de fazer um sync nos repoistórios  antes de instalar, ou tentar instalar, algum pacote viu?!

# pacman -Syu


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#11 05/03/2009 09:34:12

djskolman
Membro
Registrado: 03/03/2009
Mensagens: 94

Re: atualização do thunderbird

phillipe eu sempre uso o pacman -Sy pra instalar o pacote. Depois de ultima vez q eu usei o pacman -Syu e deu pau no meu kde numca mais eu atualizei o sistema. Qual os riscos q eu corro de dar pau novamente?

Offline

#12 05/03/2009 12:49:31

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: atualização do thunderbird

Hummm.... Isso é muito relativo.
As vezes saem pacotes para o Arch que ainda estão em faze de teste e podem ocorrer problemas mesmo.

Mas isso não é sempre.

Cabe a você meter as caras e atualizar ué.... hsuahushauh

Coragem e qualquer coisa posta aqui o que ocorreu.


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#13 05/03/2009 17:08:07

djskolman
Membro
Registrado: 03/03/2009
Mensagens: 94

Re: atualização do thunderbird

hehe valeu, pode deixar

obrigado a todos, e vou experimentar!

Offline

#14 06/03/2009 03:19:11

RickDiamond
Banido
Registrado: 17/07/2008
Mensagens: 348

Re: atualização do thunderbird

djskolman escreveu:

Depois de ultima vez q eu usei o pacman -Syu e deu pau no meu kde numca mais eu atualizei o sistema. Qual os riscos q eu corro de dar pau novamente?

Usar Arch Linux é viver perigosamente. Você nunca sabe quando (e o quanto) a próxima atualização vai quebrar alguma coisa. Eu, pessoalmente, nunca tive problemas graves com isso, mas a bala sempre está no tambor... nunca se sabe se a próxima puxada no gatilho, ou o próximo pacman -Syu, vai disparar um tiro, e nem onde. Acostume-se. wink

Offline

#15 06/03/2009 18:59:53

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: atualização do thunderbird

Também nunca tive problema nenhum com atualização .

Offline

#16 12/03/2009 00:11:33

djskolman
Membro
Registrado: 03/03/2009
Mensagens: 94

Re: atualização do thunderbird

Olá pessoal. Consegui selecionar o problema com o seletor de perfil do thunderbird. Nem precisei atualizar, eu apenas digitei $thunderbird -P (P Maiusculo) ao inves de -p e funcionou. Eu descobri isso sem querer eu ver que no ubuntu dava o mesmo problema. Desde já agradeço a atenção de todos

Obrigado

Offline

#17 12/03/2009 01:25:52

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: atualização do thunderbird

Coloque [RESOLVIDO] no topic x]

[]s


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

Rodapé do site