Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 19/05/2009 22:10:01

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

[Resolvido] Xorg - S.O Funciona sem ele??!

Bem srs,

Ao tentar CTRL+ALT+BACKSPACE vi que o mesmo não está funfando, então procurei como fazê-lo funfar:
http://forum.archlinux-br.org/viewtopic.php?pid=11074
...e se entendi bem, a parada se resumiria a:
.................................................................................................................
"Se quiser ativar o Control+Alt+Backspace, adicione isso ao xorg.conf:
Código:
Section "ServerFlags"
    Option "DontZap" "False"
EndSection"
..................................................................................................................
Porém, como tive problemas com minha reinstalação do S.O vide:
http://forum.archlinux-br.org/viewtopic.php?id=1716
Acabei por inadvertidamente deixar o S.O sem o xorg.
Vou ao /etc/X11 e ele não se encontra lá, mas meu S.O boota normalmente e está totalmente usável!!
Li em algum lugar que o xorg está em desuso, e no caso do Arch o substituto seria o hal, é isso mesmo??

As perguntas são:
O xorg fará falta prá muita coisa??
É aconselhável instalá-lo??
No caso do CTRL+ALT+BACKSPACE, como devo proceder para ativá-lo??

Mechi tanto no xorg.conf pra subir o x, que não consigo concatenar o que fiz de certo e o que fiz de errado ou incompleto.

No aguardo.!!

Última edição por rweu (13/07/2009 19:59:40)


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#2 20/05/2009 01:32:30

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Se tu pesquisar aqui vai saber que da para usar o xorg e hal juntos x)


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#3 20/05/2009 19:06:53

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Exemplo do meu Xorg:

/etc/X11/xorg.conf

Section "ServerLayout"
    Identifier     "Layout"
    Screen      0  "Screen" 0 0
EndSection

Section "Monitor"
    Identifier     "Monitor"
    VendorName     "AOC"
    ModelName      "Envision CT720g"
    HorizSync       30.0 - 72.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS" "True"
EndSection

Section "Device"
    Identifier     "Card"
    Driver         "nvidia"
    Card           "NVIDIA GeForce 6200 A-LE"
    Option         "NoLogo" "true"
    Option         "NoLogo" "true"
    Option         "DamageEvents" "True"
    Option         "BackingStore" "True"
    Option         "TripleBuffer" "true"
    Option         "ConnectedMonitor" "CRT"
    Option         "RenderAccel" "true"
EndSection

Section "Screen"
    Identifier     "Screen"
    Device         "Card"
    Monitor        "Monitor"
    DefaultDepth    24
    SubSection     "Display"
        ViewPort    0 0
        Depth       24
        Modes      "1152x864"
    EndSubSection
EndSection

Praticamente só a configuração do vídeo, o resto é tudo controlado pelo HAL aqui.

Offline

#4 20/05/2009 20:07:39

elton.linux
Membro
De: São Bernardo do Campo/SP
Registrado: 30/09/2007
Mensagens: 50

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

desliga:

#/etc/rc.d/stop kdm

( ou gdm         ou o que usar  )

liga:

#/etc/rc.d/start kdm

Offline

#5 20/05/2009 22:04:05

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Bem srs,

Tentei reinstalar o xorg para poder acertar a questão do CTRL+ALT+BACKSPACE, assim:
# hwd -xa
Xorg criado, porém, ao rebootar o S.O, a tela do GDM fica inoperante para digitação, o mouse não aparece e o teclado fica infuncional. Se xorg e hal podem funcionar em sintonia, no meu S.O dá alguma craca que impossibilidta isso.
Tive de bootar com o CD do ARCH, entrar como root, montar a partiição, ir até o X11 e comandar
# rm -rf xorg.conf
Dei reboote e o GDM, veio normal, se voces observarem esse post aqui: http://forum.archlinux-br.org/viewtopic.php?id=1716  vão perceber que tive mesmo problema com o conjunto slim x lxde, e instalei o gnome para bypassar isso, imaginando que o problema talvez estivesse no slim, mas como agora aconteceu a mesma parada, continuo sem atinar pro que está ocorrendo.

Resumo da opera:
Só com hal S.O normalíssimo!!, Com xorg e hal juntos tanto o GDM como o SLIM ficam travados no boot.
O xorg não tá me fazendo falta alguma, só que para acertar o CTRL+ALT+BACKSPACE, até agora só vi dicas com edição de xorg, então se o xorg dá craca no meu PC junto com o hal, como vou proceder para implementar o CTRL+ALT+BACKSPACE??

No aguardo.!!

Última edição por rweu (20/05/2009 22:12:08)


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#6 21/05/2009 21:29:53

hamilton
Membro
De: Ribeirão Preto/SP
Registrado: 12/04/2009
Mensagens: 88

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Tenta criar um arquivo de nome xorg.conf e adicione apenas isto

Section "ServerFlags"
    Option "DontZap" "False"
EndSection"

e veja se funciona

Offline

#7 21/05/2009 22:59:47

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Tente confgurar os arquivos do HAL :

Minhas configurações, deve funcionar com você.

/etc/hal/fdi/policy/10-keymap.fdi

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">abnt2</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">br</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>

/etc/dbus-1/system.d/hal.conf

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>

  <!-- This configuration file specifies the required security policies
       for the HAL to work. -->

  <!-- Only root or user hal can own the HAL service -->
  <policy user="hal">
    <allow own="org.freedesktop.Hal"/>
  </policy>
  <policy user="root">
    <allow own="org.freedesktop.Hal"/>
  </policy>

  <!-- Allow anyone to invoke methods on the Manager and Device interfaces -->
  <policy context="default">
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.DBus.Introspectable"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.DBus.Properties" />

    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Manager"/>

    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.CPUFreq"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.DockStation"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.KillSwitch"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.KeyboardBacklight"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.LaptopPanel"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.Leds"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.LightSensor"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.Storage"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.Storage.Removable"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.SystemPowerManagement"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.Volume"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.Volume.Crypto"/>
    <allow send_destination="org.freedesktop.Hal"
           send_interface="org.freedesktop.Hal.Device.WakeOnLan"/>

  </policy>

</busconfig>

/etc/PolicyKit/PolicyKit.conf

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->

<!DOCTYPE pkconfig PUBLIC "-//freedesktop//DTD PolicyKit Configuration 1.0//EN"
"http://hal.freedesktop.org/releases/PolicyKit/1.0/config.dtd">

<config version="0.1">

<match action="org.freedesktop.hal.storage.mount-removable">
   <return result="yes" />
</match>

<match action="org.freedesktop.hal.storage.eject-removable">
   <return result="yes" />
</match>

<match action="org.freedesktop.hal.storage.mount-fixed">
   <return result="yes"/>
</match>

<match action="hal-storage-mount-fixed-extra-options">
   <return result="yes"/>
</match>

<match action="hal-storage-mount-removable-extra-options">
   <return result="yes"/>
</match>

<match action="hal-storage-mount-removable-options">
   <return result="yes"/>
</match>

<match action="org.freedesktop.hal.power-management.shutdown">
   <return result="yes"/>
</match>

<match action="org.freedesktop.hal.power-management.reboot">
   <return result="yes"/>
</match>

</config>

Última edição por 920608 (09/06/2009 00:16:30)

Offline

#8 22/05/2009 18:29:41

elton.linux
Membro
De: São Bernardo do Campo/SP
Registrado: 30/09/2007
Mensagens: 50

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Offline

#9 23/05/2009 09:17:15

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

hamilton escreveu:

Tenta criar um arquivo de nome xorg.conf e adicione apenas isto

Section "ServerFlags"
    Option "DontZap" "False"
EndSection"

e veja se funciona

Bem srs,

Das tentativas descritas aqui, a que me pareceu de mais simples implementação, foi essa do hamilton.
Criei o xorg na " mão " e acrescentei as linhas acima citadas.

O xorg somente com essas linhas não está dando mais conflito com o hal, portanto não trava mais
o GDM, e o que é melhor, consigo ter meu CTRL+ALT+BACKSPACE funfando de boa.!!

OBS: Não existe o ( " ) depois do EndSection, o sistema dá erro, foi preciso entrar novamente no xorg e
corrigir, então ficaria:

Section "ServerFlags"
    Option "DontZap" "False"
EndSection


Grato a todos pela atenção.!!

Última edição por rweu (23/05/2009 09:49:59)


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#10 23/05/2009 13:29:51

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

rweu escreveu:
hamilton escreveu:

Tenta criar um arquivo de nome xorg.conf e adicione apenas isto

Section "ServerFlags"
    Option "DontZap" "False"
EndSection"

e veja se funciona

Bem srs,

Das tentativas descritas aqui, a que me pareceu de mais simples implementação, foi essa do hamilton.
Criei o xorg na " mão " e acrescentei as linhas acima citadas.

O xorg somente com essas linhas não está dando mais conflito com o hal, portanto não trava mais
o GDM, e o que é melhor, consigo ter meu CTRL+ALT+BACKSPACE funfando de boa.!!

OBS: Não existe o ( " ) depois do EndSection, o sistema dá erro, foi preciso entrar novamente no xorg e
corrigir, então ficaria:

Section "ServerFlags"
    Option "DontZap" "False"
EndSection


Grato a todos pela atenção.!!

Sim, isso é para habilitar a reinicialização do X pelo atalho do teclado. Isso não gera conflito com o HAL.

Você editou as configurações de HAL também ? Isso sim geraria conflito com o Xorg, ao mesmo que editasse algo, ou que tivesse feito algo errado no Xorg antes.

Offline

#11 23/05/2009 15:35:56

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Ok 920608,

Não editei as configurações do hal, porque achei dispensável ter um xorg completo em uso.
Agora que sei que ele pode ser usado, apenas com algumas indicações pontuais, vou usar este artifício caso venha a precisar dele para mais alguma coisa.

Grato pela ajuda.!!


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#12 24/05/2009 13:53:19

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Em tempo,

920608

Editei apenas /etc/hal/fdi/policy/10-keymap.fdi, pois o 10-keymap.fdi nao existia, e acrescentei o teu exemplo.
Os outros  /etc/dbus-1/system.d/hal.conf,  e /etc/PolicyKit/PolicyKit.conf, ja existiam e nao achei prudente edita-los

Grato


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#13 31/05/2009 01:19:55

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Bem srs,

Após uma desastrada tentativa de bootar com o splashy: http://forum.archlinux-br.org/viewtopic.php?id=1732 eis me as voltas novamente com a questão co xorg x hal.

920608 !!,
Na nova reinstalação eu refiz o /etc/hal/fdi/policy/10-keymap.fdi, conforme voce indicou
mas somente esse arquivo ok!?,  nos outros eu não mechi, tanto no /etc/dbus-1/system.d/hal.conf e no /etc/PolicyKit/PolicyKit.conf.

O fato novo é que, dessa vez, usando GDM x Lxde ou GDM x Gnome, mesmo que eu faça um xorg.conf, em que só conste o Código...
Section "ServerFlags"
    Option "DontZap" "False"
EndSection
...meu S.O não boota, pula uma pop-up relacionada a algo com o "sis" ou empaca pedindo login numa tela preta.

Phillipe !!
Fiz o que voce me pediu...
"Fala aí rweu!
Antes de tudo tenta fazer uma coisinha
Quando der a tela preta pedindo login, faça seu login de usuário normal e depois:
  $ su -c init 3
  $ startlxde"
...só que quando eu me logo aí na tal tela preta e depois comando $ su -c init3, é pedida niova senha e não sai disso.

Caraca, será que não vou ter de novo meu CTRL+ALT+BACKSPACE, isso faz falta.!!

No aguardo.!

Última edição por rweu (31/05/2009 01:31:08)


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#14 31/05/2009 01:44:27

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

rweu escreveu:

Bem srs,

Após uma desastrada tentativa de bootar com o splashy: http://forum.archlinux-br.org/viewtopic.php?id=1732 eis me as voltas novamente com a questão co xorg x hal.

920608 !!,
Na nova reinstalação eu refiz o /etc/hal/fdi/policy/10-keymap.fdi, conforme voce indicou
mas somente esse arquivo ok!?,  nos outros eu não mechi, tanto no /etc/dbus-1/system.d/hal.conf e no /etc/PolicyKit/PolicyKit.conf.

O fato novo é que, dessa vez, usando GDM x Lxde ou GDM x Gnome, mesmo que eu faça um xorg.conf, em que só conste o Código...
Section "ServerFlags"
    Option "DontZap" "False"
EndSection
...meu S.O não boota, pula uma pop-up relacionada a algo com o "sis" ou empaca pedindo login numa tela preta.

Phillipe !!
Fiz o que voce me pediu...
"Fala aí rweu!
Antes de tudo tenta fazer uma coisinha
Quando der a tela preta pedindo login, faça seu login de usuário normal e depois:
  $ su -c init 3
  $ startlxde"
...só que quando eu me logo aí na tal tela preta e depois comando $ su -c init3, é pedida niova senha e não sai disso.

Caraca, será que não vou ter de novo meu CTRL+ALT+BACKSPACE, isso faz falta.!!

No aguardo.!

rweu, justamente os arquivos que você não editou, são os arquivos de configuração para o HAL gerenciar seu sistema sem conflitar (travar) com o Xorg. Edite os arquivos que citei sem problemas smile E sim, teria que criar mesmo o 10-keymap.fdi, que é o arquivo de configuração do HAL para o teclado (no que te passei, ABNT2).

Os outros dois arquivos existem, é só substituir o conteúdo deles por aqueles que enviei.

Última edição por 920608 (31/05/2009 01:45:34)

Offline

#15 31/05/2009 12:43:44

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Ok 920608,

Dessa vez eu editei todos os arquivos indicados, e refiz o xorg.conf somente com o conteúdo que eu quero, ou seja, referente ao CTRL+ALT+BACKSPACE.

Porém, mesmo assim, o S.O continua travando, ou seja dando incompatibilidade entre Xorg x HAl.
Retirei o xorg de novo, e o S.O bootou normalmente, mas tem um senão: agora estou sem o botão "desligar"; ao clicar na Aba Sistema, só me me vem a opção de encerrar sessão, clico, vem a tela do GDM, e aí sim consigo desligar o PC.

No aguardo

OBS: Tive o cuidado de copiar os arquivos editados, seria o caso de tentar voltá-los!!??
_hal.conf............ para hal.conf.old
_PolicyKit.conf.... para PolicyKit.conf.old


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#16 31/05/2009 16:15:09

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

rweu escreveu:

Ok 920608,

Dessa vez eu editei todos os arquivos indicados, e refiz o xorg.conf somente com o conteúdo que eu quero, ou seja, referente ao CTRL+ALT+BACKSPACE.

Porém, mesmo assim, o S.O continua travando, ou seja dando incompatibilidade entre Xorg x HAl.
Retirei o xorg de novo, e o S.O bootou normalmente, mas tem um senão: agora estou sem o botão "desligar"; ao clicar na Aba Sistema, só me me vem a opção de encerrar sessão, clico, vem a tela do GDM, e aí sim consigo desligar o PC.

No aguardo

OBS: Tive o cuidado de copiar os arquivos editados, seria o caso de tentar voltá-los!!??
_hal.conf............ para hal.conf.old
_PolicyKit.conf.... para PolicyKit.conf.old

Não é preciso. Deveria funcionar com as configurações que passei, com ou sem xorg.conf. Seu usuário está no grupo hal e dbus ? Colocou o HAL nas DAEMONS ?

Não uso Gnome, mas que eu saiba, não existe mais o botão desligar... Você pode adicionar também seu usuário ao grupo power, no XFCE você só pode desligar o computador estando neste grupo.

Offline

#17 31/05/2009 19:51:23

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Ok 92,

Resumo:
_Meu usu está em ambos os grupos citados ( hal e dbus )
_O hal está no DAEMONS, quem não estava no DAEMONS era o dbus, acrescenteio lá.
Porém, a questão do xorg.conf continua nebulosa, continuo não conseguindo deixá-lo junto com o hal,
dá craca!!
_Também coloquei meu usu no grupo power, mas nada de conseguir desligar o PC, somente consigo terminando a sessão, indo ao GDM e aí sim consigo desligar

No aguardo.!1


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#18 31/05/2009 20:43:20

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

rweu, poste seu /etc/X11/xorg.conf aqui.

Offline

#19 31/05/2009 21:53:48

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Ok 92,

Como te relatei , meu xorg.conf se resume a isso:

Section "ServerFlags"
    Option "DontZap" "False"
EndSection

Mas, no momento nem isso !!,  posto que, se deixar a parada ativa, dá craca com o Hal
e não consigo caminhar com o boot gráfico.

No aguardo.

Última edição por rweu (31/05/2009 21:55:46)


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#20 01/06/2009 00:38:43

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

rweu escreveu:

Ok 92,

Como te relatei , meu xorg.conf se resume a isso:

Section "ServerFlags"
    Option "DontZap" "False"
EndSection

Mas, no momento nem isso !!,  posto que, se deixar a parada ativa, dá craca com o Hal
e não consigo caminhar com o boot gráfico.

No aguardo.

rweu, relatando que as configurações de monitor, placa de vídeo, etc, ainda não estão 100% implementadas com o HAL, então tente configurar somente seu vídeo, a exemplo do meu xorg.conf.

Offline

#21 01/06/2009 22:06:08

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Bem meu caro,

Tanto mechi nessa josta que agora, com xorg, ou sem xorg, a parada trava.
Fiz o que voce falou, acrescentando o teu xorg, obviamente adequando, ou seja retirando o passo relativo a nvidia, que não possuo.
Fato é que, agora eu detono o xorg, e o sistema que antes funfava sem ele, agora grita sua falta, se sapeco o dito cujo, o S.O trava, sendo o xorg, assim ou assado.
Já tentei de tudo, hwd -xa, hwd -x, renomei xorg.conf.vesa, para xorg.conf,esse vem uma tela grandona com o gdm, mas vem sem mouse, ( o ponteiro não dá as caras) e teclado, não consigo escrever usuário, já se renomeio o xorg.conf.sis para xorg.conf, não vem o gdm, também já comandei xorgcfg -textmode,
esse diz que não pode ser feito.
Tudo isso agora foi infrutífero, já havia feito em oportunidades anteriores e depois retirado, e o S.O funfava sem o xorg, mas agora pirou de vez, tá rebelde!!

Caraca.!! tô sem o Arch de novo, tô escrevendo isso do Debian que possuo em dual boot.
Eu gosto muito do Arch e não gosto de me denegrir, mas será que ele ainda é muito prá esse iniciante aqui!!??
Só o que estava faltando era arredondar a questão do CTRL+ALT+BACKSPACE, e é somente por causa disso que eu tô mechendo nessa "M" de xorg, se não tivesse sido isso deixaria o S.O só com o hal.

No aguardo de mais alguma orientação!!
Não desisto facilmente!!

Última edição por rweu (01/06/2009 22:19:19)


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#22 02/06/2009 00:40:15

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

#    Option "AutoAddDevices" "False"

Eu uso isso comentando e uso hal e xorg. Achei essa solução aqui no FORUM!

(;


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#23 02/06/2009 14:53:14

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

OK, corvolino,

É pra editar o xorg.conf apenas com essa linha?

Voce poderia postar o seu xorg??

No aguardo.!!

.................................................................................................
Em tempo, vi aqui na net:
http://matias.archlinux-br.org/page/2

Edição do xorg:

Section "ServerFlags"
        Option "AutoAddDevices" "False"
EndSection

Última edição por rweu (02/06/2009 15:12:07)


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#24 02/06/2009 15:04:22

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Section "ServerFlags"
      Option "AutoAddDevices" "False"
EndSection

Só adicione isso ao seu xorg.conf, se a sessão ServerFlags já estiver criada, acrescente a linha Option...

Última edição por 920608 (02/06/2009 15:05:15)

Offline

#25 02/06/2009 17:13:06

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: [Resolvido] Xorg - S.O Funciona sem ele??!

Section "ServerLayout"
    Identifier     "Xorg Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
# PS/2 Mouse not detected
# Serial Mouse not detected
        InputDevice    "USB Mouse" "CorePointer"
EndSection

Section "ServerFlags"
    Option "AllowMouseOpenFail"  "true"
#    Option "AutoAddDevices" "False"
    
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/misc:unscaled"
    FontPath     "/usr/share/fonts/misc"
    FontPath     "/usr/share/fonts/75dpi:unscaled"
    FontPath     "/usr/share/fonts/75dpi"
    FontPath     "/usr/share/fonts/100dpi:unscaled"
    FontPath     "/usr/share/fonts/100dpi"
    FontPath     "/usr/share/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
    FontPath     "/usr/share/fonts/cyrillic"
#    FontPath     "/usr/share/lib/X11/fonts/latin2/75dpi"
#    FontPath     "/usr/share/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
    FontPath     "/usr/share/fonts/Type1"
    FontPath     "/usr/share/fonts/ttf/western"
    FontPath     "/usr/share/fonts/ttf/decoratives"
    FontPath     "/usr/share/fonts/truetype"
    FontPath     "/usr/share/fonts/truetype/openoffice"
    FontPath     "/usr/share/fonts/truetype/ttf-bitstream-vera"
    FontPath     "/usr/share/fonts/latex-ttf-fonts"
    FontPath     "/usr/share/fonts/defoma/CID"
    FontPath     "/usr/share/fonts/defoma/TrueType"
EndSection

Section "Module"
        Load  "ddc"  # ddc probing of monitor
    Load  "dbe"
    Load  "dri"
    Load  "extmod"
    Load  "glx"
        Load  "bitmap" # bitmap-fonts
    Load  "record"
    #   Load  "synaptics"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "keyboard"
        Option      "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    Option "XkbVariant" ""
EndSection

Section "InputDevice"
    Identifier  "Serial Mouse"
    Driver      "mouse"
    Option      "Protocol" "Microsoft"
    Option      "Device" "/dev/ttyS0"
    Option      "Emulate3Buttons" "true"
    Option      "Emulate3Timeout" "70"
    Option        "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
    Identifier  "PS/2 Mouse"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option          "ZAxisMapping"          "4 5"
    Option      "Device" "/dev/psaux"
    Option      "Emulate3Buttons" "true"
    Option      "Emulate3Timeout" "70"
    Option        "SendCoreEvents"  "true"
EndSection

Section "InputDevice"
        Identifier      "USB Mouse"
        Driver          "mouse"
        Option          "Device"                "/dev/input/mice"
    Option        "SendCoreEvents"    "true"
        Option          "Protocol"              "IMPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Buttons"               "5"
EndSection

# Auto-generated by Archie mkxcfg

Section "Monitor"
    Identifier "Monitor0"
        Option "DPMS" "true"
#    HorizSync    28.0 - 78.0 # Warning: This may fry very old Monitors
    HorizSync    28.0 - 96.0 # Warning: This may fry old Monitors
    VertRefresh  50.0 - 75.0 # Very conservative. May flicker.
#    VertRefresh  50.0 - 62.0 # Extreme conservative. Will flicker. TFT default.
    #  Default modes distilled from
    #      "VESA and Industry Standards and Guide for Computer Display Monitor
    #       Timing", version 1.0, revision 0.8, adopted September 17, 1998.
    #  $XFree86: xc/programs/Xserver/hw/xfree86/etc/vesamodes,v 1.4 1999/11/18 16:52:17 tsi Exp $
    # 640x350 @ 85Hz (VESA) hsync: 37.9kHz
    ModeLine "640x350"    31.5  640  672  736  832    350  382  385  445 +hsync -vsync
    # 640x400 @ 85Hz (VESA) hsync: 37.9kHz
    ModeLine "640x400"    31.5  640  672  736  832    400  401  404  445 -hsync +vsync
    # 720x400 @ 85Hz (VESA) hsync: 37.9kHz
    ModeLine "720x400"    35.5  720  756  828  936    400  401  404  446 -hsync +vsync
    # 640x480 @ 60Hz (Industry standard) hsync: 31.5kHz
    ModeLine "640x480"    25.2  640  656  752  800    480  490  492  525 -hsync -vsync
    # 640x480 @ 72Hz (VESA) hsync: 37.9kHz
    ModeLine "640x480"    31.5  640  664  704  832    480  489  491  520 -hsync -vsync
    # 640x480 @ 75Hz (VESA) hsync: 37.5kHz
    ModeLine "640x480"    31.5  640  656  720  840    480  481  484  500 -hsync -vsync
    # 640x480 @ 85Hz (VESA) hsync: 43.3kHz
    ModeLine "640x480"    36.0  640  696  752  832    480  481  484  509 -hsync -vsync
    # 800x600 @ 56Hz (VESA) hsync: 35.2kHz
    ModeLine "800x600"    36.0  800  824  896 1024    600  601  603  625 +hsync +vsync
    # 800x600 @ 60Hz (VESA) hsync: 37.9kHz
    ModeLine "800x600"    40.0  800  840  968 1056    600  601  605  628 +hsync +vsync
    # 800x600 @ 72Hz (VESA) hsync: 48.1kHz
    ModeLine "800x600"    50.0  800  856  976 1040    600  637  643  666 +hsync +vsync
    # 800x600 @ 75Hz (VESA) hsync: 46.9kHz
    ModeLine "800x600"    49.5  800  816  896 1056    600  601  604  625 +hsync +vsync
    # 800x600 @ 85Hz (VESA) hsync: 53.7kHz
    ModeLine "800x600"    56.3  800  832  896 1048    600  601  604  631 +hsync +vsync
    # 1024x768i @ 43Hz (industry standard) hsync: 35.5kHz
    ModeLine "1024x768"   44.9 1024 1032 1208 1264    768  768  776  817 +hsync +vsync Interlace
    # 1024x768 @ 60Hz (VESA) hsync: 48.4kHz
    ModeLine "1024x768"   65.0 1024 1048 1184 1344    768  771  777  806 -hsync -vsync
    # 1024x768 @ 70Hz (VESA) hsync: 56.5kHz
    ModeLine "1024x768"   75.0 1024 1048 1184 1328    768  771  777  806 -hsync -vsync
    # 1024x768 @ 75Hz (VESA) hsync: 60.0kHz
    ModeLine "1024x768"   78.8 1024 1040 1136 1312    768  769  772  800 +hsync +vsync
    # 1024x768 @ 85Hz (VESA) hsync: 68.7kHz
    ModeLine "1024x768"   94.5 1024 1072 1168 1376    768  769  772  808 +hsync +vsync
    # 1152x864 @ 75Hz (VESA) hsync: 67.5kHz
    ModeLine "1152x864"  108.0 1152 1216 1344 1600    864  865  868  900 +hsync +vsync
    # 1280x960 @ 60Hz (VESA) hsync: 60.0kHz
    ModeLine "1280x960"  108.0 1280 1376 1488 1800    960  961  964 1000 +hsync +vsync
    # 1280x960 @ 85Hz (VESA) hsync: 85.9kHz
    ModeLine "1280x960"  148.5 1280 1344 1504 1728    960  961  964 1011 +hsync +vsync
    # 1280x1024 @ 60Hz (VESA) hsync: 64.0kHz
    ModeLine "1280x1024" 108.0 1280 1328 1440 1688   1024 1025 1028 1066 +hsync +vsync
    # 1280x1024 @ 75Hz (VESA) hsync: 80.0kHz
    ModeLine "1280x1024" 135.0 1280 1296 1440 1688   1024 1025 1028 1066 +hsync +vsync
    # 1280x1024 @ 85Hz (VESA) hsync: 91.1kHz
    ModeLine "1280x1024" 157.5 1280 1344 1504 1728   1024 1025 1028 1072 +hsync +vsync
    # 1600x1200 @ 60Hz (VESA) hsync: 75.0kHz
    ModeLine "1600x1200" 162.0 1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync
    # 1600x1200 @ 65Hz (VESA) hsync: 81.3kHz
    ModeLine "1600x1200" 175.5 1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync
    # 1600x1200 @ 70Hz (VESA) hsync: 87.5kHz
    ModeLine "1600x1200" 189.0 1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync
    # 1600x1200 @ 75Hz (VESA) hsync: 93.8kHz
    ModeLine "1600x1200" 202.5 1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync
    # 1600x1200 @ 85Hz (VESA) hsync: 106.3kHz
    ModeLine "1600x1200" 229.5 1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync
    # 1792x1344 @ 60Hz (VESA) hsync: 83.6kHz
    ModeLine "1792x1344" 204.8 1792 1920 2120 2448   1344 1345 1348 1394 -hsync +vsync
    # 1792x1344 @ 75Hz (VESA) hsync: 106.3kHz
    ModeLine "1792x1344" 261.0 1792 1888 2104 2456   1344 1345 1348 1417 -hsync +vsync
    # 1856x1392 @ 60Hz (VESA) hsync: 86.3kHz
    ModeLine "1856x1392" 218.3 1856 1952 2176 2528   1392 1393 1396 1439 -hsync +vsync
    # 1856x1392 @ 75Hz (VESA) hsync: 112.5kHz
    ModeLine "1856x1392" 288.0 1856 1984 2208 2560   1392 1393 1396 1500 -hsync +vsync
    # 1920x1440 @ 60Hz (VESA) hsync: 90.0kHz
    ModeLine "1920x1440" 234.0 1920 2048 2256 2600   1440 1441 1444 1500 -hsync +vsync
    # 1920x1440 @ 75Hz (VESA) hsync: 112.5kHz
    ModeLine "1920x1440" 297.0 1920 2064 2288 2640   1440 1441 1444 1500 -hsync +vsync
    # Additional modelines
    ModeLine "1800x1440"  230    1800 1896 2088 2392  1440 1441 1444 1490 +HSync +VSync
    ModeLine "1800x1440"  250    1800 1896 2088 2392  1440 1441 1444 1490 +HSync +VSync
    # Extended modelines with GTF timings
    # 640x480 @ 100.00 Hz (GTF) hsync: 50.90 kHz; pclk: 43.16 MHz
    ModeLine "640x480"  43.16  640 680 744 848  480 481 484 509  -HSync +Vsync
    # 768x576 @ 60.00 Hz (GTF) hsync: 35.82 kHz; pclk: 34.96 MHz
    ModeLine "768x576"  34.96  768 792 872 976  576 577 580 597  -HSync +Vsync
    # 768x576 @ 72.00 Hz (GTF) hsync: 43.27 kHz; pclk: 42.93 MHz
    ModeLine "768x576"  42.93  768 800 880 992  576 577 580 601  -HSync +Vsync
    # 768x576 @ 75.00 Hz (GTF) hsync: 45.15 kHz; pclk: 45.51 MHz
    ModeLine "768x576"  45.51  768 808 888 1008  576 577 580 602  -HSync +Vsync
    # 768x576 @ 85.00 Hz (GTF) hsync: 51.42 kHz; pclk: 51.84 MHz
    ModeLine "768x576"  51.84  768 808 888 1008  576 577 580 605  -HSync +Vsync
    # 768x576 @ 100.00 Hz (GTF) hsync: 61.10 kHz; pclk: 62.57 MHz
    ModeLine "768x576"  62.57  768 816 896 1024  576 577 580 611  -HSync +Vsync
    # 800x600 @ 100.00 Hz (GTF) hsync: 63.60 kHz; pclk: 68.18 MHz
    ModeLine "800x600"  68.18  800 848 936 1072  600 601 604 636  -HSync +Vsync
    # 1024x768 @ 100.00 Hz (GTF) hsync: 81.40 kHz; pclk: 113.31 MHz
    ModeLine "1024x768"  113.31  1024 1096 1208 1392  768 769 772 814  -HSync +Vsync
    # 1152x864 @ 60.00 Hz (GTF) hsync: 53.70 kHz; pclk: 81.62 MHz
    ModeLine "1152x864"  81.62  1152 1216 1336 1520  864 865 868 895  -HSync +Vsync
    # 1152x864 @ 85.00 Hz (GTF) hsync: 77.10 kHz; pclk: 119.65 MHz
    ModeLine "1152x864"  119.65  1152 1224 1352 1552  864 865 868 907  -HSync +Vsync
    # 1152x864 @ 100.00 Hz (GTF) hsync: 91.50 kHz; pclk: 143.47 MHz
    ModeLine "1152x864"  143.47  1152 1232 1360 1568  864 865 868 915  -HSync +Vsync
    # 1280x960 @ 72.00 Hz (GTF) hsync: 72.07 kHz; pclk: 124.54 MHz
    ModeLine "1280x960"  124.54  1280 1368 1504 1728  960 961 964 1001  -HSync +Vsync
    # 1280x960 @ 75.00 Hz (GTF) hsync: 75.15 kHz; pclk: 129.86 MHz
    ModeLine "1280x960"  129.86  1280 1368 1504 1728  960 961 964 1002  -HSync +Vsync
    # 1280x960 @ 100.00 Hz (GTF) hsync: 101.70 kHz; pclk: 178.99 MHz
    ModeLine "1280x960"  178.99  1280 1376 1520 1760  960 961 964 1017  -HSync +Vsync
    # 1280x1024 @ 100.00 Hz (GTF) hsync: 108.50 kHz; pclk: 190.96 MHz
    ModeLine "1280x1024"  190.96  1280 1376 1520 1760  1024 1025 1028 1085  -HSync +Vsync
    # 1400x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 122.61 MHz
    ModeLine "1400x1050"  122.61  1400 1488 1640 1880  1050 1051 1054 1087  -HSync +Vsync
    # 1400x1050 @ 72.00 Hz (GTF) hsync: 78.77 kHz; pclk: 149.34 MHz
    ModeLine "1400x1050"  149.34  1400 1496 1648 1896  1050 1051 1054 1094  -HSync +Vsync
    # 1400x1050 @ 75.00 Hz (GTF) hsync: 82.20 kHz; pclk: 155.85 MHz
    ModeLine "1400x1050"  155.85  1400 1496 1648 1896  1050 1051 1054 1096  -HSync +Vsync
    # 1400x1050 @ 85.00 Hz (GTF) hsync: 93.76 kHz; pclk: 179.26 MHz
    ModeLine "1400x1050"  179.26  1400 1504 1656 1912  1050 1051 1054 1103  -HSync +Vsync
    # 1400x1050 @ 100.00 Hz (GTF) hsync: 111.20 kHz; pclk: 214.39 MHz
    ModeLine "1400x1050"  214.39  1400 1512 1664 1928  1050 1051 1054 1112  -HSync +Vsync
    # 1600x1200 @ 100.00 Hz (GTF) hsync: 127.10 kHz; pclk: 280.64 MHz
    ModeLine "1600x1200"  280.64  1600 1728 1904 2208  1200 1201 1204 1271  -HSync +Vsync
EndSection

# Auto-generated by Archie mkxcfg


Section "Device"
    Identifier  "Card0"
    Driver      "intel"
    VendorName  "All"
    BoardName   "All"
EndSection


Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    DefaultColorDepth 16
    SubSection "Display"
        Depth     1
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     4
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     8
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     15
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     16
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     24
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     32
        Modes "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "DRI"
    Mode 0666
EndSection

Ai meu xorg (;

AH, uso netbook viu =p


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

Rodapé do site