Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 11/07/2009 09:30:58

azemilian
Membro
Registrado: 11/07/2009
Mensagens: 12

Ctrl+Alt+Backspace nao funfa no X

Olá pessoALL,

Sou novo aqui no forum e esse é meu primeiro post.
Instalei o ARCH e curti bastante. Eu instalei o gnome com gdm. Subiu tudo normalmente e funfa legalz, o unico problema é que o Ctrl+Alt+Backspace (tão útil em nossas vidas) não funfa. Alguem sabe me dizer o que acontece?!
Vi que tem tido varios problemas com relacao ao X depois dessas alteracoes que o Xorg fez.

Valews galera.

Offline

#2 11/07/2009 12:03:17

Lyceuhns
Membro
Registrado: 25/03/2008
Mensagens: 424

Re: Ctrl+Alt+Backspace nao funfa no X

Pois é, vários comandos tradicionais não estão mais disponíveis...

¬¬

Offline

#3 11/07/2009 13:10:36

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: Ctrl+Alt+Backspace nao funfa no X

Solução:

# cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/

Feito isso agora é só fazer o seguinte:

- Abra o arquivo que copiamos com um editor de sua preferência [Ex.#vi /etc/hal/fdi/policy/10-keymap.fdi ] e coloque o seguinte conteúdo dentro dele:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">abnt2</merge>
      </match>

      <!-- Restore Ctrl-Alt-Bksp Xserver Zapping -->
      <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>

      <merge key="input.xkb.layout" type="string">br</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>

- Salve o arquivo e então digite em um terminal: # /etc/rc.d/hal restart

Prontinho solucionamos tanto do teclado no padrão ABNT2 como das teclas CTRL+ALT+Backspace.

A solução para teclado ABNT2 tem de monte aqui no Fórum, mas a de CTRL+ALT+Backspace através de configurações no HAL eu ainda não tinha visto, por isso postei wink

Abraços!!!


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#4 11/07/2009 17:27:02

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: Ctrl+Alt+Backspace nao funfa no X

phillipe escreveu:

Solução:

# cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/

Feito isso agora é só fazer o seguinte:

- Abra o arquivo que copiamos com um editor de sua preferência [Ex.#vi /etc/hal/fdi/policy/10-keymap.fdi ] e coloque o seguinte conteúdo dentro dele:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">abnt2</merge>
      </match>

      <!-- Restore Ctrl-Alt-Bksp Xserver Zapping -->
      <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>

      <merge key="input.xkb.layout" type="string">br</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>

- Salve o arquivo e então digite em um terminal: # /etc/rc.d/hal restart

Prontinho solucionamos tanto do teclado no padrão ABNT2 como das teclas CTRL+ALT+Backspace.

A solução para teclado ABNT2 tem de monte aqui no Fórum, mas a de CTRL+ALT+Backspace através de configurações no HAL eu ainda não tinha visto, por isso postei wink

Abraços!!!

Boa phillipe big_smile Já vou adicionar aqui.

Offline

#5 11/07/2009 18:09:24

gean gustavo
Membro
De: Paiçandu/Paraná/Brasil
Registrado: 06/06/2008
Mensagens: 227

Re: Ctrl+Alt+Backspace nao funfa no X

aqui não funcionou o Ctrl+Alt+Backspace no hal não.

Offline

#6 11/07/2009 19:43:05

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: Ctrl+Alt+Backspace nao funfa no X

Esse comando foi desativado porque ele erradamente caiu no grupo de comando malicioso - assim como o rm -rf / - no site tem essa notícia e o hdoria posto em seu blog como revive-lo.

[]s


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#7 11/07/2009 20:43:28

Lyceuhns
Membro
Registrado: 25/03/2008
Mensagens: 424

Re: Ctrl+Alt+Backspace nao funfa no X

Saiu no site?!
Não tinha visto sobre o comando. o.o

Será que falaram algo sobre novos comandos de rolar a tela no modo de texto, isso também eu não vi...

Offline

#8 12/07/2009 16:46:08

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: Ctrl+Alt+Backspace nao funfa no X

Lyceuhns escreveu:

Saiu no site?!
Não tinha visto sobre o comando. o.o

Será que falaram algo sobre novos comandos de rolar a tela no modo de texto, isso também eu não vi...

kkkkkkkkkkkk, aqui eu seguro shift e rolo com Page Up/Down. Mas só funciona uma vez, depois você tem que digitar o comando denovo (exemplo: dmesg).

Offline

#9 12/07/2009 17:43:45

Jonathas
Membro
De: Rio de Janeiro, RJ
Registrado: 11/05/2009
Mensagens: 45
Website

Re: Ctrl+Alt+Backspace nao funfa no X

opa.. fiz o que o phillipe falou aí, e não funcionou aqui pra mim não..
e nem achei lá no hdoria tb o post..


Dell Inspiron 1525 Notebook + Arch Linux
Linux user # 438750
http://jonathasonline.wordpress.com

Offline

#10 12/07/2009 19:13:26

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: Ctrl+Alt+Backspace nao funfa no X

920608 escreveu:

Boa phillipe big_smile Já vou adicionar aqui.

Vlw 920608!!! wink

gean gustavo escreveu:

aqui não funcionou o Ctrl+Alt+Backspace no hal não.

Jonathas escreveu:

opa.. fiz o que o phillipe falou aí, e não funcionou aqui pra mim não..
e nem achei lá no hdoria tb o post..

Ué pessoal..... Vocês tem certeza que fizeram os passos certinhos???

Porque fiz no meu Arch e no da minha namorada e funcinou perfeitamente....


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#11 12/07/2009 20:00:26

sistematico
Admin
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.023
Website

Re: Ctrl+Alt+Backspace nao funfa no X

Confirmando o post do phillipe, meu /etc/hal/fdi/policy/10-keymap.fdi tá assim:

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">abnt2</merge>
      </match>
      <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>
      <merge key="input.xkb.layout" type="string">br</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>

E o /etc/X11/xorg.conf tá assim:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "ServerFlags"
    Option    "DontZap" "false"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
#    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName       "GeForce 7300 SE"
    Option            "RenderAccel" "True"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

E aqui o CTRL+ALT+BACKSPACE funciona normal.
Abraços..

Offline

#12 13/07/2009 01:16:40

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: Ctrl+Alt+Backspace nao funfa no X

sistematico escreveu:

Confirmando o post do phillipe, meu /etc/hal/fdi/policy/10-keymap.fdi tá assim:

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">abnt2</merge>
      </match>
      <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>
      <merge key="input.xkb.layout" type="string">br</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>

E o /etc/X11/xorg.conf tá assim:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "ServerFlags"
    Option    "DontZap" "false"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
#    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName       "GeForce 7300 SE"
    Option            "RenderAccel" "True"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

E aqui o CTRL+ALT+BACKSPACE funciona normal.
Abraços..

sistematico, no seu caso pode ser também por ter isso no seu xorg.conf:

Section "ServerFlags"
    Option    "DontZap" "false"
EndSection

Offline

#13 13/07/2009 01:40:46

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: Ctrl+Alt+Backspace nao funfa no X

920608 escreveu:

sistematico, no seu caso pode ser também por ter isso no seu xorg.conf:

Section "ServerFlags"
    Option    "DontZap" "false"
EndSection

920608... Bem não sei se isso acontece com outros usuários, mas comigo a opção "DontZap" no xorg.conf não tava adiantando de nada, mesmo meu xorg tendo a opção [ Option "AutoAddDevices" "False" ] que desabilita o reconhecimento de teclado, mouse e outros pelo HAL.

Última edição por phillipe (13/07/2009 01:41:45)


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#14 13/07/2009 04:13:12

Lyceuhns
Membro
Registrado: 25/03/2008
Mensagens: 424

Re: Ctrl+Alt+Backspace nao funfa no X

920608 escreveu:
Lyceuhns escreveu:

Saiu no site?!
Não tinha visto sobre o comando. o.o

Será que falaram algo sobre novos comandos de rolar a tela no modo de texto, isso também eu não vi...

kkkkkkkkkkkk, aqui eu seguro shift e rolo com Page Up/Down. Mas só funciona uma vez, depois você tem que digitar o comando denovo (exemplo: dmesg).

o.o
Funcionou sim, loguei e funcionou, porém não rolo para antes da tela de login, ou seja inútil, desabilitei a limpeza das mensagens de boot, mas não posso vê-las. ¬¬

Infelizmente eu quero justamente o que acontece depois do que o dmesg registra, aquela parte onde inicializa os serviços e etc.
A tela não tava rolando porque não sobe acima da tela de login. yikes

Offline

#15 13/07/2009 12:13:46

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: Ctrl+Alt+Backspace nao funfa no X

Bem srs,

Também tenho o mesmo problema com o Ctrl+Alt+Backspace, desde a instalação, vide:
http://forum.archlinux-br.org/viewtopic.php?id=1721 , então, eu fiz o que o Phillipe pede, só que eu acrescentei aquele conteúdo ao final do arquivo, já existente,
(usando: # nano /etc/hal/fdi/policy/10-keymap.fdi), então meu arquivo ficou com o conteúdo que já estava nele, ( que foi o do comando cp ) + o conteúdo que o Phillipe mencionou; salvei o arquivo, reinicializei o PC, e não funfou!!

Agora tenho essas dúvidas:
_Eu deveria ter substituído o conteúdo pelo do Phillipe, ou do jeito que fiz também funfaria!!??
_Se pode ser de um jeito ou de outro, pq não funfou??, o que posso ter feito de errado??

No aguardo!!

Última edição por rweu (13/07/2009 12:27:15)


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#16 13/07/2009 13:10:31

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: Ctrl+Alt+Backspace nao funfa no X

rweu...
Se você simplesmente acrescentar o conteúdo que postei no arquivo junto com o outro conteúdo que já estava configurado no seu, não vai funcionar mesmo, porque existe regras e padrões para que esse arquivo seja reconhecido.

A única coisa que você deveria fazer é adicionar no seu arquivo [ /etc/hal/fdi/policy/10-keymap.fdi ] a única linha que realmente é referente ao CTRL+ALT+Backspace...

O que quero dizer é que você só precisa adicionar a seguinte linha no seu arquivo:

<merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>

Veja o local onde coloquei essa linha no meu arquivo e etão coloque, + ou -, no mesmo local no seu arquivo.... Mas só essa linha viu?! O restante do arquivo é simplesmente para ajustar o teclado para o padrão brasileiro abnt2, isso o seu já deve tá blz porque o 920608 já te passou as configurações.

Entendestes?!


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#17 13/07/2009 14:08:27

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: Ctrl+Alt+Backspace nao funfa no X

Gostaria de pedir desculpa, fiz uma pequena confusão.

O post não saiu no site e sim no antigo blog do hdoria - hdoria.archlinux-br.org - e infelismente não está mais acessivel.

[]s


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#18 13/07/2009 14:30:42

Lyceuhns
Membro
Registrado: 25/03/2008
Mensagens: 424

Re: Ctrl+Alt+Backspace nao funfa no X

corvolino escreveu:

Gostaria de pedir desculpa, fiz uma pequena confusão.

O post não saiu no site e sim no antigo blog do hdoria - hdoria.archlinux-br.org - e infelismente não está mais acessivel.

[]s

Bandido!
Estava duvidando da capacidade do meu leitor de feeds (Google Reader). =x

o/

Offline

#19 13/07/2009 14:31:34

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: Ctrl+Alt+Backspace nao funfa no X

não =P


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#20 13/07/2009 14:38:59

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: Ctrl+Alt+Backspace nao funfa no X

Achei o link, so que aqui não ta abrindo.

http://hdoria.archlinux-br.org/blog/200 … backspace/

Para solucionar, olhe aqui também: http://ubuntuforum-br.org/index.php?PHP … #msg286667

espero ter ajudado.

Última edição por corvolino (13/07/2009 14:41:33)


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#21 13/07/2009 15:51:29

920608
Membro
Registrado: 26/11/2008
Mensagens: 658

Re: Ctrl+Alt+Backspace nao funfa no X

phillipe escreveu:
920608 escreveu:

sistematico, no seu caso pode ser também por ter isso no seu xorg.conf:

Section "ServerFlags"
    Option    "DontZap" "false"
EndSection

920608... Bem não sei se isso acontece com outros usuários, mas comigo a opção "DontZap" no xorg.conf não tava adiantando de nada, mesmo meu xorg tendo a opção [ Option "AutoAddDevices" "False" ] que desabilita o reconhecimento de teclado, mouse e outros pelo HAL.

phillipe, sua dica do HAL para o Ctrl+Alt+Backspace funcionou perfeitamente aqui. Mas nunca testei desabilitando o DontZap pelo xorg.conf.

Offline

#22 13/07/2009 19:34:56

rweu
Membro
De: Rio - RJ
Registrado: 25/11/2008
Mensagens: 226
Website

Re: Ctrl+Alt+Backspace nao funfa no X

Blz Phillipe,

Segui tuas orientações, e refiz meu mapa acrescentando somente a linha relativa ao CTRL+ALT+BACKSPACE e a parada agora funfou normalmente...aleluia.!!!!!!
Caraca, vou lá no meu post colocar [Resolvido]

OBS: Ao editar o arquivo, meu teclado passou a não responder mais em portugues; ele apesar de não estar como abnt2 e br nas linhas adequadas, estava funfando normalmente.
Eu simplesmente editei essas linhas colocando da forma correta, dei meu CTRL+ALT+BACKSPACE ( novinho em folha ) e tudo voltou ao normal!!

Grato a todos!!

Última edição por rweu (13/07/2009 19:35:56)


RWagner
http://rweu.blogspot.com
"Quem come prego sabe o... dia de amanhã..!!!...Titãs"

Offline

#23 13/07/2009 20:13:07

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: Ctrl+Alt+Backspace nao funfa no X

rweu escreveu:

Blz Phillipe,

Segui tuas orientações, e refiz meu mapa acrescentando somente a linha relativa ao CTRL+ALT+BACKSPACE e a parada agora funfou normalmente...aleluia.!!!!!!
Caraca, vou lá no meu post colocar [Resolvido]

OBS: Ao editar o arquivo, meu teclado passou a não responder mais em portugues; ele apesar de não estar como abnt2 e br nas linhas adequadas, estava funfando normalmente.
Eu simplesmente editei essas linhas colocando da forma correta, dei meu CTRL+ALT+BACKSPACE ( novinho em folha ) e tudo voltou ao normal!!

Grato a todos!!

Aeeeeeeeeeeeeee!!!!! lol

Conseguimos solucionar mais um problema! wink


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#24 13/07/2009 23:36:47

Lyceuhns
Membro
Registrado: 25/03/2008
Mensagens: 424

Re: Ctrl+Alt+Backspace nao funfa no X

corvolino escreveu:

não =P

=p

LOL
Foi uma afirmação, de fato ficou faltando um sujeito mais aparente, mas veja que eu afirmei (óia o ponto XP ):

Lyceuhns escreveu:

Estava duvidando da capacidade do meu leitor de feeds (Google Reader). =x/

Abraços corvoboy! o/

Offline

#25 14/07/2009 01:03:11

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: Ctrl+Alt+Backspace nao funfa no X

bjosmeliga


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

Rodapé do site