Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 28/02/2010 13:55:19

rgk
Membro
Registrado: 28/02/2010
Mensagens: 11

reiniciando 5 vezes para conectar eth0 (tcp/ip)

amigos,

eu configurei meu rc.conf para conectar a eth0 via tcp/ip aqui no lab. até aí, macio e brilhante.

só que quando eu conecto em casa via wlan0 (utilizo wicd, wicd-client):
1) o rede cai depois de ~1h de uso e eu tenho que reiniciar para conectar novamente. O wicd-client não consegue mais conectar se eu ñ reiniciar.

2) quando eu levo o lap para o lab depois de conectar em casa a wlan0, a conecção tcp/ip na eth0 não funciona, tenho que ficar reiniciando e fuçando até que misteriosamente ele funciona.


Alguém pode me dar uma luz?? Isso é bem chato, só hoje perdi ~1h com isso, uma vez tudo bem, todo dia ñ....

vlz,
rgk

Offline

#2 28/02/2010 18:25:08

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: reiniciando 5 vezes para conectar eth0 (tcp/ip)

mostra teu rc.conf (:


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#3 28/02/2010 18:47:59

rgk
Membro
Registrado: 28/02/2010
Mensagens: 11

Re: reiniciando 5 vezes para conectar eth0 (tcp/ip)

taí hermano:

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime", any other value will result
#   in the hardware clock being left untouched (useful for virtualization)
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.UTF-8"
HARDWARECLOCK="UTC"
TIMEZONE="America/Sao_Paulo"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=(iwl3945 uvcvideo)

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="myhost"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
# 
# DHCP:     Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#

#Static IP example
eth0="eth0 192.168.1.x netmask 255.255.255.0 broadcast 192.168.1.255"
#eth0="dhcp"
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.1.1"
ROUTES=(gateway)
 
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng network crond alsa hal)

Offline

#4 02/03/2010 09:14:28

rgk
Membro
Registrado: 28/02/2010
Mensagens: 11

Re: reiniciando 5 vezes para conectar eth0 (tcp/ip)

estranho que aqui no trampo, quando ele ñ se conecta (pq me conectei em casa antes), ele pinga nos outros computadores.

pensei em ser algum problema de dns. pode ser? tipo ele fica com o dns q usa em minha casa, mas quando venho para o lab ele ñ arruma um dns novo... só q, até onde entendi, o dns q serve aqui serve lá e em qualquer lugar, certo?

Offline

#5 02/03/2010 15:10:23

bino28
Membro
Registrado: 27/08/2009
Mensagens: 253

Re: reiniciando 5 vezes para conectar eth0 (tcp/ip)

Tinha este problema.

Defina uma regra para sua placa, como neste link: http://binoinformatica.com/blog/?p=225

[]'s

Offline

#6 02/03/2010 19:10:25

rgk
Membro
Registrado: 28/02/2010
Mensagens: 11

Re: reiniciando 5 vezes para conectar eth0 (tcp/ip)

não mermão, nada disso. o eth0 aqui é sempre o eth0, o wlan0 é sempre wlan0, isso tá funfando.

(no lap) O problema é que quando eu conecto pela wlan0 em casa, a eth0 conecta no trampo, pinga nos outros computadores, mas não navega.

Q para esquisita.

Alguma idéia??

valeu!

Offline

#7 02/03/2010 19:13:19

m0ska
Membro
De: Maceió-AL
Registrado: 07/08/2008
Mensagens: 102

Re: reiniciando 5 vezes para conectar eth0 (tcp/ip)

Usa o networkmanager big_smile

Offline

Rodapé do site