Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 17/01/2012 00:00:23

wf.Sam
Membro
Registrado: 29/08/2011
Mensagens: 68

pacman não atualiza. [RESOLVIDO]

galera fui atualizar o sistema hoje e dei de cara com essa msg:


:: Sincronizando a base de dados de pacotes...
core está atualizado
extra está atualizado
community está atualizado
archlinuxfr está atualizado
:: Os seguintes pacotes precisam ser atualizados antes :
    pacman
:: Você deseja cancelar a operação atual
:: e atualizar estes pacotes agora? [S/n]

resolvendo dependências...
procurando por conflitos interrelacionados...
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: packagekit: requer pacman<3.6.0
:: package-query: requer pacman<3.6
:: pacman-color: requer pacman<3.6

e agora?

Última edição por wf.Sam (18/01/2012 00:31:53)

Offline

#2 17/01/2012 09:13:09

leoarcher
Admin
De: Arapiraca - AL
Registrado: 13/07/2006
Mensagens: 1.259
Website

Re: pacman não atualiza. [RESOLVIDO]

wf.Sam escreveu:

galera fui atualizar o sistema hoje e dei de cara com essa msg:


:: Sincronizando a base de dados de pacotes...
core está atualizado
extra está atualizado
community está atualizado
archlinuxfr está atualizado
:: Os seguintes pacotes precisam ser atualizados antes :
    pacman
:: Você deseja cancelar a operação atual
:: e atualizar estes pacotes agora? [S/n]

resolvendo dependências...
procurando por conflitos interrelacionados...
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: packagekit: requer pacman<3.6.0
:: package-query: requer pacman<3.6
:: pacman-color: requer pacman<3.6

e agora?


E agora, você remove o yaourt, packagekit, package-query e pacman-color,


Se copiarem, forneçam a fonte de origem. Se alguma resposta te ajudou a solucionar o problema, por favor edite o título do tópico e adicione "[Resolvido]" a ele (sem as aspas). Obrigado!

asa_tempo.jpg

Offline

#3 17/01/2012 09:25:55

dodilei
Membro
Registrado: 17/01/2012
Mensagens: 1

Re: pacman não atualiza. [RESOLVIDO]

Tive esse mesmo problema e consegui resolver primeiro removendo o "yaourt, package-query e yajl" e depois reinstalando juntamente com as atualizações:

$ sudo pacman -Rns yaourt package-query

Depois atualizando com o comando:

$ sudo pacman -Syyu

Quando perguntando sobre atualizar antes o Pacman eu respondi com Não.

"
:: Os seguintes pacotes precisam ser atualizados antes :
    pacman
:: Você deseja cancelar a operação atual
:: e atualizar estes pacotes agora? [S/n] n
"

E tudo ficou bem!

Confira agora a versão do pacman:

$ pacman -V

.--.                  Pacman v4.0.1 - libalpm v7.0.1
/ _.-' .-.  .-.  .-.   Copyright (C) 2006-2011 Pacman Development Team
\  '-. '-'  '-'  '-'   Copyright (C) 2002-2006 Judd Vinet
'--'
                       Este programa pode ser redistribuído livremente sob
                       os termos da GNU General Public License

Offline

#4 17/01/2012 10:18:18

leoarcher
Admin
De: Arapiraca - AL
Registrado: 13/07/2006
Mensagens: 1.259
Website

Re: pacman não atualiza. [RESOLVIDO]


Se copiarem, forneçam a fonte de origem. Se alguma resposta te ajudou a solucionar o problema, por favor edite o título do tópico e adicione "[Resolvido]" a ele (sem as aspas). Obrigado!

asa_tempo.jpg

Offline

#5 18/01/2012 00:04:36

wf.Sam
Membro
Registrado: 29/08/2011
Mensagens: 68

Re: pacman não atualiza. [RESOLVIDO]

erro: unrar: signature from "Giovanni Scafora <[email protected]>" is unknown trust
erro: falha em submeter a transação (pacote inválido ou corrompido (assinatura PGP))
Ocorreram erros, nenhum pacote foi atualizado.

galera, atualixou mas da esse problema aew pra instalar qualquer coisa,

Offline

#6 18/01/2012 00:31:34

wf.Sam
Membro
Registrado: 29/08/2011
Mensagens: 68

Re: pacman não atualiza. [RESOLVIDO]

resolvido, substitui as informações do pacman.conf pelas do pacman.conf.pacnew q foi criado com a atualização, tudo ok agora vlw galera!

Offline

#7 18/01/2012 01:18:42

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: pacman não atualiza. [RESOLVIDO]

o avast falando que o site do technoobs tem vírus.. HUADHUADHUADHUD


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

Rodapé do site