Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 09/03/2007 23:07:20

dean
Membro
De: Curitiba-PR
Registrado: 09/03/2007
Mensagens: 1

Problemas com o QT-mt

Estou com um problema em compilar pacotes que pedem o qt o erro é o seguinte:


checking for Qt... configure: error: Qt (>= Qt 3.3) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

desde já VALEU!!!

Offline

#2 24/07/2007 13:38:31

Memphyx
Membro
De: Jandira/SP
Registrado: 28/06/2007
Mensagens: 169
Website

Re: Problemas com o QT-mt

Cara... estou com o mesmo problema com arch x86_64! Até agora mesmo apontando os diretórios corretos em uma compilação, continuo com o mesmo erro que você!

Alguém tem alguma idéia de como resolver isto?

Offline

#3 30/07/2007 14:16:19

Memphyx
Membro
De: Jandira/SP
Registrado: 28/06/2007
Mensagens: 169
Website

Re: Problemas com o QT-mt

Aleluia... enfim, boas novas!

Andei pesquisando na net e encontrei a solução e uma possível explicação para o problema de erro na compilação de pacotes que pedem a qt no Arch64.

1º - Eu instalei o KdeMod que instala a biblioteca qt-enhanced que não é compilada com a libthread/thread, por isto, causa problemas na compilação de softwares/pacotes que precisam da biblioteca qt-mt.

2º - Acredito também que os HowTo de instalação do KDE para o Arch, tanto em 32bits(i686) como em 64 (x86_64), pedem para instalar a qt-enhanced no lugar da qt em si, então é bem provável que muitos de nós poderemos passar pelo mesmo problema.

Solução:
A Solução que encontre foi no BBS do Arch Internacional, e foi enviada pelo usuário AndyRTR.

http://bbs.archlinux.org/viewtopic.php?id=18087

Fiz exatamente como ele recomendou mas modificando algumas coisas como segue abaixo:

pacman -Rd qt-enhanced
mkdir /opt/qt/qscintilla
cd /opt/qt/lib
mv libqtsintilla* ../qscintilla
rmdir /opt/qt/lib
pacman -S qt
cd /opt/qt/qscintilla
mv * ../lib
cd ..
rmdir qscintilla
ldconfig && updatedb


Pronto... após isto testei uma compilação de um software que pedia a Qt-mt e foi que foi. Uma maravilha! smile

Offline

Rodapé do site