Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 17/11/2012 23:57:54

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

[Resolvido] apache não inicia pelo systemd

estou tentando iniciar o apache pelo systemd mais ele sempre falha, quando inicio pelo apachectl funciona normalmente.

systemctl start httpd
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -n' for details.
journalctl -n
Nov 16 12:20:53 Victor-Arch_Linux systemd[1]: Starting Apache Web Server...
Nov 16 12:20:54 Victor-Arch_Linux systemd[1]: PID file /run/httpd/httpd.pid not readable (yet?) after start.
Nov 16 12:20:54 Victor-Arch_Linux systemd[1]: Failed to start Apache Web Server.
Nov 16 12:20:54 Victor-Arch_Linux systemd[1]: Unit httpd.service entered failed state
/usr/sbin/apachectl start
[sem output]

eu reportei no bug report do arch linux, mais foi fechado, dizendo que não era um bug. #32708
eu já reinstalei o apache, e o systemd mais não adiantou de nada.
Desde já, obrigado.

Última edição por hotvic (27/11/2012 16:48:53)


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#2 18/11/2012 08:58:21

danilo21
Membro
De: Rio de Janeiro, Rio de janeiro
Registrado: 19/04/2009
Mensagens: 193

Re: [Resolvido] apache não inicia pelo systemd

Amigo parece que este cara(do link abaixo) teve problemas similares com o BSD. Aparentemente ele chegou a conclusão que era o http.conf corrompido. Aqui estou com systemd e o apache está abrindo, não parece ser um bug generalizado, pelo menos no caso do link abaixo, após ele restaurar o httpd.conf por uma versão backup padrão, o apache voltou a abrir, o problema parece ter sido causado por sair de um editor de texto rapidamente de forma inadequada.
Abraços e  Boa sorte.
http://forums.freebsd.org/showthread.php?t=27073


<edit>

Na verdade parece que o cara acima não tem o mesmo problema que você, este sim tem:

http://forums.fedoraforum.org/showthread.php?t=281384
"
Ok found the trick.

if anyone has a "PID file /var/run/XXX.pid not readable (yet?) after start."

it's only a Pid path confusion between the init script and systemd.
if your service config file has another path that systemd standard path (/var/run/httpd for systemd)
so it will complain. the solution is to set PidFile in httpd.conf as /var/run/httpd/httpd.pid"

Parece que a solução é alterar a pasta destino do pid  no htttpd.conf.  Não entendi exatamente o por quê(se você entender explique-me, mais por curiosidade mesmo).

Última edição por danilo21 (18/11/2012 09:22:10)


Desenvolvedor de Software e Estudante de Ciência da Computação na PUC Rio desde 2012

Offline

#3 18/11/2012 19:16:29

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

eu adicionei:

PidFile /var/run/httpd/httpd.pid

ao httpd.conf, e mudei /usr/lib/systemd/system/httpd.service para /var/run/httpd/httpd.pid:

[Unit]
Description=Apache Web Server
After=network.target remote-fs.target nss-lookup.target

[Service]
Type=forking
PIDFile=/var/run/httpd/httpd.pid
ExecStart=/usr/sbin/apachectl start
ExecStop=/usr/sbin/apachectl graceful-stop
ExecReload=/usr/sbin/apachectl graceful
PrivateTmp=true
LimitNOFILE=infinity

[Install]
WantedBy=multi-user.target

e ainda falha quando tento inicialo:

Nov 18 18:12:19 Victor-Arch_Linux systemd[1]: Starting Apache Web Server...
Nov 18 18:12:21 Victor-Arch_Linux systemd[1]: PID file /var/run/httpd/httpd.pid not readable (yet?) after start.
Nov 18 18:12:21 Victor-Arch_Linux systemd[1]: Failed to start Apache Web Server.
Nov 18 18:12:21 Victor-Arch_Linux systemd[1]: Unit httpd.service entered failed state

o mais estranho é que o pelo apachectl inicia normalmente.

Última edição por hotvic (18/11/2012 19:17:37)


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#4 18/11/2012 20:25:21

danilo21
Membro
De: Rio de Janeiro, Rio de janeiro
Registrado: 19/04/2009
Mensagens: 193

Re: [Resolvido] apache não inicia pelo systemd

Umas perguntas.
Você está com a última versão do apache?
Existe alguma chance do processo ter morrido ou o sistema ter sido desligado de forma inadequada e o arquivo .pid existe mesmo antes de tentar abrir o apache?

Uma sugestão meio aleatória seria tentar mover o arquivo .pid para uma pasta qualquer(ou renomea-lo como .bkp) e tentar abrir o apache em seguida.
Parece que você não tem permissão ou sobre a pasta ou sobre o arquivo... Muito estranho. A pasta /run/httpd ou a nova existem?


Desenvolvedor de Software e Estudante de Ciência da Computação na PUC Rio desde 2012

Offline

#5 18/11/2012 20:40:39

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

tudo está certo, o apache está na ultima versão como postei lá no bug report.

se eu iniciar o apache por fora do systemd, ou seja usando apachectl, ou mesmo rodando httpd, ele iniciar normalmente sem erro ou aviso qualuer, o problema é na hora de iniciar o usando o systemctl, sempre falha, eu acredito que o apache não tenha nada a ver com isso e que a cupa toda seja do systemd.
mais tou meio perdido, por isso que criei este tópico.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#6 19/11/2012 11:39:34

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: [Resolvido] apache não inicia pelo systemd

você instalou este pacote?
https://aur.archlinux.org/packages/systemd-httpd-units/

existe no /usr/lib/tmpfiles.d

o arquivo httpd.conf

parece que não está sendo criado o arquivo /var/run/httpd/httpd.pid

Já tentou criar no etc

/etc/tmpfiles.d/httpd.conf

d	/var/run/httpd			710	root	apache

Offline

#7 19/11/2012 13:17:49

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

$ stat /var/run/httpd/httpd.pid 
stat: impossível obter estado de “/var/run/httpd/httpd.pid”: Arquivo ou diretório não encontrado
$ sudo apachectl start
$ stat /var/run/httpd/httpd.pid 
  File: “/var/run/httpd/httpd.pid”
  Size: 5               Blocks: 8          IO Block: 4096   arquivo comum
Device: eh/14d  Inode: 49176       Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2012-11-19 12:08:28.379576213 -0300
Modify: 2012-11-19 12:08:28.379576213 -0300
Change: 2012-11-19 12:08:28.379576213 -0300
 Birth: -
$ cat /var/run/httpd/httpd.pid 
1024
$ sudo apachectl stop
$ stat /var/run/httpd/httpd.pid 
stat: impossível obter estado de “/var/run/httpd/httpd.pid”: Arquivo ou diretório não encontrado

vejo que o arquivo de pid está sendo criado normalmente, por isso acho que a culpa seja do systemd.

$ sudo chown http.http /var/run/httpd/
$ sudo chmod 0750 /var/run/httpd/
$ sudo systemctl start httpd
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -n' for details.
$ su -c 'echo "D /var/run/httpd 0750 http http -" > /etc/tmpfiles.d/httpd.conf'
$ sudo systemctl start httpd
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -n' for details.

não adiantou ainda falha, oo troço pra me causar dor de cabeça é esse systemd.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#8 19/11/2012 13:56:42

danilo21
Membro
De: Rio de Janeiro, Rio de janeiro
Registrado: 19/04/2009
Mensagens: 193

Re: [Resolvido] apache não inicia pelo systemd

Este pacote citado pelo swatquest não é mais necessário, no próprio link isto é citado. Atualmente o httpd.service "correto" é incluído no apache.
Eu realmente não sei o que está acontecendo, não parece ter nenhum sentido.


Desenvolvedor de Software e Estudante de Ciência da Computação na PUC Rio desde 2012

Offline

#9 19/11/2012 19:46:52

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

isso é o que mais me deixa doido, com o systemd sempre aparece problemas sem sentido algum.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#10 20/11/2012 00:08:54

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: [Resolvido] apache não inicia pelo systemd

já viu a saida do journalctl

journalctl _SYSTEMD_UNIT=httpd.service

veja se tem alguma modificação errada nas units
systemd-delta

Offline

#11 20/11/2012 01:42:08

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

journalctl _SYSTEMD_UNIT=httpd.service
não retorna nada alem de "-- Logs begin at Sat, 2012-11-10 09:48:20 BRT, end at Sat, 2012-11-10 09:51:38 B"

$ sudo systemd-delta
[EQUIVALENT] /etc/systemd/system/default.target → /usr/lib/systemd/system/defaul

1 overridden configuration files found.

Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#12 20/11/2012 02:09:59

sistematico
Admin
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.023
Website

Re: [Resolvido] apache não inicia pelo systemd

Você deve estar usando o Apache 1.x ou algo assim.
Aqui o Apache + Systemd está funcionando normal, porem, meu arquivo httpd.service é completamente diferente do seu.
Qual sua versão do Apache?

Só uma dica, nunca altere nada em /usr/lib/systemd, copie o arquivo para /etc/systemd e altere lá.

Um abraço.

Offline

#13 20/11/2012 12:27:08

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

"Só uma dica, nunca altere nada em /usr/lib/systemd, copie o arquivo para /etc/systemd e altere lá.", obrigado pela dica.

$ pacman -Qi apache
Nome                 : apache
Versão               : 2.2.23-1
URL                  : http://www.apache.org/dist/httpd
Licenças             : APACHE
Grupos               : Nenhum
Provê                : Nenhum
Depende De           : openssl  zlib  apr-util  pcre
Depend. Opcionais    : lynx: apachectl status
Necessário Para      : mod_dnssd  php-apache
Conflita Com         : Nenhum
Substitui            : Nenhum
Tamanho Instalado    : 4964,00 KiB
Empacotador          : Jan de Groot <[email protected]>
Arquitetura          : i686
Data da Compilação   : Qua 19 Set 2012 19:43:04 BRT
Data da Instalação   : Sex 16 Nov 2012 12:17:30 BRT
Motivo da instalação : Instalado explicitamente
Script de Instalação : Sim
Descrição            : A high performance Unix-based HTTP server

no httpd.service eu só mudei a o local do arquivo de Pid, o resto está como vei no pacote, que reinstalei antes de ontem.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#14 20/11/2012 13:56:16

danilo21
Membro
De: Rio de Janeiro, Rio de janeiro
Registrado: 19/04/2009
Mensagens: 193

Re: [Resolvido] apache não inicia pelo systemd

O meu httpd.service é idêntico ao do hotvic, exceto que ainda aponta para o .pid original(em /run/httpd/httpd.pid).
Cara realmente não sei o que fazer, tente remover completamente o apache e instalar denovo.
O único cara que vi com o mesmo problema no forum gringo reinstalou o sistema.
verifique se existe algum processo httpd aberto e mate, depois

#systemctl disable httpd
#pacman -Rcsun apache
#ls /run/httpd/
-- se houver arquivo .pid, delete.

Atenção: O Arquivo httpd.conf vai sumir, faça backup.
Depois reinstale o apache tente abri-lo pelo systemd.
Se não funcionar eu desisto de tentar te ajudar, aconselharia você a procurar um Guru, Padre, Pastor, ou alguém da sua religião favorita,sei lá.
Boa Sorte.

PS: Eu suponho que não, mas você não tem mais rc.conf né? se tem poste.

Última edição por danilo21 (20/11/2012 14:34:56)


Desenvolvedor de Software e Estudante de Ciência da Computação na PUC Rio desde 2012

Offline

#15 20/11/2012 18:32:18

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

removi o apache do jeito que você mandou, e instalei novamente, tentei iniciar e ainda deu erro, e olha que eu nem tinha recuperado o backup do httpd.conf.

o rc.conf tinha, mais apenas continha uns daemons, que já exclui, o rc.conf estava rc.conf.pacsave, eu devo ter movido sem querer, mais enfim, não tem mais já reinstalei o apache, e não deu certo.

Edit:
vou continuar esperando alguém me ajudar, pois não estou usando windows, pra que quando ter um problema a única solução ser reinstalar.

Última edição por hotvic (20/11/2012 18:34:46)


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#16 20/11/2012 22:26:02

sistematico
Admin
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.023
Website

Re: [Resolvido] apache não inicia pelo systemd

Cola o /etc/systemd/system/httpd.service

Offline

#17 20/11/2012 22:57:35

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: [Resolvido] apache não inicia pelo systemd

ahhhhh..
ok..
Só pelas modificações que você fez não seria possível ter só isso.

[EQUIVALENT] /etc/systemd/system/default.target → /usr/lib/systemd/system/defaul

1- recomendo você remover o default.target do /etc. ( por padrão graphical.target)

O  /etc/systemd/system/default.target só serve na hora de modificar para target multi-user

para aplicar :
systemctl enable multi-user.target

E não aparece [EQUIVALENT] e sim [REDIRECTED]
[REDIRECTED]   /etc/systemd/system/default.target → /usr/lib/systemd/system/default.target

Se está usando um gerenciador de login ..kdm,gdm,slim,lxdm...

systemd enable kdm.service

então  rm /etc/systemd/system/default.target

depois deste procedimento adicione novamente a saida do systemd-delta.

não precisa ser root para executar o  systemd-delta

Última edição por swatquest (20/11/2012 23:45:10)

Offline

#18 20/11/2012 23:32:05

sistematico
Admin
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.023
Website

Re: [Resolvido] apache não inicia pelo systemd

Peraí, num era o Apache?

Offline

#19 20/11/2012 23:34:57

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: [Resolvido] apache não inicia pelo systemd

sistematico

é que pedi para ele executar o  systemd-delta para ver as modificações feitas nas units.

Última edição por swatquest (20/11/2012 23:35:41)

Offline

#20 21/11/2012 00:25:37

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

"E não aparece [EQUIVALENT] e sim [REDIRECTED]", eu não sei, eu apenas copiei o output.
eu também achei estranha o só mostrar isso.

fiz o que você mandou, e agora apareceu quase a mesma coisa(apareceu do jeito que você falou):

[REDIRECTED]   /etc/systemd/system/default.target → /usr/lib/systemd/system/defa

1 overridden configuration files found.

ainda continua aparecendo somente 1, eu acho estranho.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#21 21/11/2012 00:41:15

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: [Resolvido] apache não inicia pelo systemd

ok..

Se você não mascarou ou modificou nenhuma units, então ok.

Você desabilitou modo graphical, então está correto. Se quiser habilitar em modo graphical. então remova o  /etc/systemd/system/default.target

Pois ainda indica que o arquivo /etc/systemd/system/default.target existe.

então  rm /etc/systemd/system/default.target

ou

systemctl disable multi-user.target

Na saida do comando systemd-delta não era para aparecer.

Aqui eu mascarei e modifiquei algumas units.

[OVERRIDDEN] /etc/systemd/system/[email protected] → /usr/lib/systemd/system/[email protected]

--- /usr/lib/systemd/system/[email protected]      2012-10-24 22:37:52.000000000 -0
+++ /etc/systemd/system/[email protected]  2012-11-20 23:53:45.187519659 -0200
@@ -1,49 +1,5 @@
-#  This file is part of systemd.
-#
-#  systemd is free software; you can redistribute it and/or modify it
-#  under the terms of the GNU Lesser General Public License as published by
-#  the Free Software Foundation; either version 2.1 of the License, or
-#  (at your option) any later version.
-
-[Unit]
-Description=Getty on %I
-Documentation=man:agetty(8)
-After=systemd-user-sessions.service plymouth-quit-wait.service
-After=rc-local.service
-
-# If additional gettys are spawned during boot then we should make
-# sure that this is synchronized before getty.target, even though
-# getty.target didn't actually pull it in.
-Before=getty.target
-IgnoreOnIsolate=yes
-
-# On systems without virtual consoles, don't start any getty. (Note
-# that serial gettys are covered by [email protected], not this
-# unit
-ConditionPathExists=/dev/tty0
+.include /usr/lib/systemd/system/[email protected]
 
 [Service]
-Environment=TERM=linux
 # the VT is cleared by TTYVTDisallocate
-ExecStart=-/sbin/agetty --noclear %I 38400
-Type=idle
-Restart=always
-RestartSec=0
-UtmpIdentifier=%I
-TTYPath=/dev/%I
-TTYReset=yes
-TTYVHangup=yes
-TTYVTDisallocate=yes
-KillMode=process
-IgnoreSIGPIPE=no
-
-# Unset locale for the console getty since the console has problems
-# displaying some internationalized messages.
-Environment=LANG= LANGUAGE= LC_CTYPE= LC_NUMERIC= LC_TIME= LC_COLLATE= LC_MONET
-
-# Some login implementations ignore SIGTERM, so we send SIGHUP
-# instead, to ensure that login terminates cleanly.
-KillSignal=SIGHUP
-
-[Install]
-Alias=getty.target.wants/[email protected]
+TTYVTDisallocate=no

[MASKED]     /etc/systemd/system/systemd-readahead-replay.service → /usr/lib/sys
[MASKED]     /etc/systemd/system/sys-kernel-debug.mount → /usr/lib/systemd/syste
[MASKED]     /etc/systemd/system/dev-mqueue.mount → /usr/lib/systemd/system/dev-
[MASKED]     /etc/systemd/system/systemd-readahead-done.timer → /usr/lib/systemd
[MASKED]     /etc/systemd/system/systemd-readahead-collect.service → /usr/lib/sy
[MASKED]     /etc/systemd/system/cryptsetup.target → /usr/lib/systemd/system/cry
[OVERRIDDEN] /etc/systemd/system/iptables.service → /usr/lib/systemd/system/ipta

--- /usr/lib/systemd/system/iptables.service    2012-10-15 15:49:42.000000000 -0
+++ /etc/systemd/system/iptables.service        2012-11-20 23:58:33.462553943 -0
@@ -1,11 +1,4 @@
-[Unit]
-Description=Packet Filtering Framework
-
-[Service]
-Type=oneshot
-ExecStart=/usr/sbin/iptables-restore /etc/iptables/iptables.rules
-ExecStop=/usr/lib/systemd/scripts/iptables-flush
-RemainAfterExit=yes
+.include /usr/lib/systemd/system/iptables.service
 
-[Install]
-WantedBy=multi-user.target
+[Unit]
+Before=network.target

[MASKED]     /etc/systemd/system/dev-hugepages.mount → /usr/lib/systemd/system/d
[MASKED]     /etc/systemd/system/systemd-readahead-done.service → /usr/lib/syste

10 overridden configuration files found.

Para editar as units você pode usar o include.

Uma modidicação da unit iptables.service
Criei um arquivo no   /etc/systemd/system/ chamado iptables.service
o arquivo

.include /usr/lib/systemd/system/iptables.service

[Unit]
Before=network.target

Veja se tem algum arquivo de backup destro da pasta e subpastas em   /etc/systemd/system/

acho que o kate tem essa função de criar arquivos de backups

o systemd pode apresentar erro com arquivos de backups. ex. iptables.service~

Última edição por swatquest (21/11/2012 00:51:57)

Offline

#22 21/11/2012 01:31:07

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

removi o /etc/systemd/system/default.target

e agora não mostra nenhuma modificação.

$ systemd-delta 
0 overridden configuration files found.

procurei por aquivos de backup, não encontrei nenhum(desativei essa função em todos editores que uso).

$ find /etc/systemd/system/ -name *~

mais o apache ainda falha ao iniciar pelo systemctl.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#23 21/11/2012 01:36:02

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

um detalhe, que não sei se vai servir.

se eu iniciar o apache pelo apachectl, e depois iniciar pelo systemctl(com o apache iniciado), ele inicia normalmente.

ao que me parece o apache está demorando a criar o arquivo de Pid, e nesse meio tempo o systemd entra em estado de falha.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#24 21/11/2012 03:09:53

sistematico
Admin
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.023
Website

Re: [Resolvido] apache não inicia pelo systemd

Você ainda não colou o arquivo que eu te pedi.

Offline

#25 21/11/2012 11:46:10

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [Resolvido] apache não inicia pelo systemd

se for a unit, eu já coloquei, aqui

## Essa é a atual sem modificação nenhuma, ou seja a que veio no pacote
[Unit]
Description=Apache Web Server
After=network.target remote-fs.target nss-lookup.target

[Service]
Type=forking
PIDFile=/run/httpd/httpd.pid
ExecStart=/usr/sbin/apachectl start
ExecStop=/usr/sbin/apachectl graceful-stop
ExecReload=/usr/sbin/apachectl graceful
PrivateTmp=true
LimitNOFILE=infinity

[Install]
WantedBy=multi-user.target

Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

Rodapé do site