Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 06/08/2007 19:23:01

tonhoo
Tonho da Lua
Registrado: 06/08/2007
Mensagens: 8

X Travando

Bom não consegui colocar um topico mais preciso, mas acredito que esse quebre um galho.

A algum tempo venho enfrentado em meu arch, o X travando fazendo com que ele paralize totalmente a maquina sem poder ir para o modo texto e quando trava, o mouse continua funcionando o som tambem, eventualmente ontem estava assistindo Naruto (Recomendo big_smile)  o X travou do nada, apenas o som funcionava, o mouse nada e o video tambem nada, todas as teclas sem funcionamento, o led do NumLock ScrollLock e Caps Lock tambem não funcionavam.
Atualmente acrecido desse problema tambem o X não quer iniciar, logo em minha maquina como usuario dou um startx, ele inicia o X mas vai para uma tela preta.
Me desculpe caso fique incoeso o texto, so péssimo em português sad .

Ficaria agradecido se caso pudessem me ajudar ou ao menos me indicar aonde ficariam os logs desse "erro".

Obrigado
Gabriel S. Ames


[email protected] #ArchLinux-BR

Offline

#2 07/08/2007 16:58:20

hokahey
Membro
De: Rio de Janeiro
Registrado: 11/07/2006
Mensagens: 50

Re: X Travando

Acho interessante você fazer o básico.

- Verifique os drivers que você colocou na sua placa de vídeo e recompile.
- Verificar se sua placa esta bem instalada na sua cpu
- Colar o log do travamento aqui (/var/log etc....)


- H 0 ka h3y -
Arch Linux Brasil

Offline

#3 08/08/2007 18:34:26

TonySP
Membro
De: Florianópolis - SC
Registrado: 16/07/2006
Mensagens: 35

Re: X Travando

Se acontece depois de um tempo, pode ser algo relativo ao gerenciamento de energia ou mesmo ao screensaver, mais as possibilidades que o hokahey já passou...

Talvez não seja possível você ver nada no log do X, porque afinal se o X continua rodando (o mouse e o som confirmam isso), mas tente de início adicionar o parâmetro de boot noacpi


./configure --prefix=/floripa --enable-gatas --enable-praia --disable-chefe --without-money

Offline

#4 04/10/2007 13:16:42

cyber_punk
Membro
Registrado: 12/09/2007
Mensagens: 8

Re: X Travando

estou com o mesmo problema
e tem a ver com a placa de vídeo  e o maldito acpi
e não é só com o arch (pelo menos aqui )

estou com um

arch 2007.08.1   i686     ( mesmo problema com X86_64 )

AMD Athlon(tm) 64 X2 Dual Core Processor 3600+ 
HD SATA 80 GB samsung
1 GB DDR2
NVIDIA® GeForce® 7300 GS 
xorg-server 7.3 ( mesmo problema em versões anteriores )
driver nvidia 100.14.19 


problema é quando eu ativo o driver nvidia no XF86Config ( xorg.conf da versão 7.3 )

depois de um tempo trava e nada mais acontece, só volta se reiniciar o pc,  se colocar essas opções no menu.lst  para de "congelar" 

# (0) Arch Linux
title Arch Linux
root (hd0,0)
kernel /boot/vmlinuz26 root=/dev/sda1 ro noapic acpi=off
initrd /boot/kernel26.img

# (1) Arch Linux
title Arch Linux Fallback
root (hd0,0)
kernel /boot/vmlinuz26 root=/dev/sda1 ro
initrd /boot/kernel26-fallback.img

porém, ao fazer isso depois de um tempo o pc começa a travar  e para e volta a  travar ¬¬  mais dessa vez é como se estivesse em uso de 100 % da CPU sabe? quando fica tudo lerdo

tirei a opção do menu.lst  e estou usando a porcaria do driver genérico NV  , que não é justo pois paguei caro pra ter uma placa de vídeo 3D  e eu quero usar.


se eu add somente noacpi  o boot  trava

Offline

#5 04/10/2007 14:21:22

hdoria
Membro
Registrado: 02/10/2007
Mensagens: 131
Website

Re: X Travando

Você poderia colar seu xorg.conf? Qual o modelo de sua placa? Já rodou o hwd -x ou o nvidia-xconfig?


http://hdoria.archlinux-br.org

Se minha resposta o ajudou a solucionar seu problema, por favor, adicione "[resolvido]" ao título do tópico. Isso ajudará e facilitará a vida das outras pessoas. :-)

Offline

#6 04/10/2007 15:19:10

cyber_punk
Membro
Registrado: 12/09/2007
Mensagens: 8

Re: X Travando

NVIDIA GeForce 7300 GS   

img?s=MLB&f=57836141_3607.jpg&v=P


ja usei , hwd -x, nvidia-xconfig e X -configure

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  ([email protected])  Wed Sep 12 14:29:35 PDT 2007

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    RgbPath         "/usr/share/X11/rgb"
    ModulePath      "/usr/lib/xorg/modules"
    FontPath        "/usr/share/fonts/misc"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/TTF"
    FontPath        "/usr/share/fonts/Type1"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "glx"
    Load           "xtrap"
    Load           "record"
#    Load  "dri"
    Load           "freetype"
    Load           "type1"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"

    #DisplaySize      340   270    # mm
 ### Comment all HorizSync and VertRefresh values to use DDC:
    Identifier     "Monitor0"
    VendorName     "PHL"
    ModelName      "Philips 170S"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"               # [<bool>]
        #Option     "HWcursor"               # [<bool>]
        #Option     "NoAccel"                # [<bool>]
        #Option     "ShadowFB"               # [<bool>]
        #Option     "UseFBDev"               # [<bool>]
        #Option     "Rotate"                 # [<str>]
        #Option     "VideoKey"               # <i>
        #Option     "FlatPanel"              # [<bool>]
        #Option     "FPDither"               # [<bool>]
        #Option     "CrtcNumber"             # <i>
        #Option     "FPScale"                # [<bool>]
        #Option     "FPTweak"                # <i>
        #Option     "DualHead"               # [<bool>]
    Identifier     "Card0"
    Driver         "nv"
    VendorName     "nVidia Corporation"
    BoardName      "G71 [GeForce 7300 GS]"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

Offline

#7 05/10/2007 00:45:51

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: X Travando

fica mostrando uma tela e falando para trocar o X de número?


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#8 05/10/2007 23:55:30

cyber_punk
Membro
Registrado: 12/09/2007
Mensagens: 8

Re: X Travando

não, simplesmente congela , para tudo , nem o mouse funciona

não tem log de erro, não da aviso , é do nada isso

só se a placa de video estiver ativada, se usar o driver nv normal,  mas é ruim por q fica lento

Offline

#9 14/10/2007 11:22:52

ropcker
Membro
Registrado: 09/10/2007
Mensagens: 32

Re: X Travando

ctz que deve ser o driver então...
se vc muda o driver e para de congelar... ctz..

Offline

#10 13/03/2008 18:48:23

sparta
Membro
Registrado: 12/03/2008
Mensagens: 47

Re: X Travando

dá um upgrade no x ou baixa o pacote e instala na mao mano, vai que sua conecao te mandou um arquivo meio corrompido por causa da sua conexao , te falar a verdade, baixo todos os pacotes, gravo no cd, e instalo manualmente, te garanto, pal ? impossivel.

Offline

Rodapé do site