Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via [email protected]

Para mais informações: [email protected]

#1 02/05/2016 12:42:54

jonathanbarboza
Membro
Registrado: 02/05/2016
Mensagens: 1

Steam não abre no Arch linux

Bom eu fiz a parada do multilib la de tirar o # e consegui instalar. Depois ele atualizou e nao abriu, fui e clickei no icone para abrir ele e nada...

Eu sou novato no arch e linux em geral... nao manjo muito de comandos e tals entao pf quem puder me ajudar agradeço desde já

to usando o Arch Linux com gnome e grafico wayland.

Offline

#2 02/05/2016 14:46:23

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.610

Re: Steam não abre no Arch linux

Se você tenta abrir o steam via termial apresenta algum erro?

Offline

#3 31/05/2016 01:33:40

dalcolli
Membro
Registrado: 31/05/2016
Mensagens: 1

Re: Steam não abre no Arch linux

executa o comando steam no terminal e depois manda o que aparece.
Provavelmente ta faltando isto aqui

sudo pacman -S lib32-nvidia-libgl

yaourt -S steam-fonts

Offline

#4 23/06/2016 22:50:02

Filipe Araújol
Membro
Registrado: 13/06/2016
Mensagens: 9

Re: Steam não abre no Arch linux

Acabei de chegar no Arch, meu sistema está todo funcionando, apenas a Steam que não roda de jeito nenhum. Já segui vários tutoriais na internet e até agora não consegui rodar. Olhem o erro:

[[email protected] ~]$ steam
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
Running Steam on arch  64-bit
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Alguém tem alguma dica pra resolver esse problema?

Offline

#5 24/06/2016 00:45:40

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.610

Re: Steam não abre no Arch linux

Oi amigo.

Pelo que vi parece que você usa placa de video intel.

De uma olhada aqui
https://wiki.archlinux.org/index.php/Intel_graphics

Muitos recomendam até usar o modesetting do kernel em vez de xf86-video-intel.

Pelo erro
libGL error: unable to load driver: i965_dri.so

Instale o pacote mesa para aceleração 3D
Para habilitar o suporte OpenGL , também instale o mesa-libgl.Para suporte 32-bit , instale lib32-mesa-libgl do repositório multilib.

Última edição por swatquest (24/06/2016 00:47:21)

Offline

#6 24/06/2016 05:38:28

Filipe Araújol
Membro
Registrado: 13/06/2016
Mensagens: 9

Re: Steam não abre no Arch linux

Já chequei todos os drivers amigo, segui todos os tutoriais e nada, mas resolvi a primeira parte do problema, executando o Steam dava:

[[email protected] ~]$ steam
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
Running Steam on arch  64-bit
/home/filipe/.local/share/Steam/steam.sh: line 161: VERSION_ID: variável não vinculada
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

Existem dois erros aí, o primeiro é um erro na linha 161 e o segundo o "libGL". No primeiro caso, dá um erro na linha 161 do "steam.sh", pois tenta iniciar "VERSION_ID" de "/etc/os-lançamento", o Arch possui "/etc/os-lançamento", mas ele não tem um "VERSION_ID".
A solução é alterar a linha 160 de "steam.sh", de:

elif [ -f /etc/os-release ]; then


para algo como isto:

elif $(grep 'VERSION_ID' /etc/os-release > /dev/null 2>&1); then


Isso faz com que "steam.sh" passe a usar o fallback genérico.
Depois de corrigir esse erro acima, pode acontecer de dar esse erro abaixo:

/home/runningdroid/.local/share/Steam/steam.sh: line 710: LD_LIBRARY_PATH: unbound variable


Geralmente "LD_LIBRARY_PATH" não é definido por padrão, então para corrigir isso vamos mudar a linha 710, de:

export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/lib32"


para

export LD_LIBRARY_PATH="${LD_LIBRARY_PATH:-/usr/lib}:/usr/lib32"


Para acessar "steam.sh" basta seguir esse caminho "/home/USUÁRIO/.local/share/Steam" e abrir o steam.sh com o geany para editar as linhas. Eu usei esse processo porque estou com Gnome, não sei se o caminho é o mesmo nas outras interfaces. Mas o princípio é o mesmo e funcionou pra mim. Para o segundo erro, o da libGL, eu achei a solução na wi do arch, estava em inglês então traduzir pra facilitar pra vocês. Quem quiser ir lá mesmo assim, o link está lá no final.

O erro de libGL se dá porque a Steam instala suas próprias versões mais antigas de algumas bibliotecas coletivamente chamadas de "Steam Runtime". Pode acontecer dessas bibliotecas do Steam entrar em conflito com as bibliotecas incluídas no Arch Linux. Para resolver esse problema, você pode forçar a Steam para usar as versões do sistema (aquelas instalados pelo pacman ). Há duas maneiras de fazer isso:

1 - Usando o vinculador dinâmico, rode esse comando no terminal para fazer a Steam rodar imediatamente:

LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' steam


Se você quiser usar esse método em um atalho .desktop, você pode usar este comando no Exec=campo.

Exec=env LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' /usr/bin/steam %U



2 - Excluindo as bibliotecas de tempo de execução, Execute este comando para excluir as bibliotecas de execução conhecidas por causar problemas no Arch Linux:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

Se o comando acima não funciona, execute o comando acima novamente, em seguida, executar este comando.

find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete


Eu rodei o primeiro comando da opção 1 e a Steam rodou na hora, mas pelo terminal. O segundo comando da opção 1 eu não entendi, então parti pra opção dois e o primeiro comando já fez a Steam funcionar pelo atalho.
Link da wi: https://wiki.archlinux.org/index.php/St … leshooting

Última edição por Filipe Araújol (25/06/2016 00:29:29)

Offline

#7 25/06/2016 00:27:36

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.610

Re: Steam não abre no Arch linux

Oi amigo .

Veja se resolve
https://bugs.archlinux.org/task/48994

find ~/.steam/root/ -name "libgpg-error.so*" -print -delete

Offline

#8 25/06/2016 00:31:08

Filipe Araújol
Membro
Registrado: 13/06/2016
Mensagens: 9

Re: Steam não abre no Arch linux

Muito obrigado amigo, quando tu postou aqui eu já tinha resolvido o problema. kkk
Mas obrigado mesmo assim, editei minha resposta de cima com a maneira que resolveu meu problema pra quem precisar.

Offline

#9 25/06/2016 00:43:23

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.610

Re: Steam não abre no Arch linux

Blz..

Coloque a tag [RESOLVIDO] no tópico.

Offline

#10 25/06/2016 01:54:00

Filipe Araújol
Membro
Registrado: 13/06/2016
Mensagens: 9

Re: Steam não abre no Arch linux

Como que eu faço isso?

Offline

#11 25/06/2016 16:38:15

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.610

Re: Steam não abre no Arch linux

blz..

Não tem como..
Não foi você que criou o tópico.

Offline

#12 05/07/2016 00:37:44

Adriano_Gon
Membro
Registrado: 03/06/2016
Mensagens: 12

Re: Steam não abre no Arch linux

Cara ajudou muito valeu mesmo.

Offline

Rodapé do site