Você não está autenticado.

#1 17/07/2016 03:48:30

beagle
Membro
Registrado: 31/08/2015
Mensagens: 74

Removi o linux e ficou no meu boot a entrada

Oi galera,

Então, deixa eu resumir. Eu estava com o windows10 aqui, aí particionei o disco pra instalar o linux. Entrei no linux via live usb, fiz a instalação.
Na hora de escolher o disco, selecionei o disco que já havia o windows (com as duas particoes padrao do windows, ntfs) entao o espaço livre criei mais duas. A ROOT e a do BOOT/EFI.
Então mandei instalar.
Acontece que eles só deixou instalar o grub2 (tem a ver com esse efi não?) e daí quando a máquina iniciou, entrou o grub2 somente com UMA opcao, a do linux (a do windows não achou mais).
Dai, resolvi tirar tudo.
Botei o live usb de novo, limpei as particoes do linux e deixei so a do windows, entrei com o pendrive no windows e mandei recuperar. Recuperou.

Porém, lá na minha bios ficou a entrada do LINUX!
Essa entrada foi criada quando instalei o linux. Pelo que vi (no menu de boot que aparece todos meus hds), aparece essa entrada + todos meus HDS. Daí ele entrava nessa ENTRADA e ia para o grub2 (onde eu selecionava o linux, e não aparecia o windows).
Parece que ele mudou algo ANTES do grub2, tinha pesquisado na internet até achei algo por alto mas não entendi direito.

Alguém aí poderia me ajudar? Eu entrei na bios e desabilitei essa entrada, deixei só a do windows (do hd que está o windows). Está entrando normal, mas a entrada ficou lá. Como remover ela?

Obrigado desde ja...

Offline

#2 17/07/2016 03:53:31

beagle
Membro
Registrado: 31/08/2015
Mensagens: 74

Re: Removi o linux e ficou no meu boot a entrada

Pesquisando achei isso. https://br.answers.yahoo.com/question/i … 45AAcbtfT#
Vejam aí acho que é esse o meu problema.. será que via ubuntu consigo? Pois eu tinha instalado o MANJARO. Pelo manjaro faço isso ou posso usar o ubuntu mesmo?

Nobre colega tem jeito de corrigir.
Te recomendo usar um live cd do ubuntu pra isto:

1)Dê o boot pelo live cd do Ubuntu;
2)Escolha a opção de teste "try before installing"
3)Com o uuntu iniciado use o terminal de root (Alt+F2)
3)Inicie uma seção de root (sudo su)
4)Instale efibootmgr, fica assim: sudo apt-get install efibootmgr
6)Instale o kernel (interface) do programa: sudo modprobe efivars
7)Com o efibootmgr instalado você poderá visualizar as entradas de boot (opção -v) e remover a uefi do Ubuntu via Terminal (opção -b ou -B), conforme desejar eliminar uma seção, no meu caso fica assim a tela:

$ sudo efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,0003
Boot0000* rEFInd Boot Manager HD(1,28,96000,bc34b60c-6611-492f-99b0-d2...
Boot0001* fedora HD(1,28,96000,bc34b60c-6611-492f-99b0-d2...
Boot0003* ubuntu HD(1,28,96000,bc34b60c-6611-492f-99b0-d2...
$ sudo efibootmgr -b 3 -B
Fonte(s):
http://askubuntu.com/questions/263028/h … ot-options

http://askubuntu.com/questions/63610/ho … -menu-uefi

http://linux.die.net/man/8/efibootmgr

Offline

#3 17/07/2016 15:56:18

beagle
Membro
Registrado: 31/08/2015
Mensagens: 74

Re: Removi o linux e ficou no meu boot a entrada

Galera, to aqui no live usb. E rodei o comando ali sudo efibootmgs e retornou

efibootmgr: EFI variables are not supported on this system.

E agora o que faco? Ficou aquela entrada la na minha bios!!

Offline

#4 17/07/2016 17:58:54

beagle
Membro
Registrado: 31/08/2015
Mensagens: 74

Re: Removi o linux e ficou no meu boot a entrada

Tentei pegar o programa easyuefi no windows.
http://easyuefi.com/index-us.html

E não deu. ERRO
EasyUEFI can only be installed on (U)EFI-based windows operating system.

Pelo jeito vou ter que fazer pelo linux mesmo.

EDIT
Mais uma solucao e nada.
http://superuser.com/questions/930725/h … -boot-menu

Vou tentar pelo manjaro.

Última edição por beagle (17/07/2016 18:26:16)

Offline

#5 18/07/2016 23:57:25

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.298

Re: Removi o linux e ficou no meu boot a entrada

Só para entender..

Esta entrada é no bootloader do Windows ou no grub do Linux?

Última edição por swatquest (18/07/2016 23:57:40)

Offline

#6 19/07/2016 00:05:50

beagle
Membro
Registrado: 31/08/2015
Mensagens: 74

Re: Removi o linux e ficou no meu boot a entrada

swatquest escreveu:

Só para entender..

Esta entrada é no bootloader do Windows ou no grub do Linux?

Em nenhuma das duas, está na partição EFI (antes do boot).

Mas, RESOLVIDO!

Offline

#7 19/07/2016 16:22:33

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.298

Re: Removi o linux e ficou no meu boot a entrada

Blz.

Quando puder adicione aqui o procedimento que você fez.

E adicione [resolvido] no título do tópico..

Valeu...

Offline

#8 26/07/2016 11:14:51

Guitto
Membro
De: Porto Alegre
Registrado: 26/07/2016
Mensagens: 7

Re: Removi o linux e ficou no meu boot a entrada

Estou com esse mesmo "problema". Não achei até o momento, nenhuma solução que funcionasse pra mim. Quando puder, contribua! Obrigado!

Offline

Rodapé do site