Você não está autenticado.

#1 22/07/2016 17:07:21

psicoppardo
Membro
Registrado: 21/06/2016
Mensagens: 6

[RESOLVIDO] instalação conky-lua

Galera estou tendo problemas com a instalação do Conky-lua, não consigo instalar pelo yaourt, segue saída:

==> Iniciando build()...
-- The C compiler identification is GNU 6.1.1
-- The CXX compiler identification is GNU 6.1.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1") 
-- Looking for include file sys/statfs.h
-- Looking for include file sys/statfs.h - found
-- Looking for include file sys/param.h
-- Looking for include file sys/param.h - found
-- Looking for include file sys/inotify.h
-- Looking for include file sys/inotify.h - found
-- Looking for include file dirent.h
-- Looking for include file dirent.h - found
-- Looking for strndup
-- Looking for strndup - found
-- Looking for pipe2
-- Looking for pipe2 - not found
-- Looking for O_CLOEXEC
-- Looking for O_CLOEXEC - found
-- Looking for statfs64
-- Looking for statfs64 - found
-- Looking for clock_gettime
-- Looking for clock_gettime - found
-- Looking for include file ncurses.h
-- Looking for include file ncurses.h - found
-- Looking for iwlib.h
-- Looking for iwlib.h - found
-- Looking for iw_sockets_open
-- Looking for iw_sockets_open - not found
-- Looking for getnameinfo
-- Looking for getnameinfo - found
-- Looking for 5 include files netdb.h, ..., arpa/inet.h
-- Looking for 5 include files netdb.h, ..., arpa/inet.h - found
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Checking for one of the modules 'lua=5.1;lua5.1;lua-5.1'
CMake Error at /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:574 (message):
  None of the required 'lua=5.1;lua5.1;lua-5.1' found
Call Stack (most recent call first):
  cmake/ConkyPlatformChecks.cmake:252 (pkg_search_module)
  CMakeLists.txt:37 (include)


-- Checking for modules 'cairo;cairo-xlib'
--   Found cairo, version 1.14.6
--   Found cairo-xlib, version 1.14.6
-- Checking for module 'imlib2'
--   Found imlib2, version 1.4.9
-- Checking for module 'librsvg-2.0'
--   Found librsvg-2.0, version 2.40.16
-- Checking for module 'libcurl'
--   Found libcurl, version 7.49.1
-- Checking for module 'libxml-2.0'
--   Found libxml-2.0, version 2.9.4
-- Configuring incomplete, errors occurred!
See also "/home/pedro/builds/yaourt-tmp-pedro/aur-conky-lua/src/conky-1.10.1/CMakeFiles/CMakeOutput.log".
See also "/home/pedro/builds/yaourt-tmp-pedro/aur-conky-lua/src/conky-1.10.1/CMakeFiles/CMakeError.log".
==> ERRO: Uma falha ocorreu em build().
    Abortando...
==> ERRO: Makepkg não conseguiu compilar conky-lua.
==> Reiniciar a compilação de conky-lua ? [s/N]

Sendo que tenho essa biblioteca lua51 instalada, pesquisei em outros foruns, mas não entendi a solução dada, quem puder ajudar serei grato.

Última edição por psicoppardo (23/07/2016 22:29:24)

Offline

#2 22/07/2016 22:15:35

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.376

Re: [RESOLVIDO] instalação conky-lua

No próprio AUR tem um usuário que mandou o PKBUILD consertado
https://aur.archlinux.org/packages/conky-lua/



The following PKGBUILD fixes lua5.1 compilation issues as well as speeding up compilation time:

cmake.patch:
https://gist.github.com/tonylambiris/97 … 85989df623

PKGBUILD:
https://gist.github.com/tonylambiris/bd … 6888d3a85b

Pelo que vi.

É só copiar estes arquivos para uma pasta
por exemplo

caso de erro de checksum

antes execute na propria pasta o comando
updpkgsums



~/Aur/conky-lua



então
makepkg -sci

Offline

#3 23/07/2016 11:10:08

psicoppardo
Membro
Registrado: 21/06/2016
Mensagens: 6

Re: [RESOLVIDO] instalação conky-lua

swatquest, obrigado pela resposta, mas estou esbarrando em outro erro:

fiz o procedimento indicado, editei o  PKGBUILD código editado:

# Maintainer: alexiobash < me (at) alexiobash (dot) com >
# Co-Maintainer: TidestManager1 < michaelpulliam1 (at) gmail (dot) com > 
pkgname=conky-lua
_pkgname=conky
pkgver=1.10.1
pkgrel=3
pkgdesc='Lightweight system monitor for X, with Lua support enabled'
url='http://github.com/brndnmtthws/conky'
license=('BSD' 'GPL3')
arch=('i686' 'x86_64')
options=('!emptydirs')
makedepends=('docbook2x' 'perl-xml-libxml' 'cmake' 'docbook-xsl' 'docbook-xml')
depends=('alsa-lib' 'libxml2' 'curl' 'wireless_tools' 'libxft' 'glib2' 'libxdamage' 'imlib2' 'lua51' 'cairo' 'tolua++')
provides=('conky=1.10.1')
conflicts=('conky')
backup=('etc/conky/conky.conf' 'etc/conky/conky_no_x11.conf')

source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz" fix_build.patch)

sha1sums=('97b59ec1daf54126b30516e8663a9cf1f218d8ae''3ef0f96772410f975e815087509db9537edcd6e2')

replaces=('torsmo')

build() {
cd "${srcdir}/${_pkgname}-${pkgver}"

CPPFLAGS="${CXXFLAGS}" LIBS="${LDFLAGS}" LUA_LIBS="-llua5.1" LUA_CFLAGS="-I/usr/include/lua5.1" \
cmake \
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_BUILD_TYPE=Release \
-D MAINTAINER_MODE=ON \
-D BUILD_CURL=ON \
-D BUILD_LUA_RSVG=ON \
-D BUILD_LUA_CAIRO=ON \
-D BUILD_LUA_IMLIB2=ON \
-D BUILD_IMLIB2=ON \
-D BUILD_RSS=ON \
-D BUILD_WEATHER_METAR=ON \
-D BUILD_WEATHER_XOAP=ON \
-D BUILD_XDBE=ON \
.


make
}

package() {
	cd "${srcdir}/${_pkgname}-${pkgver}"
	make DESTDIR="${pkgdir}" install
	install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
	install -Dm644 LICENSE.BSD ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.BSD
	install -Dm644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
	install -Dm644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
}

prepare() {
	cd "${srcdir}/${_pkgname}-${pkgver}"
	patch -p1 -i ../fix_build.patch
}

só que aparace esse erro:

==> Obtendo fontes...
  -> Baixando v1.10.1.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   126    0   126    0     0    169      0 --:--:-- --:--:-- --:--:--   169
100  335k  100  335k    0     0   103k      0  0:00:03  0:00:03 --:--:--  185k
==> ERRO: fix_build.patch não foi encontrado no diretório de compilação e não é uma URL.
==> ERROR: Failed to generate new checksums

se tiver mais alguma sugestão ajudaria muito. Desde já agradeço.

Offline

#4 23/07/2016 13:26:27

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.376

Re: [RESOLVIDO] instalação conky-lua

ok.

baixe o snapshot
https://aur.archlinux.org/packages/conky-lua/

snapshot: https://aur.archlinux.org/cgit/aur.git/ … lua.tar.gz

e pegue apenas o arquivo fix_build.patch e coloque na pasta também

Offline

#5 23/07/2016 15:20:37

psicoppardo
Membro
Registrado: 21/06/2016
Mensagens: 6

Re: [RESOLVIDO] instalação conky-lua

swatquest, valeu mesmo pela força que está me dando, mas voltei ao ponto de partida, depois que adicionei o fix_build.patch e fiz as modificações segundo os comentários do pacote, pois ele diz que o pacote ++tolua deve estar em dependence e não em makedependence, voltei ao mesmo erro que ocorre no yaourt. Tudo indica que o mantenedor do pacote fez as correções no yaourt, segue minha saída:

 

updpkgsums
==> Obtendo fontes...
  -> Baixando v1.10.1.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   126    0   126    0     0    114      0 --:--:--  0:00:01 --:--:--   114
100  335k  100  335k    0     0  71524      0  0:00:04  0:00:04 --:--:-- 99707
  -> Encontrado fix_build.patch
==> Gerando somas de verificação para os arquivos fonte...
conky-lua # makepkg -sci
==> Criando o pacote: conky-lua 1.10.1-3 (Sáb Jul 23 14:00:16 UTC 2016)
==> Verificando as dependências de tempo de execução...
==> Verificando as dependências de tempo de compilação...
==> Obtendo fontes...
  -> Encontrado v1.10.1.tar.gz
  -> Encontrado fix_build.patch
==> Validando source arquivos com sha1sums...
    v1.10.1.tar.gz ... Passou
    fix_build.patch ... Passou
==> Extraindo fontes...
  -> Extraindo v1.10.1.tar.gz com bsdtar
==> Iniciando prepare()...
patching file cmake/ConkyPlatformChecks.cmake
==> Iniciando build()...
-- The C compiler identification is GNU 6.1.1
-- The CXX compiler identification is GNU 6.1.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1") 
-- Looking for include file sys/statfs.h
-- Looking for include file sys/statfs.h - found
-- Looking for include file sys/param.h
-- Looking for include file sys/param.h - found
-- Looking for include file sys/inotify.h
-- Looking for include file sys/inotify.h - found
-- Looking for include file dirent.h
-- Looking for include file dirent.h - found
-- Looking for strndup
-- Looking for strndup - found
-- Looking for pipe2
-- Looking for pipe2 - not found
-- Looking for O_CLOEXEC
-- Looking for O_CLOEXEC - found
-- Looking for statfs64
-- Looking for statfs64 - found
-- Looking for clock_gettime
-- Looking for clock_gettime - found
-- Looking for include file ncurses.h
-- Looking for include file ncurses.h - found
-- Looking for getnameinfo
-- Looking for getnameinfo - found
-- Looking for 5 include files netdb.h, ..., arpa/inet.h
-- Looking for 5 include files netdb.h, ..., arpa/inet.h - found
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Checking for one of the modules 'lua=5.1;lua5.1;lua-5.1'
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:646 (message):
  None of the required 'lua=5.1;lua5.1;lua-5.1' found
Call Stack (most recent call first):
  cmake/ConkyPlatformChecks.cmake:252 (pkg_search_module)
  CMakeLists.txt:37 (include)


-- Checking for modules 'cairo;cairo-xlib'
--   Found cairo, version 1.14.6
--   Found cairo-xlib, version 1.14.6
-- Checking for module 'imlib2'
--   Found imlib2, version 1.4.9
-- Checking for module 'librsvg-2.0'
--   Found librsvg-2.0, version 2.40.16
-- Checking for module 'libcurl'
--   Found libcurl, version 7.49.1
-- Checking for module 'libxml-2.0'
--   Found libxml-2.0, version 2.9.4
-- Configuring incomplete, errors occurred!
See also "/home/pedro/Downloads/conky-lua/src/conky-1.10.1/CMakeFiles/CMakeOutput.log".
See also "/home/pedro/Downloads/conky-lua/src/conky-1.10.1/CMakeFiles/CMakeError.log".
==> ERRO: Uma falha ocorreu em build().
    Abortando...
conky-lua # sudo rmdir pkg
[sudo] senha para pedro: 
conky-lua # updpkgsums
==> Obtendo fontes...
  -> Baixando v1.10.1.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   126    0   126    0     0     68      0 --:--:--  0:00:01 --:--:--    68
100  335k  100  335k    0     0  73578      0  0:00:04  0:00:04 --:--:--  123k
  -> Encontrado fix_build.patch
==> Gerando somas de verificação para os arquivos fonte...
conky-lua # makepkg -sci
==> Criando o pacote: conky-lua 1.10.1-3 (Sáb Jul 23 14:09:08 UTC 2016)
==> Verificando as dependências de tempo de execução...
==> Verificando as dependências de tempo de compilação...
==> Obtendo fontes...
  -> Encontrado v1.10.1.tar.gz
  -> Encontrado fix_build.patch
==> Validando source arquivos com sha1sums...
    v1.10.1.tar.gz ... Passou
    fix_build.patch ... Passou
==> Extraindo fontes...
  -> Extraindo v1.10.1.tar.gz com bsdtar
==> Iniciando prepare()...
patching file cmake/ConkyPlatformChecks.cmake
==> Iniciando build()...
CMake Error: The source directory "/home/pedro/Downloads/conky-lua/src/conky-1.10.1/BUILD_WLAN=ON" does not exist.
Specify --help for usage, or press the help button on the CMake GUI.
==> ERRO: Uma falha ocorreu em build().
    Abortando...
conky-lua # updpkgsums
==> Obtendo fontes...
  -> Encontrado v1.10.1.tar.gz
  -> Encontrado fix_build.patch
==> Gerando somas de verificação para os arquivos fonte...
conky-lua # makepkg -sci
==> Criando o pacote: conky-lua 1.10.1-3 (Sáb Jul 23 14:10:18 UTC 2016)
==> Verificando as dependências de tempo de execução...
==> Verificando as dependências de tempo de compilação...
==> Obtendo fontes...
  -> Encontrado v1.10.1.tar.gz
  -> Encontrado fix_build.patch
==> Validando source arquivos com sha1sums...
    v1.10.1.tar.gz ... Passou
    fix_build.patch ... Passou
==> Extraindo fontes...
  -> Extraindo v1.10.1.tar.gz com bsdtar
==> Iniciando prepare()...
patching file cmake/ConkyPlatformChecks.cmake
==> Removendo diretório $pkgdir/ existente...
==> Iniciando build()...
-- The C compiler identification is GNU 6.1.1
-- The CXX compiler identification is GNU 6.1.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29.1") 
-- Looking for include file sys/statfs.h
-- Looking for include file sys/statfs.h - found
-- Looking for include file sys/param.h
-- Looking for include file sys/param.h - found
-- Looking for include file sys/inotify.h
-- Looking for include file sys/inotify.h - found
-- Looking for include file dirent.h
-- Looking for include file dirent.h - found
-- Looking for strndup
-- Looking for strndup - found
-- Looking for pipe2
-- Looking for pipe2 - not found
-- Looking for O_CLOEXEC
-- Looking for O_CLOEXEC - found
-- Looking for statfs64
-- Looking for statfs64 - found
-- Looking for clock_gettime
-- Looking for clock_gettime - found
-- Looking for include file ncurses.h
-- Looking for include file ncurses.h - found
-- Looking for iwlib.h
-- Looking for iwlib.h - found
-- Looking for iw_sockets_open
-- Looking for iw_sockets_open - not found
-- Looking for getnameinfo
-- Looking for getnameinfo - found
-- Looking for 5 include files netdb.h, ..., arpa/inet.h
-- Looking for 5 include files netdb.h, ..., arpa/inet.h - found
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Checking for one of the modules 'lua=5.1;lua5.1;lua-5.1'
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:646 (message):
  None of the required 'lua=5.1;lua5.1;lua-5.1' found
Call Stack (most recent call first):
  cmake/ConkyPlatformChecks.cmake:252 (pkg_search_module)
  CMakeLists.txt:37 (include)


-- Checking for modules 'cairo;cairo-xlib'
--   Found cairo, version 1.14.6
--   Found cairo-xlib, version 1.14.6
-- Checking for module 'imlib2'
--   Found imlib2, version 1.4.9
-- Checking for module 'librsvg-2.0'
--   Found librsvg-2.0, version 2.40.16
-- Checking for module 'libcurl'
--   Found libcurl, version 7.49.1
-- Checking for module 'libxml-2.0'
--   Found libxml-2.0, version 2.9.4
-- Configuring incomplete, errors occurred!
See also "/home/pedro/Downloads/conky-lua/src/conky-1.10.1/CMakeFiles/CMakeOutput.log".
See also "/home/pedro/Downloads/conky-lua/src/conky-1.10.1/CMakeFiles/CMakeError.log".
==> ERRO: Uma falha ocorreu em build().
    Abortando...

Desculpe minha ignorância no assunto.

Offline

#6 23/07/2016 15:28:15

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.376

Re: [RESOLVIDO] instalação conky-lua

Blz...

https://gist.github.com/tonylambiris/bd … 6888d3a85b

o PKBUILD está diferente do seu

# Maintainer: TidestManager1 < michaelpulliam1 (at) gmail (dot) com > 
pkgname=conky-lua
_pkgname=conky
pkgver=1.10.1
pkgrel=7
pkgdesc='Lightweight system monitor for X, with Lua support enabled'
url='http://github.com/brndnmtthws/conky'
license=('BSD' 'GPL3')
arch=('i686' 'x86_64')
options=('!emptydirs')
makedepends=('docbook2x' 'perl-xml-libxml' 'cmake' 'docbook-xsl' 'docbook-xml' 'perl-xml-libxml')
depends=('tolua++' 'alsa-lib' 'libxml2' 'curl' 'wireless_tools' 'libxft' 'glib2' 'libxdamage' 'imlib2' 'lua51' 'cairo')
provides=('conky=1.10.1')
conflicts=('conky')
backup=('etc/conky/conky.conf' 'etc/conky/conky_no_x11.conf')
source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz"
		"cmake.patch")
sha1sums=('97b59ec1daf54126b30516e8663a9cf1f218d8ae'
          'ab865d33374ed5cce03986256af0a2c30997a462')
 
replaces=('torsmo')
 
build() {
    cd "${srcdir}/${_pkgname}-${pkgver}"
 
    CPPFLAGS="${CXXFLAGS}" LIBS="${LDFLAGS}" LUA_LIBS="-llua5.1" LUA_CFLAGS="-I/usr/include/lua5.1" \
        cmake \
        -D CMAKE_INSTALL_PREFIX=/usr \
        -D CMAKE_BUILD_TYPE=Release \
        -D MAINTAINER_MODE=ON \
        -D BUILD_CURL=ON \
        -D BUILD_LUA_RSVG=ON \
        -D BUILD_LUA_CAIRO=ON \
        -D BUILD_LUA_IMLIB2=ON \
        -D BUILD_IMLIB2=ON \
        -D BUILD_RSS=ON \
        -D BUILD_WEATHER_METAR=ON \
        -D BUILD_WEATHER_XOAP=ON \
        -D BUILD_XDBE=ON \
        -D BUILD_WLAN=ON \
        .
 
	make -j $(nproc)
}
 
package() {
    cd "${srcdir}/${_pkgname}-${pkgver}"
    make DESTDIR="${pkgdir}" install
    install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
    install -Dm644 LICENSE.BSD ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.BSD
    install -Dm644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
    install -Dm644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
}
 
prepare() {
    cd "${srcdir}/${_pkgname}-${pkgver}"
    patch -p1 -i ${startdir}/fix_build.patch
	patch -p1 -i ${startdir}/cmake.patch
}

e não esqueça do cmake.path
https://gist.github.com/tonylambiris/97 … 85989df623

--- conky-1.10.1/cmake/ConkyPlatformChecks.cmake.orig	2016-07-04 17:48:16.093454814 -0400
+++ conky-1.10.1/cmake/ConkyPlatformChecks.cmake	2016-07-04 17:48:57.536173441 -0400
@@ -249,7 +249,7 @@
 	endif(X11_FOUND)
 endif(BUILD_X11)
 
-pkg_search_module(LUA REQUIRED lua=5.1 lua5.1 lua-5.1)
+pkg_search_module(LUA REQUIRED lua5.1 lua-5.1 lua51 lua>=5.1)
 set(conky_libs ${conky_libs} ${LUA_LIBRARIES})
 set(conky_includes ${conky_includes} ${LUA_INCLUDE_DIRS})
link_directories(${LUA_LIBRARY_DIRS})

Última edição por swatquest (23/07/2016 15:29:43)

Offline

#7 23/07/2016 22:28:38

psicoppardo
Membro
Registrado: 21/06/2016
Mensagens: 6

Re: [RESOLVIDO] instalação conky-lua

swatquest, muito obrigado mesmo pela ajuda, sua correção no cmake.path foi perfeita. Compilou perfeitamente, agora posso brincar com o conky-lua valeu mesmo.

Offline

Rodapé do site