Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 21/11/2016 21:54:44

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Ajustes Pós-Instalação

olá,
Comecei a fazer a instalação do arch semana passada, tive que parar, hoje voltei a mexer, instalei ambiente gráfico e pacotes complementares, o wifi-menu fazia todo processo para rede sem fio mas dava erro, e não consegui conectar estava usando cinnamon ai baixei mate-gtk3 e consegui conectar.
Copiei os dados que tinha no meu antigo HD, para uma partição neste, instalei o megasync e ele esta sincronizando tudo de novo não sei por que, foi um arquivo ou ourtro que teve modificação, com o tempo o note trava, resolvi apagar a configuração do wifi e deixei no cabo para testar, e não travou até agora, quando estou no wifi, o uso da memória vai aumentando, até que trava e não consigo mais mexer.

lspci;
00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 30)

esta placa atheros acho que usa driver ath10, dizem este 802.11 ac faz melhor uso das redes 5.8 ghz, trabalhando mais rápido, meu modem ainda é padrão 2.4, caso realmente seja melhor pretendo trocar meu modem.

lsmod | grep ath;
ath10k_pci             45056  0
ath10k_core           282624  1 ath10k_pci
ath                    28672  1 ath10k_core
mac80211              667648  1 ath10k_core
cfg80211              495616  3 mac80211,ath,ath10k_core

não consigo reproduzir mp3 no clementine, no deadbeef roda normal, mesmo tendo instalado phonon-vlc streamer0.10-[uns 10 arquivos], vlc, alsa-utils, pulseaudio, testei rádio on-line e youtube ambos funcionaram.
Instalei linux-zen e linux-lts nas opções avançadas continua aparecendo a opção padrão e fallback, quando fiz a instalação tive problemas ao rodar o comando mkiniticpio -p linux, dava uma mensagem de falha ao carregar algo, mas instalei o grub e mandei gerar e gerou normal, tanto que a instalação funcionou e consegui abrir o sistema e m modo texto, onde rodei o comando novamente e não retornou erro mais, mas meus outros kernel não aparecem nas opções avançadas do grub.

Offline

#2 21/11/2016 22:34:51

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: Ajustes Pós-Instalação

Novo item, novos problemas,,,kkkk

Cara falando serio agora.

O seu note é loenovo né.

veja este link

https://wiki.archlinux.org/index.php/Laptop/Lenovo

Veja aqui sobre o drive wifi
https://wiki.archlinux.org/index.php/Wi … on#Atheros

Por exemplo o ath10k qyue você usa é para 802.11ac

No seu caso vocÊ tem que rodar ath9k que é para 802.11abgn

mais info
https://wireless.wiki.kernel.org/en/use … HB_Drivers

sobre mp3

talvez tenha que instalar o lame.

aqui está uma lista de codecs
https://wiki.archlinux.org/index.php/Codecs

Eu normalmente instalado os mais conhecidos

Você pode testar o sayonara player ( é o que uso no momento)
http://sayonara-player.com/index.php

Sobre o grub reomendo você ler sobre custom.cfg

Personaliza a sainda e não esquenta mais a cabeça.

Você pode criar todas as imagens

mkinitcpio -p linux
mkinitcpio -p linux-zen
mkinitcpio -p linux-lts

veja se foi tudo criado em /boot

rode o comando
grub-mkconfig -o /boot/grub/grub.cfg

e veja se cria as entradas.

talvez tenha que mudar alguma coisa em /etc/default/grub

Última edição por swatquest (21/11/2016 22:44:39)

Offline

#3 21/11/2016 22:46:05

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: Ajustes Pós-Instalação

soiamgem do player
Screenshot0.png

Offline

#4 22/11/2016 12:44:00

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: Ajustes Pós-Instalação

Então,
No meu antigo note estava tudo normal até que uma atualização fez meu gnome parar de rodar, ai cheguei no mate, ai rhythmbox deu de não rodar meus mp3, sendo que no gnome ele ia normal, ai instalei o clementine e foi.

Rodando os comandos que você passou as entradas apareceram agora, na lina que monta a partição /boot esta assim
UUID=d7a3c05f-6f84-412d-8d8d-fbaf1a341d7b    /boot         ext4          rw,relatime,stripe=4    0 2
o que seria esta opção stripe=4? nunca vi ela no fstab antigos


O lame instalei os seguintes a52dec faac faad2 flac jasper lame libdca libdv libmad libmpeg2 libtheora libvorbis libxv wavpack x264 xvidcore gstreamer0.10-plugins
e mesmo assim o clementine não toca os mp3.

Neste link da lenovo não consta o ideapad 310

Li sobre o ath9, mas não sei como desabilito o ath10 e faço carregar este ath9, se não me engano tem um arquivo blacklist ou algo assim para barrar o ath10, e como posso fazer carregar o ath9 no lugar?

Desculpe minha ignorância, mas pretendo continuar no arch.

Última edição por riesdra (22/11/2016 21:20:45)

Offline

#5 22/11/2016 22:04:37

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: Ajustes Pós-Instalação

Sobre o stripe=4
https://bbs.archlinux.org/viewtopic.php?id=155266

Você pode modificar

Por exemplo

UUID=cb15e42d-1f39-4bbe-9a4	/boot     	ext4      	noatime,nodev,nosuid,noexec,discard,noauto,x-systemd.automount			0 2

Recomendo você ver o tópico https://forum.archlinux-br.org/viewtopic.php?id=4552

Sobre o lame, recomendo você atualizar os espelho. Pelo que vi o espelho padrão que você usa está desatuallizado

Aqui está o mirrorlist que uso

# Server list generated by rankmirrors on 2016-11-02
## Brazil
## United States
Server = http://archlinux.pop-es.rnp.br/$repo/os/$arch
Server = http://archlinux-br.mirror.host1plus.com/$repo/os/$arch
Server = http://linorg.usp.br/archlinux/$repo/os/$arch
Server = http://pet.inf.ufsc.br/mirrors/archlinux/$repo/os/$arch
Server = http://mirror.us.leaseweb.net/archlinux/$repo/os/$arch
Server = http://mirror2.hackingand.coffee/arch/$repo/os/$arch

Você pode usar este script para criar seu mirrorlist
https://forum.archlinux-br.org/viewtopic.php?id=4353

Sobre o som
Alguns player não usam mais a versão legacy
instale gst-plugins
Mais informações aqui
https://wiki.archlinux.org/index.php/GStreamer

Quando vocẽ executa para reproduzir o mp3 aparece algum aviso ou erro?

Para ath9
Edite  /etc/modprobe.d/ath9k.conf e adicione a linha:

options ath9k nohwcrypt=1

Não sei se precisa colocar ath10 em blacklist
Mais infomacão
https://wiki.archlinux.org/index.php/Wi … tion#ath9k

Última edição por swatquest (22/11/2016 22:07:29)

Offline

#6 22/11/2016 22:26:45

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: Ajustes Pós-Instalação

quanto ao fstab, devo alterar ou deixo com esta pois ja veio assim da instalação?

este gst-plugins resolveu, a questão do clementine e os mp3

o arquivo /etc/modprobe.d/ath9k.conf não existe é só criar ele com este conteúdo?

Offline

#7 22/11/2016 22:33:21

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: Ajustes Pós-Instalação

Você pode alterar..
UUID=cb15e42d-1f39-4bbe-9a4    /boot         ext4          noatime,nodev,nosuid,noexec,discard,noauto,x-systemd.automount            0 2

noatime,nodev,nosuid,noexec é recomendado usar
discard só se for ssd
,noauto,x-systemd.automount é para o systemd  montar automaticamente ao iniciar é recomendado colocar na particao home.

o arquivo /etc/modprobe.d/ath9k.conf não existe é só criar ele com este conteúdo?
o arquivo é para criar

Offline

#8 22/11/2016 22:36:12

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: Ajustes Pós-Instalação

Fiz e depois como carrego ele, é só reiniciar?
Só vou mexer amanhã, pois vou dormir já.
Muito obrigado por enquanto.

Offline

#9 22/11/2016 22:40:45

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: Ajustes Pós-Instalação

Blz..
É só reiniciar.

Offline

#10 24/11/2016 22:31:26

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: Ajustes Pós-Instalação

Funcionou?

Offline

#11 25/11/2016 04:59:08

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: Ajustes Pós-Instalação

Desculpa ainda não usei o note, vou ver se consigo hoje ou então amanhã. Aí dou retorno.

Offline

#12 27/11/2016 18:00:35

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: Ajustes Pós-Instalação

Hoje voltei a ligar mais ainda esta carregando o móulo ath10k, conforme pode ver abaixo;

lsmod | grep ath
ath10k_pci             45056  0
ath10k_core           282624  1 ath10k_pci
ath                    28672  1 ath10k_core
mac80211              667648  1 ath10k_core
cfg80211              495616  3 mac80211,ath,ath10k_core

não me lembro como que faz mas acho que tenho que colocar este ath10 em uma blacklist, e por para carregar o ath9, mas não lembro mais como faz, tentei ver aqui e não consegui.

Outro detalhe que estou tentando usar o cinnamon mas ele não conecta no meu wireless, com o mate e mate-gtk3 ele conecta mais com tempo dá o problema do travamento.

Offline

#13 27/11/2016 19:23:18

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: Ajustes Pós-Instalação

desabilitei o networkmanager, e estou no xfce4 com uso do wifi e ainda não travou, estou achando que possa ser algum conflito com o networkmanager.

Offline

#14 27/11/2016 19:36:45

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.962

Re: Ajustes Pós-Instalação

Sobre o blacklist
https://wiki.archlinux.org/index.php/Ke … acklisting

Em /etc/modprobe.d/

crie um arquivo, por exemplo
/etc/modprobe.d/wifi.conf

com a seguinte configuração

# Não carregar o módulo ath10k no boot
blacklist ath10k

Offline

#15 27/11/2016 19:58:37

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: Ajustes Pós-Instalação

vou deixar este por enquanto, depois que desabilitei o networkmanager não travou mais até o momento.
e via wifi-menu consegui conectar meu wifi.

Última edição por riesdra (01/12/2016 13:49:04)

Offline

Rodapé do site