Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#26 27/09/2017 00:31:47

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

soluções

talvez tenha que habiliatr kms nvidia

na linha do kernel do grub adicione
nvidia-drm.modeset=1

ou

não use gdm

tente usar outro gerenciador de login

lightdm
lxdm
slim

Última edição por swatquest (27/09/2017 00:49:48)

Offline

#27 27/09/2017 00:33:49

julio.cesar.s93
Membro
Registrado: 13/09/2017
Mensagens: 46

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

swatquest escreveu:

sudo systemctl stop gdm
sudo systemctl disable gdm


reinicie e startx

não da pra escrever esses comandos porque eu tenho que logar antes, e não consigo logar por causa desse problema

Offline

#28 27/09/2017 00:39:43

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

sei como é.
fica voltando para tela do de inicialização

tente ir inserindo pouco a  pouco

ou então


vc tem a imagem do arch?

entre no cd do arch

monte o root , home , e e outras partições se forem necessárias ( a mesmas que você usou para instlar


arch-chroot /mnt

systemctl disable gdm

Offline

#29 27/09/2017 00:44:05

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

se vc usa nvidia

ao entrar no grub

tecla a tecla e

e insira na linha do kernel
nvidia-drm.modeset=1


caso funcione

/etc/default/grub

em
GRUB_CMDLINE_LINUX_DEFAULT="quiet"

mude para
GRUB_CMDLINE_LINUX_DEFAULT="quiet nvidia-drm.modeset=1"

Última edição por swatquest (27/09/2017 00:46:31)

Offline

#30 27/09/2017 00:46:43

julio.cesar.s93
Membro
Registrado: 13/09/2017
Mensagens: 46

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

swatquest escreveu:

se vc usa nvidia

ao entrar no grub

tecla a tecla e

e insira na linha do kernel
nvidia-drm.modeset=1


consegui comentar lá de novo e iniciar o arch. então... eu tenho um notebook com uma intel hd graphics 3000 e uma amd radeon 7730m

Offline

#31 27/09/2017 00:49:18

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

tente usar outro gerenciador

remove o gdm

e
instale
https://wiki.archlinux.org/index.php/LXDM

ou

https://wiki.archlinux.org/index.php/LightDM

disable gdm

e tente iniciar com o startx

Última edição por swatquest (27/09/2017 00:50:15)

Offline

#32 27/09/2017 00:53:05

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

para o kms da  intel

/etc/mkinitcpio.conf

MODULES="... i915 ..."


e refaz a imagem

mkinitcpio -p linux

e veja se funciona

Offline

#33 27/09/2017 01:08:42

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

para testar o gdm co kms

deixe sem iniciar com sistema

systemctl disable gdm

inicie o sistema

e execute o comando de start

systemctl start gdm

Offline

#34 27/09/2017 14:45:46

julio.cesar.s93
Membro
Registrado: 13/09/2017
Mensagens: 46

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

swatquest escreveu:

para testar o gdm co kms

deixe sem iniciar com sistema

systemctl disable gdm

inicie o sistema

e execute o comando de start

systemctl start gdm

desculpa, me confundi nas mensagens. pode me explicar de novo por favor como fazer pra funcionar no gdm?

Offline

#35 28/09/2017 01:03:03

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

edite o arquivo

/etc/mkinitcpio.conf

em
MODULES=""

adiccione i915

MODULES="i915"

e corra o comando

mkinitcpio -p linux
caso utilize ou kernel, por exemplo linux-zen

mkinitcpio -p linux-zen

então

deixe sem iniciar com sistema

systemctl disable gdm

inicie o sistema

e execute o comando de start

systemctl start gdm

caso não funcione terá que utilizar outro gerenciador de login


--------------------------------------------------------

você também pode testar com startx

instale o xorg-xinit

pacman -S xorg-xinit

crie e edit o arquivo
~/.xinitrc

#!/bin/sh
if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

exec gnome-session

reinicie e execute o comando

startx

Última edição por swatquest (28/09/2017 01:03:48)

Offline

#36 29/09/2017 18:36:58

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

funcionou?

Offline

#37 02/10/2017 22:49:58

julio.cesar.s93
Membro
Registrado: 13/09/2017
Mensagens: 46

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

swatquest escreveu:

funcionou?

desculpa a demora, estava apertado. vou testar agora

Offline

#38 02/10/2017 22:56:47

julio.cesar.s93
Membro
Registrado: 13/09/2017
Mensagens: 46

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

swatquest escreveu:

edite o arquivo

/etc/mkinitcpio.conf

em
MODULES=""

adiccione i915

MODULES="i915"

e corra o comando

mkinitcpio -p linux
caso utilize ou kernel, por exemplo linux-zen

mkinitcpio -p linux-zen

então

deixe sem iniciar com sistema

systemctl disable gdm

inicie o sistema

e execute o comando de start

systemctl start gdm

caso não funcione terá que utilizar outro gerenciador de login


--------------------------------------------------------

você também pode testar com startx

instale o xorg-xinit

pacman -S xorg-xinit

crie e edit o arquivo
~/.xinitrc

#!/bin/sh
if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

exec gnome-session

reinicie e execute o comando

startx

tentei. não funcionou

Offline

#39 02/10/2017 23:11:09

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

tem o startx e veja se funciona?
deveria funcionar..

vocÊ deve usar outro gerenciador de login, por exemplo, lightdm.

Última edição por swatquest (02/10/2017 23:12:47)

Offline

#40 02/10/2017 23:14:10

julio.cesar.s93
Membro
Registrado: 13/09/2017
Mensagens: 46

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

swatquest escreveu:

tem o startx e veja se funciona?
deveria funcionar..

vocÊ deve usar outro gerenciador de login, por exemplo, lightdm.

como faço para usar o lightdm? eu desativei o gdm com systemctl disable gdm e ativei o lxdm, mas quando liguei o pc estava preto

Offline

#41 02/10/2017 23:17:35

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

https://wiki.archlinux.org/index.php/LightDM

remova o gdm caso não for utilizar mais

Offline

#42 02/10/2017 23:33:03

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

cara não sei o que é então..

funcionou com startx?

veja se tem instalado xorg-server

o drive da placa de video..

e desinsta-le o Wayland

Última edição por swatquest (02/10/2017 23:42:40)

Offline

#43 03/10/2017 23:23:01

julio.cesar.s93
Membro
Registrado: 13/09/2017
Mensagens: 46

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

swatquest escreveu:

cara não sei o que é então..

funcionou com startx?

veja se tem instalado xorg-server

o drive da placa de video..

e desinsta-le o Wayland

eu fiz:
editar
/etc/mkinitcpio.conf
em
MODULES=""
adiccione i915
e corri o comando
mkinitcpio -p linux
então
deixe sem iniciar com sistema
systemctl disable gdm
iniciei o sistema e executei o comando de start
systemctl start gdm

instalei o xorg-xinit
crie e edit o arquivo
~/.xinitrc
#!/bin/sh
if [ -d /etc/X11/xinit/xinitrc.d ] ; then
for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
done
unset f
fi

exec gnome-session

reinicieu e executei o comando
startx

nada disso funcionou. tenho o xorg-server e os drivers instalados. pra desinstalar o wayland é só dar sudo pacman -R wayland? quais os riscos? pode acontecer de o sistema não iniciar mais?

Última edição por julio.cesar.s93 (03/10/2017 23:23:47)

Offline

#44 04/10/2017 00:11:33

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

não remova não.


se não está funcionando com o startx entào não funcionará..

Sem informação fica difícil descobrir o erro.

Inicia com startx e fica com tela preta ou dá erro ou não inicia?
Você tem mais um monitor ou tv ligado ao computador?

Offline

#45 04/10/2017 09:02:00

julio.cesar.s93
Membro
Registrado: 13/09/2017
Mensagens: 46

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

swatquest escreveu:

não remova não.


se não está funcionando com o startx entào não funcionará..

Sem informação fica difícil descobrir o erro.

Inicia com startx e fica com tela preta ou dá erro ou não inicia?
Você tem mais um monitor ou tv ligado ao computador?

só um monitor. iniciei com o startx, aí ficou preto e dando aquele problema pra digitar a senha porque ficava voltando pro ctrl alt f1

Offline

#46 04/10/2017 17:34:50

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

Ok..

https://wiki.archlinux.org/index.php/GN … gu%C3%AAs)

Em seu .bash_profile você adicionou

if [[ -z $DISPLAY ]] && [[ $(tty) = /dev/tty1 ]] && [[ -z $XDG_SESSION_TYPE ]]; then
  XDG_SESSION_TYPE=wayland exec dbus-run-session gnome-session
fi

se sim remova ou comente e faça o teste novamente.


outra coisa

https://wiki.archlinux.org/index.php/Intel_graphics
para intel é necessário criar o arquivo

/etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
EndSection

contudo você pode modificar algumas opções para um melhor performace

exemplo

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"		"true"
   Option      "DRI"			"3"
   Option      "AccelMethod"		"sna"
#   Option      "AccelMethod"		"uxa"
EndSection

Veja no link para mais informações
https://wiki.archlinux.org/index.php/Intel_graphics

Última edição por swatquest (04/10/2017 18:01:32)

Offline

#47 06/10/2017 00:31:48

julio.cesar.s93
Membro
Registrado: 13/09/2017
Mensagens: 46

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

swatquest escreveu:

Ok..

https://wiki.archlinux.org/index.php/GN … gu%C3%AAs)

Em seu .bash_profile você adicionou

if [[ -z $DISPLAY ]] && [[ $(tty) = /dev/tty1 ]] && [[ -z $XDG_SESSION_TYPE ]]; then
  XDG_SESSION_TYPE=wayland exec dbus-run-session gnome-session
fi

se sim remova ou comente e faça o teste novamente.


outra coisa

https://wiki.archlinux.org/index.php/Intel_graphics
para intel é necessário criar o arquivo

/etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
EndSection

contudo você pode modificar algumas opções para um melhor performace

exemplo

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"		"true"
   Option      "DRI"			"3"
   Option      "AccelMethod"		"sna"
#   Option      "AccelMethod"		"uxa"
EndSection

Veja no link para mais informações
https://wiki.archlinux.org/index.php/Intel_graphics

no meu .bash_profile tem apenas:

#
# ~/.bash_profile
#

[[ -f ~/.bashrc ]] && . ~/.bashrc


o 20-intel.conf já existia, mas não tinha as 3 últimas linhas que você escreveu. agora adicionei elas

Offline

#48 06/10/2017 23:38:12

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

você tem o arquivo /etc/X11/xorg.conf?

remova-o e tente novamente.

você fez alguma modificação referente a wayland?
tente remover a  modificação.

verifique se tem o arquivo
~/.profile

veja se tem alguma configuração com wayland

caso tenha, tente remover


veja se tem arquivos no ~/.config/gnome-session, se tiver remova-os e tente novamente

uma outra opção

veja o arquivo ~/.local/share/xorg/Xorg.0.log

seja se tem algum error ou warning

os avisos
(++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

qualquer coisa poste aqui entre code

[code]text[/code]

Última edição por swatquest (06/10/2017 23:41:37)

Offline

#49 06/10/2017 23:47:50

julio.cesar.s93
Membro
Registrado: 13/09/2017
Mensagens: 46

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

swatquest escreveu:

você tem o arquivo /etc/X11/xorg.conf?

tenho xorg.conf.d

swatquest escreveu:

você fez alguma modificação referente a wayland?

não fiz

swatquest escreveu:

verifique se tem o arquivo
~/.profile

não tem

swatquest escreveu:

veja se tem arquivos no ~/.config/gnome-session, se tiver remova-os e tente novamente

tem apenas saved-session

swatquest escreveu:

veja o arquivo ~/.local/share/xorg/Xorg.0.log

seja se tem algum error ou warning

tem esses:

[    55.640] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.


[    55.740] (EE)
Fatal server error:
[    55.740] (EE) no screens found(EE)


[    55.767] (EE) Server terminated with error (1). Closing log file.

Offline

#50 06/10/2017 23:53:15

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: [Resolvido] "Atalho" do destop na barra lateral do nautilus no gnome

antes do (ee) tem algum (II) com informação sobre a intel
tente instalar o vesa para radeon para teste

pacman -S xf86-video-vesa

ou

pacman -S xf86-video-ati

mais informação
https://wiki.archlinux.org/index.php/ATI

e reinicie e veja se funciona

Última edição por swatquest (07/10/2017 00:02:51)

Offline

Rodapé do site