Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 17/10/2017 17:53:09

uc_mvini
Membro
Registrado: 17/10/2017
Mensagens: 6

hwclock e teclado

Boa tarde a todos.

Instalei o Arch Linux como systemd (GPT) e estou com o seguinte problema ao executar o hwclock:

[[email protected] dex]# hwclock --systohc --utc
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.
[[email protected] dex]# hwclock --debug
hwclock from util-linux 2.30.2
Trying to open: /dev/rtc0
Trying to open: /dev/rtc
Trying to open: /dev/misc/rtc
No usable clock interface found.
hwclock: Cannot access the Hardware Clock via any known method.

E o problema do teclado eh q n carrega o keymap correto. Aqui esta a saida de  /etc/vconsole.conf:

[[email protected] dex]# cat /etc/vconsole.conf
KEYMAP=br-abnt2

E ja defini o keymap br-abnt2 com o comando: br-abnt2

Alguma sugestao para resolucao deste problema?

Aqui tambem esta parte da saida do comando cat /etc/mkinitcpio.conf:
HOOKS="base udev autodetect modconf keymap keyboard block encrypt lvm2 resume filesystems fsck"

Alguma coisa errada aqui?


Grato,
Marcus.

Última edição por uc_mvini (17/10/2017 18:13:57)

Offline

#2 17/10/2017 23:22:42

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: hwclock e teclado

parece que você não tem o /etc/adjtime

execute o comando
timedatectl set-ntp true

e veja se cria o arquivo
caso nào crie tente criar um e refaz o comando

touch  /etc/adjtime
e
hwclock --systohc --utc

Offline

#3 18/10/2017 00:58:33

uc_mvini
Membro
Registrado: 17/10/2017
Mensagens: 6

Re: hwclock e teclado

swatquest escreveu:

parece que você não tem o /etc/adjtime

execute o comando
timedatectl set-ntp true

e veja se cria o arquivo
caso nào crie tente criar um e refaz o comando

touch  /etc/adjtime
e
hwclock --systohc --utc


Aqui esta mais saidas de hardware.

lspci: https://pastebin.com/KFqkwnZn

dmesg: https://pastebin.com/A2jbBpYS

hwdetect: https://pastebin.com/rb6AJkuP

Alguma ideia para resolucao?

Se trata de um notebook LOG-QAL30 da Login. Se quiser mais especificacoes, posto aqui.

Me parece ser algum modulo faltando ou algo do tipo.

Offline

#4 18/10/2017 22:41:56

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: hwclock e teclado

cara veja aqui, não cheguei a ler tudo
mas teve uma pessoa que estava tendo um problema parecido com o seu
https://bugs.archlinux.org/task/55629?p … string=tar

tente colocar na linha kernel no grub
iommu=soft

ou

intel_iommu=off

Offline

#5 20/10/2017 01:56:21

uc_mvini
Membro
Registrado: 17/10/2017
Mensagens: 6

Re: hwclock e teclado

swatquest escreveu:

cara veja aqui, não cheguei a ler tudo
mas teve uma pessoa que estava tendo um problema parecido com o seu
https://bugs.archlinux.org/task/55629?p … string=tar

tente colocar na linha kernel no grub
iommu=soft

ou

intel_iommu=off

Já andei lendo sobre isso. Vou pesquisar mais à fundo. Retorno aqui com mais informações, mas como percebi no output do dmesg, o rtc_cmos estava ocupado por causa do erro -16.  Estou investigando o porquê disso. Tentei usar um outro Kernel, a versão LTS, e o erro persistiu, e agora está dando o mesmo erro deste post que você me passou. Estranho, mas vamos nos falando. Muito agradecido.


Atenciosamente,
Marcus.

Offline

#6 20/10/2017 16:14:14

uc_mvini
Membro
Registrado: 17/10/2017
Mensagens: 6

Re: hwclock e teclado

swatquest escreveu:

cara veja aqui, não cheguei a ler tudo
mas teve uma pessoa que estava tendo um problema parecido com o seu
https://bugs.archlinux.org/task/55629?p … string=tar

tente colocar na linha kernel no grub
iommu=soft

ou

intel_iommu=off

Quando você diz colocar na linha Kernel no Grub, a que se refere? Encontrei a documentação do kernel na internet: https://www.kernel.org/doc/Documentatio … meters.txt.

Estou colocando o valor com a variável em /etc/default/grub e gerando o arquivo de configuração do grub pelo comando grub-mkconfig -o /boot/grub/grub.cfg. Por acaso, estou fazendo algo de errado?

No começo do arquivo grub.cfg, tenho os seguintes comentários:

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

Isto significa que não é apropriado mexer nesse arquivo pelo pouco que estou utilizando o Arch Linux. Agora, veja uma entrada de dados em /etc/default/grub que estou fazendo abaixo:

# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="cryptdevice=/dev/sda2:vg0 root=/dev/mapper/vg0-root resume=/dev/mapper/vg0-swap quiet splash rw"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires to
# set 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT="true"

intel_iommu=igfx_off]
# CONFIG_INTEL_IOMMU is not set
# CONFIG_INTEL_IOMMU_SVN is not set
# CONFIG_INTEL_IOMMU_DEFAULT_ON is not set
# CONFIG_INTEL_IOMMU_FLOPPY_WA is not set


Outra dúvida que tenho... Estou utilizando uma partição LVM on LUKS e, existe uma variável ali chamada GRUB_ENABLE_CRYPTODISK=y. Eu comentei essa variável do Kernel e, ele chama o HOOK encrypt e faz o processo de boot certinho. Por acaso, preciso descomentar essa função ou não é necessário?

Amigos, estou com uma porção de trabalho da faculdade para fazer e isso está me deixando intrigado... Muito mesmo! Simplesmente, meu sistema puxa o HOOK de encrypt, coloco a minha senha e não possuo modo gráfico. E, outra... Estou usando o kernel linux-lts e possuo já os headers (cabeçalhos). Preciso de ajuda o mais rápido possível pra resolução desse problema. Depois que me responder essa mensagem, se for necessário, tenho os logs dos comandos dmesg, lscpi, uname -r e uname -a. Se precisarem de mais algumas informações. Aaaahhh, meu notebook é um LOG-QAL30 e, as especificações estão aqui neste link: www.login.com.br/Login_Files/files/Docs_Produtos/notebook_QAL30.pdf

Se precisarem da saída com o comando --verbose do mkinitcpio, posso colar aqui também. Me ajudem, meus amigos. Desde já agradeço.


Atenciosamente,
Marcus.

Última edição por uc_mvini (20/10/2017 16:28:05)

Offline

#7 20/10/2017 22:25:22

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: hwclock e teclado

isso adicone no /etc/default/grub

por exemplo
intel_iommu=off

GRUB_CMDLINE_LINUX_DEFAULT="cryptdevice=/dev/sda2:vg0 root=/dev/mapper/vg0-root resume=/dev/mapper/vg0-swap quiet splash rw intel_iommu=off"

depois execute
grub-mkconfig -o /boot/grub/grub.cfg

Última edição por swatquest (20/10/2017 23:18:57)

Offline

#8 20/10/2017 23:20:31

uc_mvini
Membro
Registrado: 17/10/2017
Mensagens: 6

Re: hwclock e teclado

swatquest escreveu:

isto adicone no /etc/default/grub

por exemplo
intel_iommu=off

GRUB_CMDLINE_LINUX_DEFAULT="cryptdevice=/dev/sda2:vg0 root=/dev/mapper/vg0-root resume=/dev/mapper/vg0-swap quiet splash rw intel_iommu=off"

depois execute
grub-mkconfig -o /boot/grub/grub.cfg

Kernel e arquitetura do sisema: 4.9.56-1-lts x86_64

dmesg: https://pastebin.com/2xuTZ75s

lsmod | grep i915: https://pastebin.com/2i1G3JJ5

lsmod: https://pastebin.com/kxwXY7T0

lspci | grep intel: https://pastebin.com/jW807Jw1

Eu tentei usar o parametro do kernel intel_iommu=off, mas não resolveu o meu problema. Então, eu usei o parâmetro do kernel drm.debug=0x1e and log_buf_len=1M sem o intel_iommu=off para maiores informações do dmesg com um debug específico em DRM.

A parte relevante de dmesg é esta:
[   38.102022] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[   38.103242] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[   38.103269] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

Agradeço pela ajuda, amigo.

Última edição por uc_mvini (20/10/2017 23:36:20)

Offline

#9 20/10/2017 23:29:17

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: hwclock e teclado

adicione na linha do kernel

i915.enable_rc6=0

veja se resolve

Offline

#10 21/10/2017 14:18:14

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: hwclock e teclado

sobre o lvm e encrypt

vc tem que descomentar as seguintes opções do hooks, e todos tem que ficar antes do filesystems

HOOKS="... keyboard block encrypt lvm2 ... filesystems ..."

mais informação
https://wiki.archlinux.org/index.php/Dm … UKS_on_LVM

Última edição por swatquest (21/10/2017 14:20:14)

Offline

#11 21/10/2017 22:59:23

uc_mvini
Membro
Registrado: 17/10/2017
Mensagens: 6

Re: hwclock e teclado

swatquest escreveu:

sobre o lvm e encrypt

vc tem que descomentar as seguintes opções do hooks, e todos tem que ficar antes do filesystems

HOOKS="... keyboard block encrypt lvm2 ... filesystems ..."

mais informação
https://wiki.archlinux.org/index.php/Dm … UKS_on_LVM

swat, boa noite, meu caro amigo.


Bem, isso já havia feito. Coloquei keymap depois do teclado. Uma coisa que pela minha lógica se encaixa bem e está funcionando. Se tiver outra sugestão pode passar sobre o keymap. A minha questão é sobre aquela variável que mencionei acima (GRUB_ENABLE_CRYPTODISK). Há a necessidade de descomentá-la ou não?

Outra coisa, testei o que havia mencionado e não resolveu o problema. Existe mais alguma entrada de parâmetros que possa resolver o problema? Me passa a linha dos parâmetros adicionais para verificar a solução.


Obrigado, swatquest. Tem me ajudado bastante.

Última edição por uc_mvini (21/10/2017 23:00:15)

Offline

#12 22/10/2017 22:35:37

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: hwclock e teclado

ok..

adicione na linha do kernel

intel_iommu=igfx_off

Última edição por swatquest (22/10/2017 23:11:18)

Offline

Rodapé do site