Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 15/01/2019 09:08:15

SuperMax
Membro
Registrado: 09/04/2015
Mensagens: 83

Timer no Sistemd

Eu estou com uma dificuldade, eu tenho um .timer que criei para hibernar diariamente as 00:10h.

HIBERNAR.TIMER
[Unit]
Description=Hibernar diariamente as 00:10h

[Timer]
OnCalendar=00:10:55
Persistent=false

[Install]
WantedBy=multi-user.target

HINERNAR.SERVICE
[Unit]
Description=Hibernar Programado

[Service]
ExecStart=/usr/local/bin/hibernar.sh 5 plex
Type=simple
Restart=on-failure

[Install]
WantedBy=multi-user.target

Funciona ok, mas qdo o PC está desligado nesse horário, assim que ele é ligado ele executa a hibernação.

De acordo com https://wiki.archlinux.org/index.php/Systemd/Timers
Persistent=false
seria a solução, mas não tem efeito.

alguém poderia ajudar?
desde já agradeço,

Offline

#2 01/02/2019 23:30:01

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.940

Re: Timer no Sistemd

Persistent=false

não tem efeito pois o padrão é false

Persistent=

    Takes a boolean argument. If true, the time when the service unit was last triggered is stored on disk. When the timer is activated, the service unit is triggered immediately if it would have been triggered at least once during the time when the timer was inactive. This is useful to catch up on missed runs of the service when the machine was off. Note that this setting only has an effect on timers configured with OnCalendar=. Defaults to false.

não cheguei a ler tudo , mas veja se tem alguma opção

https://www.freedesktop.org/software/sy … timer.html

Offline

Rodapé do site