Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 22/03/2008 13:41:14

lampih
Membro
De: Recife - PE
Registrado: 04/11/2007
Mensagens: 68

problema com ntfs-3g

pessoal, tou com uma bronca aqui já faz um tempinho, tentei várias coisas e até agora nada. não estou conseguindo montar partições ntfs com o ntfs-3g como usuário. funcionava muito bem a um mês mais ou menos, depois de alguma atualização do fuse ou do ntfs-3g tá acontecendo esse problema. depois de muito pesquisar, achei um possível problema no fuse, adicionar no arquivo /etc/fuse.conf a opção "allow_user_others", o arquivo não existia, copiei o padrão, agora na hora de montar o ntfs-3g não reconhece o comando.

antes de criar o /etc/fuse.conf, tentava montar e aparecia isso:

lampih ~  $  mount -t ntfs-3g /dev/hda1 /mnt/Windows
ntfs-3g-mount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf
lampih ~  $

criei o /etc/fuse.conf:

lampih ~  $  mount -t ntfs-3g /dev/hda1 /mnt/Windows
ntfs-3g-mount: reading /etc/fuse.conf: line 9 too long
ntfs-3g-mount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf
lampih ~  $

grupos:

lampih ~  $  groups
tty wheel proxy dbus hal network video audio optical storage power users
lampih ~  $

fstab:

/dev/cdrom /mnt/cdrom   iso9660   ro,user,noauto,unhide   0      0
/dev/dvd /mnt/dvd   udf   ro,user,noauto,unhide   0      0
/dev/fd0 /mnt/floppy   vfat   user,noauto   0      0
/dev/hda1 /mnt/Windows  ntfs-3g  user,noauto,locale=pt_BR.utf-8  0      0
/dev/hdb5 /mnt/Musicas    ntfs-3g  user,noauto,locale=pt_BR.utf-8  0      0
/dev/hdd1 /mnt/hd3    reiserfs  user,noauto,locale=pt_BR.utf-8 0      0
/dev/hda2 / reiserfs defaults 0 1
/dev/hda6 swap swap defaults 0 0

fuse.conf:

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#
#mount_max = 1000

# Allow non-root users to specify the 'allow_other' or 'allow_root'
# mount options.
#
user_allow_other

Linux User #458857

Offline

#2 12/04/2008 10:48:32

jamesmrtlPT
Membro
De: Portugal
Registrado: 20/01/2008
Mensagens: 127
Website

Re: problema com ntfs-3g

Já tentou usar no fuse.conf a linha allow_other sem o user_ antes?

ou seja, ficando assim:

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#
#mount_max = 1000

# Allow non-root users to specify the 'allow_other' or 'allow_root'
# mount options.
#
allow_other

Última edição por jamesmrtlPT (12/04/2008 10:49:01)


Laptop: Sony Vaio VGN-FW21E    => Nickname: O trabalhador
Hardware: Intel C2D P8400 (2.26GHz) + 4GB DDRII + 320GB SATAII + ATI Radeon HD3470
Sistema: ArchLinux 64bits + 2.6.28-Arch + Gnome/KDE
Others: Instalado a 01-01-2009 + "Linux não é pra quem pode, é pra quem quer!"

Offline

#3 12/04/2008 11:19:51

lampih
Membro
De: Recife - PE
Registrado: 04/11/2007
Mensagens: 68

Re: problema com ntfs-3g

jamesmrtlPT escreveu:

Já tentou usar no fuse.conf a linha allow_other sem o user_ antes?

ou seja, ficando assim:

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#
#mount_max = 1000

# Allow non-root users to specify the 'allow_other' or 'allow_root'
# mount options.
#
allow_other

tinha tentado desse jeito, tentei agora colocando os dois... dessa maneira:

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#
#mount_max = 1000

# Allow non-root users to specify the 'allow_other' or 'allow_root'
# mount options.
#
user_allow_other
allow_other

e funcionou! ;]
valeu a ajuda.


Linux User #458857

Offline

#4 12/04/2008 11:28:39

jamesmrtlPT
Membro
De: Portugal
Registrado: 20/01/2008
Mensagens: 127
Website

Re: problema com ntfs-3g

Nada, sempre às ordens!

Não se esqueça de colocar a tag [Resolvido] para saber que o seu problema já foi resolvido

Abraço!
JamesmrtlPT

Última edição por jamesmrtlPT (12/04/2008 17:17:53)


Laptop: Sony Vaio VGN-FW21E    => Nickname: O trabalhador
Hardware: Intel C2D P8400 (2.26GHz) + 4GB DDRII + 320GB SATAII + ATI Radeon HD3470
Sistema: ArchLinux 64bits + 2.6.28-Arch + Gnome/KDE
Others: Instalado a 01-01-2009 + "Linux não é pra quem pode, é pra quem quer!"

Offline

Rodapé do site