Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 15/04/2008 19:29:09

Nara
Membro
Registrado: 02/03/2008
Mensagens: 10

[resolvido]impressora parou de funcionar

oi
tenho uma impressora epson que derepente parou de funcionar.
eu ja reinicie o cups e nada.
no localhost:631 aparece o seguinte:

"Unable to open parallel port device file: Permission denied"

Última edição por Nara (18/10/2008 14:15:55)

Offline

#2 16/04/2008 00:29:18

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: [resolvido]impressora parou de funcionar

está sem permissão, correto? tongue


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#3 16/04/2008 01:23:32

osc~
Membro
Registrado: 07/12/2007
Mensagens: 238
Website

Re: [resolvido]impressora parou de funcionar

eu procurei em varios forums mas não achei nada. parece que é um problema constante.
corvolino,
como que se da a permissão, voce sabe?

Offline

#4 16/04/2008 09:52:00

cemsbr
Membro
De: São Paulo
Registrado: 16/04/2008
Mensagens: 25
Website

Re: [resolvido]impressora parou de funcionar

Deixe eu dar uma olhada em

ls -l /dev/lp*

Offline

#5 17/04/2008 02:35:54

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: [resolvido]impressora parou de funcionar

osc~ escreveu:

eu procurei em varios forums mas não achei nada. parece que é um problema constante.
corvolino,
como que se da a permissão, voce sabe?

nem sei viu.. so pesquisando! tongue


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#6 17/04/2008 10:41:47

havocz
Membro
De: Nilópolis - RJ
Registrado: 05/06/2007
Mensagens: 62

Re: [resolvido]impressora parou de funcionar

Segue a solução moçada !! Aqui funcionou tongue wink

http://bugs.archlinux.org/task/9935#comment26467

Edit: Foi mal, agora que eu vi que tua impressora é paralela.

Bom... verifique se você está no grupo lp... use: groups <nome-do-usuário>

Se você não estiver lá no grupo é só adicionar-se ao mesmo: adduser <nome-do-usuário> lp

[ ]s

Última edição por havocz (17/04/2008 10:54:47)


Linux User #433307

Offline

#7 17/04/2008 23:56:00

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: [resolvido]impressora parou de funcionar

Se resolveu coloca [RESOLVIDO] no topic ! ;P


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#8 18/04/2008 21:30:27

Nara
Membro
Registrado: 02/03/2008
Mensagens: 10

Re: [resolvido]impressora parou de funcionar

ls -l /dev/lp*

crw-rw---- 1 root lp 6, 0 Abr 18 20:27 /dev/lp0

Offline

#9 16/09/2008 22:02:01

cemsbr
Membro
De: São Paulo
Registrado: 16/04/2008
Mensagens: 25
Website

Re: [resolvido]impressora parou de funcionar

Desculpe a demora. Você está no grupo "lp"? Pode checar digitando "groups" no terminal. Se não aparecer "lp", faça como root:

gpasswd -a seu_usuario lp

Faça logoff, entre de novo, confirme que o comando "groups" mostra "lp" e tente imprimir novamente.

Offline

#10 16/09/2008 22:17:34

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: [resolvido]impressora parou de funcionar

Por que o usuário teria que estar no grupo lp? Quem abre o dispositivo é o cups

Veja qual usuário está rodando o cups:

ps aux | grep cups

Aqui é o root. Talvez tenha mudado alguma configuração aí e esteja rodando com algum usuário restringido (por exemplo nobody)

Offline

#11 23/09/2008 22:09:46

Brunonormandia
Membro
Registrado: 01/11/2007
Mensagens: 29

Re: [resolvido]impressora parou de funcionar

olá!!

também estou tendo problemas quanto ao funcionamento da minha impressora que de repente parou de funcionar...
percebi logo quando vi que ao iniciar o daemon do cups retorna a seguinte mensagem:

/usr/sbin/cupsd: error while loading shared libraries: libgnutls.so.13: cannot open shared object file: No such file or directory


alguém sabe como solucionar isso??
obs: minha impressora é uma HP Desject D2360

Offline

#12 23/09/2008 23:11:59

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: [resolvido]impressora parou de funcionar

Também não tenho o libgnutls.so.13 e funciona corretamente o CUPS. Você está com o seu sistema completamente atualizado?

Offline

#13 24/09/2008 21:14:26

Brunonormandia
Membro
Registrado: 01/11/2007
Mensagens: 29

Re: [resolvido]impressora parou de funcionar

thotypous escreveu:

Também não tenho o libgnutls.so.13 e funciona corretamente o CUPS. Você está com o seu sistema completamente atualizado?

pior que não...
mas (acredite se quiser...) eu por coincidência achei qual pacote precisava ser atualizado no meio de mais de 300 megas de atualizações pendentes que tenho...:P

para quem tiver este problema que tive e não estiver afim ou não puder de atualizar todo o sistema basta dar um: pacman -S libcups
aqui pelo menos resolveu.. big_smile

até mais
um abraço

Última edição por Brunonormandia (24/09/2008 21:22:33)

Offline

Rodapé do site