Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 25/04/2009 18:21:26

Danilo Vilas Boas
Membro
De: São João da Boa Vista - SP
Registrado: 10/04/2009
Mensagens: 292

hwd -xa: "no Xserver installed" [RESOLVIDO]

Olá pessoal.
Meu vídeo é um famigerado sis 630 sad, e estou com um problema para configurar o servidor X.
Antes de qualquer coisa, já atualizei o sistema com
# pacman -Syu
portanto a versão do xorg é 1.6

Executei os seguintes passos:

# pacman -S xorg
ocorreu tudo bem, depois fiz
# pacman -S xorg-video-drivers hwd
onde foi instalado, dentre outros, o driver da minha sis.
O próximo passo seria rodar
# hwd -xa
mas quando faço isso ele retorna: "no Xserver installed".

Parti então para o
# Xorg -configure
mas quando testo com
# X -config /root/xorg.conf.new
não iniciava nenhum gerenciador de janela, e o teclado não funcionava para dar ctrl+alt+backspace. Após algumas alterações no xorg.conf.new, o teclado passa a funcionar, mas o gerenciador de janelas não.
O hal está rodando desde a inicialização, porque o adicionei ao DAEMON no rc.conf. Então, experimentei um startx e ele iniciou o gerenciador de janelas padrão (acho que é o xterm, não?).
A partir daí, instalei o xfce4 pensando poder rodá-lo, mas ao rodar
# startxfce4
trava tudo de novo, e nem teclado nem nada pra eu voltar ao terminal, então tenho que reiniciar no botão (meu HD logo logo vai pro espaço assim).
Gostaria de poder postar meu xorg.conf.new aqui para ser analisado, mas estou usando windows para postar isso e, sinceramente, não sei como copiar o arquivo e postar aqui pelo elinks.

Já consultei o Guia dos Iniciantes, o verbete Xorg no wiki, e este link http://forum.archlinux-br.org/viewtopic.php?id=1649, que contém um problema semelhante ao meu, mas não consegui elucidar ainda a questão.
Creio que se o comando # hwd -xa funcionasse corretamente este problema seria solucionado.
Aproveito para dizer que gostei muito do arch, e que não vou deixá-lo apenas por esse detalhe, já que aprendi com ele em uma semana mais do que em um ano com Mandriva e openSuse. Devido às limitações da máquina, tenciono usá-lo para rodar com Xfce ou lxde.

Obrigado pela atenção.

Última edição por Danilo Vilas Boas (29/04/2009 18:50:37)


Archeando...

Offline

#2 25/04/2009 21:08:17

RickDiamond
Banido
Registrado: 17/07/2008
Mensagens: 348

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

Agora que eu percebi: sumiram com o xorgcfg. Deve ser por isso que o hwd não funciona. O jeito é você ler a página do manual do xorg.conf (man xorg.conf), pesquisar sobre o xorg.conf no Google e ir ajustando às suas necessidades.

Offline

#3 29/04/2009 03:32:05

simon
Membro
De: Belo Horizonte - MG
Registrado: 30/03/2009
Mensagens: 40
Website

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

voce tentou
cp /root/xorg.conf.new /etc/X11/xorg.conf

e depois restartar o x??

Offline

#4 29/04/2009 03:34:02

simon
Membro
De: Belo Horizonte - MG
Registrado: 30/03/2009
Mensagens: 40
Website

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

RickDiamond escreveu:

Agora que eu percebi: sumiram com o xorgcfg. Deve ser por isso que o hwd não funciona. O jeito é você ler a página do manual do xorg.conf (man xorg.conf), pesquisar sobre o xorg.conf no Google e ir ajustando às suas necessidades.

Acho que o corvolinux explicou isso parece que a galera q programa o hwd nao atualizou o software para o novo xorg. por isso que ele da essa msg "no Xserver installed".

Mas se voce der o X - Configure ele cria o xorg.conf no root. depois eh so copiar X11 como disse acima.

Offline

#5 29/04/2009 10:54:47

alexspe
Membro
Registrado: 06/08/2008
Mensagens: 64

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

saiu hoje o hwd 5.5 q reconhece o xorgserver 1.6

Offline

#6 29/04/2009 10:59:03

YacK
Membro
De: São Luis - Maranhao
Registrado: 06/03/2009
Mensagens: 30
Website

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

qual o seu xorg server? pq
o hwd ainda nao é compativel com o 1.6
atualiza para o hwd 5.5 ainda nao tem no repositorio mais os dev's ja disponibilizaram
http://user-contributions.org/projects/hwd/pkg/PKGBUILD
ta ai o PKGBUILD, da da um makepkg que ele gera o pacote ai depois disso pacman -U

Última edição por YacK (29/04/2009 12:32:38)


15735gc4.png

Offline

#7 29/04/2009 12:08:47

Danilo Vilas Boas
Membro
De: São João da Boa Vista - SP
Registrado: 10/04/2009
Mensagens: 292

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

Valeu pessoal. Vou atualizar o hwd e testar pra ver.
Se nao der, vou fazer o que o simon sugeriu.


Archeando...

Offline

#8 29/04/2009 12:21:10

YacK
Membro
De: São Luis - Maranhao
Registrado: 06/03/2009
Mensagens: 30
Website

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

a minha tambem é SIS qual o driver voce esta utilizando
eu te aconselho a usar VESA.
porque a sis tem problemas com linux. neutral
Caso o post ajude Coloque como [resolvido]

Última edição por YacK (29/04/2009 12:33:06)


15735gc4.png

Offline

#9 29/04/2009 12:55:27

Danilo Vilas Boas
Membro
De: São João da Boa Vista - SP
Registrado: 10/04/2009
Mensagens: 292

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

Estou usando o driver sis mesmo. Ja que nao vou usar aceleracao 3D nem nada, creio que o vesa seja suficiente. Alguem tem alguma contra-indicacao para o vesa?


Archeando...

Offline

#10 29/04/2009 13:53:28

alexspe
Membro
Registrado: 06/08/2008
Mensagens: 64

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

qual teu monitor?
vesa suporta no maximo 1024x768 pixels

Offline

#11 29/04/2009 14:08:48

Danilo Vilas Boas
Membro
De: São João da Boa Vista - SP
Registrado: 10/04/2009
Mensagens: 292

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

Meu monitor e um crt philips 105S. Realmente 1024x768 e a resolucao que eu uso no dia a dia.
Mais algum detalhe sobre o vesa?
Valeu pessoal.


Archeando...

Offline

#12 29/04/2009 16:55:05

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

alexspe escreveu:

qual teu monitor?
vesa suporta no maximo 1024x768 pixels

uso versa e uso resolução 1280x1024 =p


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#13 29/04/2009 18:49:02

Danilo Vilas Boas
Membro
De: São João da Boa Vista - SP
Registrado: 10/04/2009
Mensagens: 292

Re: hwd -xa: "no Xserver installed" [RESOLVIDO]

Pessoal, as dicas do YacK e do simon funcionaram bem. Estou rodando o xfce agora. Vou estudar o processo, rever os passos que tomei para aprender corretamente.


Archeando...

Offline

Rodapé do site