Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 18/09/2012 17:01:12

sistematico
Admin
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.022
Website

[RESOLVIDO] BUG no UFW após Linux-CK

Pessoal, recebo a seguinte mensagem:

[[email protected] ~]# ufw status
Traceback (most recent call last):
  File "/usr/bin/ufw", line 95, in <module>
    ui = ufw.frontend.UFWFrontend(pr.dryrun)
  File "/usr/lib/python2.7/site-packages/ufw/frontend.py", line 153, in __init__
    self.backend = UFWBackendIptables(dryrun)
  File "/usr/lib/python2.7/site-packages/ufw/backend_iptables.py", line 45, in __init__
    ufw.backend.UFWBackend.__init__(self, "iptables", dryrun, files)
  File "/usr/lib/python2.7/site-packages/ufw/backend.py", line 88, in __init__
    nf_caps = ufw.util.get_netfilter_capabilities(self.ip6tables)
  File "/usr/lib/python2.7/site-packages/ufw/util.py", line 734, in get_netfilter_capabilities
    raise OSError(errno.ENOENT, out)
OSError: [Errno 2] ip6tables v1.4.15: can't initialize ip6tables table `filter': Address family not supported by protocol
Perhaps ip6tables or your kernel needs to be upgraded.

Notei isso depois de configurar o Linux CK, porem eu não sei se o problema é relacionado:

[[email protected] ~]# uname -r -m
3.5.4-1-ck x86_64

No systemd parece estar normal o daemon:

[[email protected] ~]# systemctl status ufw.service
ufw.service - CLI Netfilter Manager
	  Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled)
	  Active: active (exited) since Tue, 18 Sep 2012 15:00:26 -0400; 1s ago
	 Process: 1240 ExecStart=/usr/lib/ufw/ufw-init start (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/ufw.service

Alguem me ajuda?
Obrigado desde já.

Última edição por sistematico (19/04/2013 13:13:24)

Offline

#2 19/09/2012 02:02:55

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [RESOLVIDO] BUG no UFW após Linux-CK

sistematico

Você compilou o linux-ck com o módulo ipv6?
Desativou o ipv6 pelo /etc/sysctl.conf?
O módulo ipv6 está funcionando?

Se desabilitou o ipv6, viu a configuração do ipv6 em /etc/default/ufw ?

Offline

#3 19/04/2013 02:02:21

sistematico
Admin
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.022
Website

Re: [RESOLVIDO] BUG no UFW após Linux-CK

swatquest, me desculpe pela demora, a sua resposta passou completamente desapercebida por mim.
Um descuido.
Somente ao ter o mesmo problema novamente e procurar no Google, a sua resposta foi o primeiro resultado.

Logo, re-abro esse tópico pra tratar do mesmo problema.

swatquest escreveu:

sistematico

Você compilou o linux-ck com o módulo ipv6?

Não sei, instalação default.

swatquest escreveu:

Desativou o ipv6 pelo /etc/sysctl.conf?

Acho que não: http://paste.archlinux-br.org/2138

swatquest escreveu:

O módulo ipv6 está funcionando?

Está: http://paste.archlinux-br.org/2139

swatquest escreveu:

Se desabilitou o ipv6, viu a configuração do ipv6 em /etc/default/ufw ?

Sim, desabilitei lá: http://paste.archlinux-br.org/2140

Obrigado desde já.

Offline

#4 19/04/2013 12:54:06

sistematico
Admin
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.022
Website

Re: [RESOLVIDO] BUG no UFW após Linux-CK

Mais um detalhe que eu havia esquecido!
/etc/default/grub:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="quiet ipv6.disable=1 elevator=bfq"
GRUB_CMDLINE_LINUX=""
GRUB_SAVEDEFAULT="true"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/boot/grub/arch.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

Vou alterar essa linha:

GRUB_CMDLINE_LINUX_DEFAULT="quiet ipv6.disable=1 elevator=bfq"

E já eu posto o resultado.

Obrigado.

Offline

#5 19/04/2013 13:12:56

sistematico
Admin
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.022
Website

Re: [RESOLVIDO] BUG no UFW após Linux-CK

Como eu havia suspeitado, retirei o ipv6.disable=1 e o UFW voltou a funcionar.

Muito obrigado swatquest.

Offline

Rodapé do site