Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 02/04/2013 23:04:48

afrosamurai
Membro
De: cabo de santo agostinho
Registrado: 20/11/2012
Mensagens: 46

[RESOLVIDO]pacman atualizado mais do q deveria

bem pessoal eu instalei o yaourt mas percebi que ele nao eh tao legal pq instala os programas de uma forma q deixou notebook mais pesado. entao resolvi desista-lo até pq quando instalei o MATE ele deu erro e nao foi como e tentei fazer o log in usando o mate mas nao foi. Mas enfim instalei o mate usando o
o comando


# pacman -S ffmpegthumbnailer-caja mate mate-backgrounds mate-bluetooth mate-calc mate-common mate-conf mate-conf-editor mate-control-center mate-corba mate-desktop mate-dialogs mate-display-manager mate-doc-utils mate-document-viewer mate-file-manager mate-file-manager-open-terminal mate-file-manager-sendto mate-icon-theme mate-keyring mate-media mate-menu-editor mate-menus mate-mime-data mate-netspeed mate-notification-daemon mate-panel mate-polkit mate-power-manager mate-screensaver mate-sensors-applet mate-session-manager mate-settings-daemon mate-system-monitor mate-terminal mate-text-editor mate-themes mate-utils mate-vfs mate-window-manager



referente ao site

http://gnutwoall.wordpress.com/2012/09/ … rch-linux/


mas quando desinstalei o yaourt fica dando o erro quando eu tento apagar os arquivos

[email protected] matias]#  pacman -Su
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.1
[[email protected] matias]#  pacman -Su
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] y

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.1
[[email protected] matias]#




alguem faz ideia como eu faço pra corrigir isso

Última edição por afrosamurai (03/04/2013 20:56:32)

Offline

#2 02/04/2013 23:07:24

afrosamurai
Membro
De: cabo de santo agostinho
Registrado: 20/11/2012
Mensagens: 46

Re: [RESOLVIDO]pacman atualizado mais do q deveria

e tambem depois apagar todos esses arquivos

Offline

#3 02/04/2013 23:19:54

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [RESOLVIDO]pacman atualizado mais do q deveria

se quer remover o yaourt e o package-query, é só ignorar as dependências:

# pacman -Rdd yaourt package-query

depois você vai poder atualizar o pacman sem problemas.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#4 03/04/2013 11:00:09

afrosamurai
Membro
De: cabo de santo agostinho
Registrado: 20/11/2012
Mensagens: 46

Re: [RESOLVIDO]pacman atualizado mais do q deveria

[[email protected] matias]# pacman -Syu       
:: Synchronizing package databases...
testing                                       19.9 KiB  54.4K/s 00:00 [#######################################] 100%
core is up to date
extra                                       1417.3 KiB  61.0K/s 00:23 [#######################################] 100%
community-testing is up to date
community                                   1932.3 KiB  60.9K/s 00:32 [#######################################] 100%
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] y

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.1
[[email protected] matias]#

Offline

#5 03/04/2013 13:03:17

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [RESOLVIDO]pacman atualizado mais do q deveria

o package-query tem que ser removido antes de atualizar o sistema.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#6 03/04/2013 20:55:45

afrosamurai
Membro
De: cabo de santo agostinho
Registrado: 20/11/2012
Mensagens: 46

Re: [RESOLVIDO]pacman atualizado mais do q deveria

valeu irmão deu certo já atualizando o firefox para o 20.0

Offline

#7 06/04/2013 15:47:04

bakurito
Membro
Registrado: 06/04/2013
Mensagens: 7

Re: [RESOLVIDO]pacman atualizado mais do q deveria

Pacotes (2): package-query-1.2-2  yaourt-1.3-1

Tamanho total download:    0,07 MiB
Tamanho total instalado:   0,37 MiB

:: Prosseguir com a instalação? [S/n] s
:: Obtendo pacotes ...
package-query-1.2-2...    21,7 KiB  77,9K/s 00:00 [######################] 100%
yaourt-1.3-1-any          49,7 KiB  26,7K/s 00:02 [######################] 100%
(2/2) verificando chaves no chaveiro               [######################] 100%
(2/2) verificando integridade do pacote            [######################] 100%
erro: package-query: missing required signature
:: Arquivo /var/cache/pacman/pkg/package-query-1.2-2-i686.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n]

Offline

#8 06/04/2013 15:53:35

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: [RESOLVIDO]pacman atualizado mais do q deveria

bakurito,

O certo é criar uma thread para cada problema, outra coisa, colocar comandos e output dentro da tag code.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#9 06/04/2013 16:02:03

bakurito
Membro
Registrado: 06/04/2013
Mensagens: 7

Re: [RESOLVIDO]pacman atualizado mais do q deveria

Obrigado pela dica, desculpe eu sou novo no fórum, irei fazer isso...

hotvic escreveu:

bakurito,

O certo é criar uma thread para cada problema, outra coisa, colocar comandos e output dentro da tag code.

Offline

#10 06/04/2013 17:44:44

afrosamurai
Membro
De: cabo de santo agostinho
Registrado: 20/11/2012
Mensagens: 46

Re: [RESOLVIDO]pacman atualizado mais do q deveria

bakurito escreveu:

Obrigado pela dica, desculpe eu sou novo no fórum, irei fazer isso...

hotvic escreveu:

bakurito,

O certo é criar uma thread para cada problema, outra coisa, colocar comandos e output dentro da tag code.


mas com eu faço isso usando um codigo

Offline

#11 06/04/2013 17:49:30

bakurito
Membro
Registrado: 06/04/2013
Mensagens: 7

Re: [RESOLVIDO]pacman atualizado mais do q deveria

Amigo use [-code]seu codigo[-/code] retire o - e poste sua duvida!!

afrosamurai escreveu:
bakurito escreveu:

Obrigado pela dica, desculpe eu sou novo no fórum, irei fazer isso...

hotvic escreveu:

bakurito,

O certo é criar uma thread para cada problema, outra coisa, colocar comandos e output dentro da tag code.


mas com eu faço isso usando um codigo

Offline

Rodapé do site