Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 06/04/2013 22:54:26

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

DICA: Atualização do 'pacman' conflita com 'package-query'

Se você está tentando atualizar o pacman(ou o sistema completo) e tiver o 'package-query' instalado não será possível:

# pacman -Su
:: Os seguintes pacotes precisam ser atualizados antes :
    pacman
:: Você deseja cancelar a operação atual
:: e atualizar estes pacotes agora? [S/n] 

resolvendo dependências...
procurando por conflitos inter-relacionados...
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: package-query: requer pacman<4.1

para resolver isso simplesmente atualize o pacman ignorando deponências:

# pacman -Sdd pacman
procurando por conflitos inter-relacionados...

Alvos (1): pacman-4.1.0-2

Tamanho Total Download:    0,58 MiB
Tamanho Total Instalado:   4,24 MiB
Alteração no Tamanho:      0,70 MiB

Prosseguir com a instalação? [S/n] s
:: Obtendo pacotes de core...
 pacman-4.1.0-2-x86_64                                                                                 598,0 KiB   107K/s 00:06 [#############################################################################] 100%
(1/1) verificando integridade do pacote                                                                                         [#############################################################################] 100%
(1/1) carregando arquivos do pacote                                                                                             [#############################################################################] 100%
(1/1) verificando conflitos de arquivo                                                                                          [#############################################################################] 100%
(1/1) verificando espaço em disco disponível                                                                                    [#############################################################################] 100%
(1/1) atualizando pacman                                                                                                        [#############################################################################] 100%
atenção: /etc/pacman.conf installed as /etc/pacman.conf.pacnew

mais lembre-se de logo após isso atualizar o 'package-query':
Não será possível usar yaourt, então a atualização tem que ser manualmente.

% wget 'https://aur.archlinux.org/packages/pa/package-query/package-query.tar.gz'
% tar xvzf package-query.tar.gz
% cd package-query
% makepkg
# pacman -U package-query-1.2-2-x86_64.pkg.tar.xz

Pronto só isso...

Espero que ajude alguém big_smile.

[]'s

Edit:

Lembrem-se também de atualizar seu pacman.conf de acordo com o pacman.conf.pacnew

Última edição por hotvic (06/04/2013 23:03:45)


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#2 08/04/2013 23:43:25

Clecio
Membro
De: Goiânia
Registrado: 20/06/2008
Mensagens: 216
Website

Re: DICA: Atualização do 'pacman' conflita com 'package-query'

Boa, já ia postar algo referente a isso aqui forum sobre essa atualização que aconteceu comigo ontem.
Postei no blog como solucionei o problema, foi parecido: http://cleciooliveira.com/blog/2013/04/ … acman-4-1/

Offline

Rodapé do site