Você não está autenticado.

#1 02/03/2016 19:45:20

lsxs
Membro
Registrado: 02/03/2016
Mensagens: 1

Problema na instação do Scilab

Opa pessoal, tudo bem?!

Estou tentando instalar o Scilab no meu arch através do "yaourt -S scilab", porém me deparo sempre com essa mensagem de erro. Inclusive, já resolvi essas dependencias, porém, volto a isso novamente:

erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: scilab: requer java-flexdock>=1.2.4
:: scilab: requer fop-hyph
:: scilab: requer java-freehep-vectorgraphics
:: scilab: requer jgraphx>=2.0.0.1
:: scilab: requer javahelp2
:: scilab: requer saxon-he
:: scilab: requer jlatexmath-fop>=1.0.3
:: scilab: requer jrosetta>=1.0.4
:: scilab: requer java-qdox
:: scilab: requer scirenderer
:: scilab: requer java-testng

Offline

#2 02/03/2016 22:42:59

chulungs
Membro
De: Florianópolis, SC
Registrado: 21/11/2012
Mensagens: 164

Re: Problema na instação do Scilab

Confere se vc está instalando o pacote do AUR.

Como vc usa o yaourt talvez vc tenha o repositorio do archlinuxfr habilitado.

Digite o comando sem o -S e verifique qual pacote ele está instalando (se é o do AUR ou do archlinuxfr).

Última edição por chulungs (02/03/2016 22:43:29)

Offline

#3 05/03/2016 04:34:39

sistematico
Moderador
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.003
Website

Re: Problema na instação do Scilab

1- Antes de mais nada, tenta instalar direto, sem usar nenhum helper.
https://wiki.archlinux.org/index.php/Ar … g_packages
https://wiki.archlinux.org/index.php/Makepkg#Usage

Exemplo(como usuário normal):

mkdir -p ~/tmp/aur/ && cd ~/tmp/aur/
wget https://aur.archlinux.org/cgit/aur.git/snapshot/scilab.tar.gz
tar xzf scilab.tar.gz
cd scilab
makepkg
sudo pacman -U scilab*pkg.tar.gz

2- Instale essas dependências manualmente, eu acho que tem todas no AUR, não sei.
Instale as dependências usando o exemplo de rotina acima, caso uma falhe, pule para a próxima até que todas as dependências estejam satisfeitas.

Se a construção falhar em algum ponto, diga qual pacote falhou que eu ou algum colega do fórum tentará corrigir o PKGBUILD(caso este seja o problema).

Abraço.

Offline

Rodapé do site