Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via [email protected]

Para mais informações: [email protected]

#1 25/04/2016 09:19:15

positivity
Membro
Registrado: 02/01/2016
Mensagens: 34

[RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

Olá!

Já estou usando o Arch há alguns meses. Nunca tive nenhum problema grave com ele. Esta semana, infelizmente, algo inusitado aconteceu: depois de atualizar o sistema, como faço quase todos os dias, eu percebi que o wifi-menu conecta a internet, porém eu não consigo navegar com nenhum dos navegadores. Alguém me ajuda a resolver este problema?

Obrigado antecipadamente a todos os usuários do forum Arch Brasil.

Última edição por positivity (29/04/2016 10:18:43)

Offline

#2 25/04/2016 16:45:43

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.735

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

Você consegue fazer o ping?

Já viu se o proxy está ativado?

Offline

#3 25/04/2016 16:56:10

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

positivity escreveu:

Olá!

Já estou usando o Arch há alguns meses. Nunca tive nenhum problema grave com ele. Esta semana, infelizmente, algo inusitado aconteceu: depois de atualizar o sistema, como faço quase todos os dias, eu percebi que o wifi-menu conecta a internet, porém eu não consigo navegar com nenhum dos navegadores. Alguém me ajuda a resolver este problema?

Obrigado antecipadamente a todos os usuários do forum Arch Brasil.

Também tive esse problema.
Pelo que analisei, deveria haver um arquivo chamado /var/run/connman/resolv.conf (link simbólico para /etc/resolv.conf) para que o DNS funcione, mas o diretório connman por algum motivo sumiu.
Apenas criei ele novamente e restartei o serviço de rede e tudo voltou a funcionar novamente.


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#4 25/04/2016 21:15:06

positivity
Membro
Registrado: 02/01/2016
Mensagens: 34

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

Ainda nao tinha testado o comando ping. Eu usei ping www.google.com , e apareceu a seguinte mensagem:
Nome ou servico desconhecido

Quanto ao proxy, nao sei como checar se ele esta ativo...

Offline

#5 25/04/2016 21:18:38

positivity
Membro
Registrado: 02/01/2016
Mensagens: 34

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

Realmente nao havia o diretorio do connman, eu criei um link simbolico dessa maneira:

sudo ln -s /var/run/connman/resolv.conf /etc/resolv.conf

entretanto, os navegadores contiuam nao acessando a internet.

Obrigado pela ajuda, pessoal!

Offline

#6 25/04/2016 22:17:44

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.735

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

pelo que entendi teria que ser ao  contrário


sudo ln -s /etc/resolv.conf /var/run/connman/resolv.conf

Offline

#7 26/04/2016 03:53:18

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

Na verdade é o contrário mesmo swatquest...
Mas mesmo assim esse connman, por algum motivo está tomando de conta do arquivo /etc/resolv.conf.
O que fiz pra resolver de vez meu problema foi o seguinte:

# systemctl disable connman
# systemctl disable connman-vpn
# rm -rf /etc/resolv.conf
# systemctl stop connman-vpn
# systemct restart netctl

Se não funcionar, dê um reboot no seu sistema.


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#8 26/04/2016 18:12:01

positivity
Membro
Registrado: 02/01/2016
Mensagens: 34

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

ola, pessoal!

Eu acabei de chegar em casa e ja testei os comandos passado pelo Phillipe. Infelizmente continuo sem conexao...
Bem, em todo o caso eu agradeco pela ajuda, vou ficar usando o Arch sem conexao mesmo, pois eu tenho varios programas que sao dificeis de instalar em outras distribuicoes, e quando eu precisar acessar a internet eu uso o tablet.

Temham todos uma otima semana.

Offline

#9 27/04/2016 00:13:50

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

positivity, não desista ainda meu caro!

Tente fazer o seguinte (como root):

# rm -rf /etc/resolv.conf
# resolvconf -u

"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#10 27/04/2016 18:40:58

positivity
Membro
Registrado: 02/01/2016
Mensagens: 34

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

phillipe escreveu:

positivity, não desista ainda meu caro!

Tente fazer o seguinte (como root):

# rm -rf /etc/resolv.conf
# resolvconf -u

Meu irmão... cê num vai acreditar: FUNCIONOU!!!
Eu nem achava mais que tinha como resolver isso, eu pensei que só reinstalando o sistema. Mas eis que eu executei esses comandos e a minha conexão foi restabelecida. Eu inicio o computador no modo terminal, e antes mesmo de digitar startx eu usei o lynx para ver se tinha navegação. Nunca fiquei tão feliz de ver aquela página inicial do lynx com todas aquelas cores... desculpa a comparação exagerada, mas eu me sinto como se você fosse um médico e tivesse me curado de uma doença grave!

VIVAAA!!!

Vou me esforçar para participar mais deste forum, é chato a gente vir até aqui só quando precisa de ajuda...

Offline

#11 28/04/2016 01:35:22

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

positivity escreveu:

Meu irmão... cê num vai acreditar: FUNCIONOU!!!
Eu nem achava mais que tinha como resolver isso, eu pensei que só reinstalando o sistema. Mas eis que eu executei esses comandos e a minha conexão foi restabelecida. Eu inicio o computador no modo terminal, e antes mesmo de digitar startx eu usei o lynx para ver se tinha navegação. Nunca fiquei tão feliz de ver aquela página inicial do lynx com todas aquelas cores... desculpa a comparação exagerada, mas eu me sinto como se você fosse um médico e tivesse me curado de uma doença grave!

VIVAAA!!!

Vou me esforçar para participar mais deste forum, é chato a gente vir até aqui só quando precisa de ajuda...

Kkkkkkkkkk....
Que maravilha meu camarada!
Dificilmente tenho problemas com Archlinux, mesmo com essas atualizações constantes, mas te confesso que gosto muito quando ocorre algum problema, pois os problemas nos força a entender melhor nosso sistema operacional.
E gostei muito da sua comparação! Rsrsrsrsrsr...


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#12 28/04/2016 18:22:09

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.658
Website

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

Coloque [RESOLVIDO] no tópico por favor =]


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#13 28/04/2016 21:16:24

positivity
Membro
Registrado: 02/01/2016
Mensagens: 34

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

corvolino escreveu:

Coloque [RESOLVIDO] no tópico por favor =]

Como faz? Tentei alterar o título do tópico mas não consegui...

Offline

#14 29/04/2016 01:50:48

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: [RESOLVIDO] wifi-menu conecta, porém nenhum navegador navega

Edita sua primeira postagem neste tópico.


"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

Rodapé do site