Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 03/06/2016 20:26:45

Adriano_Gon
Membro
Registrado: 03/06/2016
Mensagens: 12

[RESOLVIDO] Iniciar sddm automaticamente

Tive problemas com o Gnome e o gdm por conta do driver Catalyst... Removi eles e  instalei o Kde plasma e o sddm... Não consigo fazer o sddm iniciar sozinho, toda vez tenho que digitar "systemctl start sddm" . Como posso resolver isso?

Última edição por Adriano_Gon (03/06/2016 23:12:59)

Offline

#2 03/06/2016 20:32:11

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [RESOLVIDO] Iniciar sddm automaticamente

systemctl enable  sddm

mais informações
https://wiki.archlinux.org/index.php/Sy … sing_units

Offline

#3 03/06/2016 20:36:02

Adriano_Gon
Membro
Registrado: 03/06/2016
Mensagens: 12

Re: [RESOLVIDO] Iniciar sddm automaticamente

Eu fiz esse comando, mas como eu tinha antes instalado o gdm acho que foi criado um arquivo que deve estar o gdm como início automático

Offline

#4 03/06/2016 20:39:28

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [RESOLVIDO] Iniciar sddm automaticamente

systemctl disable  gdm

e então

systemctl enable  sddm

Offline

#5 03/06/2016 22:09:49

Adriano_Gon
Membro
Registrado: 03/06/2016
Mensagens: 12

Re: [RESOLVIDO] Iniciar sddm automaticamente

Quando eu digito systemctl disable gdm diz que arquivo ou diretorio não existe. Deve ser pq eu desinstalei o gdm... Será que eu não tenho que alterar o arquivo de inicialização ou coisa do tipo?

Offline

#6 03/06/2016 22:26:18

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [RESOLVIDO] Iniciar sddm automaticamente

tenta
systemctl disable  sddm
systemctl enable  sddm

Offline

#7 03/06/2016 22:49:09

Adriano_Gon
Membro
Registrado: 03/06/2016
Mensagens: 12

Re: [RESOLVIDO] Iniciar sddm automaticamente

Nada... quando eu digito systemctl enable sddm diz que o arquivo já existe.

Offline

#8 03/06/2016 22:59:16

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [RESOLVIDO] Iniciar sddm automaticamente

Oi amigo você executou o comando disable antes..

Se sim.

Apague o arquivo manualmente

rm -f /etc/systemd/system/display-manager.service

Então execute
systemctl enable  sddm

depois

Offline

#9 03/06/2016 23:11:53

Adriano_Gon
Membro
Registrado: 03/06/2016
Mensagens: 12

Re: [RESOLVIDO] Iniciar sddm automaticamente

Funcionou!!! Valeu mesmo, procurei em todo lugar isso e nada.... Abçs

Offline

#10 03/06/2016 23:12:41

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [RESOLVIDO] Iniciar sddm automaticamente

blz.

Coloca como resolvido no título do tópico.

Offline

Rodapé do site