Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 27/07/2016 22:56:04

MLagoa
Membro
De: Mundo Novo - MS
Registrado: 13/05/2016
Mensagens: 33

[RESOLVIDO] Ativar Nvidia 8600 GT sem usar o driver "nouveau" ?

Olá!
Antes de abrir o tópico, tentei encontrar matérias sobre o problema, mas infelizmente não achei nenhum tópico que me esclarecesse. Ainda sou "novato" no Arch Linux e no Linux em geral.
Em Maio/2016 eu mesmo fiz a instalação do Sistema no PC, seguindo tutoriais da internet, mas não tenho muita experiência no assunto.

Minha configuração: AMD Athlon-64 3700+ / RAM: 2Gb / Video: NVIDIA Corporation G84 [GeForce 8600 GT] (rev a1)

É possível configurar a placa gráfica (Nvidia 8600 GT) sem usar o driver "nouveau" ?
Sei que o Pacman faz download / instalação do driver "nvidia-340xx" e outros drivers necessários, porém não sei como ativar a instalação! (Suponho que esses drivers podem ativar recursos que o driver "nouveau" não ativa).
Como podem ver, meu PC é antigo, então quanto mais "redondo" eu conseguir deixá-lo, melhor ele vai funcionar, para compensar as peças já obsoletas.

Já baixei o driver nvidia-340xx, já removi o driver xf86-video-nouveau, gerei um xorg.conf com o comando: nvidia-xconfig, já executei o comando mkinitcpio. Fiz tudo isso seguindo vários tutoriais, alguns em português, outros em inglês, fiz isso diversas vezes mas não consegui resolver o problema!

Cada vez que executo o nvidia-xconfig, ele gera um xorg.conf. Mas ao reiniciar o computador, ele pára logo após a execução do Grub. Não completa o boot e nem libera o prompt, me obrigando a entrar noutro terminal via Ctrl+F2 para deletar manualmente o xorg.conf. Se eu não faço isso, a tela fica negra, sem prosseguir. E na vez que eu deletei o xf86-video-nouveau, fui obrigado a reinstalar depois, porque ao reiniciar o PC a tela continuou preta, dizendo que estava "fora de escala"...

Obs: Se eu deletar o xorg.conf da pasta /etc/X11/ o computador reinicia normalmente e entra na tela gráfica (desde que eu tenha xf86-video-nouveau instalado). Também estou usando o XFCE4 e o gerenciador LXDE.

Fico aguardando instruções passo-a-passo, e agradeço a atenção de vocês.

Eis o xorg.conf que o nvidia-xconfig gerou:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 340.96  ([email protected])  Sun Nov  8 22:50:27 PST 2015

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Última edição por MLagoa (07/08/2016 16:59:37)


Ao trocar dois pães, cada um voltará pra casa com um pão. Mas ao trocar ideias, cada um voltará pra casa com duas ideias...

Offline

#2 27/07/2016 23:51:34

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [RESOLVIDO] Ativar Nvidia 8600 GT sem usar o driver "nouveau" ?

Você pode utilizar o nvIdia-settings e salve o xorg em /etc/X11

https://wiki.archlinux.org/index.php/NVIDIA

Você pode usar o /etc/X11/xorg.conf.d/20-nvidia.conf
Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        Option "NoLogo" "true"
EndSection

Última edição por swatquest (27/07/2016 23:58:57)

Offline

#3 28/07/2016 00:46:31

MLagoa
Membro
De: Mundo Novo - MS
Registrado: 13/05/2016
Mensagens: 33

Re: [RESOLVIDO] Ativar Nvidia 8600 GT sem usar o driver "nouveau" ?

Eu não tenho o arquivo "20-nvidia.conf" dentro de /etc/X11/xorg.conf.d... Essa pasta existe, mas está vazia. Nem mesmo arquivo oculto há nela.
Executei o nvidia-settings (como usuário comum e também root, através do terminal), mas não sei o quê e nem como configurar aquilo:
Ao executar nvidia-settings, o aplicativo abre, mas deixa essa mensagem no terminal:
ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       preopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

E na tela gráfica do aplicativo, ele avisa:
"You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

Obs: `nvidia-xconfig` eu já executei (antes mesmo do nvidia-settings).

E dentro de "/usr/share/nvidia/nvidia-application-profiles-key-documentation" encontrei um longo texto de configurações que não me ajudou em nada a entender o problema.

Mesmo usando o tradutor do Google pra decifrar as mensagens, continuo sem saber o que fazer.
Sou mesmo leigo no assunto.

Obrigado pela resposta Swatquest, mas ainda sem solução para o meu problema...

Última edição por MLagoa (28/07/2016 01:17:45)


Ao trocar dois pães, cada um voltará pra casa com um pão. Mas ao trocar ideias, cada um voltará pra casa com duas ideias...

Offline

#4 28/07/2016 22:13:24

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [RESOLVIDO] Ativar Nvidia 8600 GT sem usar o driver "nouveau" ?

então cara..

Apaga o /etc/X11/xorg.conf
Crie o arquivo /etc/X11/xorg.conf.d/20-nvidia.conf
E adicione o básico

Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        Option "NoLogo" "true"
EndSection

Veja aqui para mais informação

Última edição por swatquest (28/07/2016 22:15:40)

Offline

#5 29/07/2016 15:05:25

MLagoa
Membro
De: Mundo Novo - MS
Registrado: 13/05/2016
Mensagens: 33

Re: [RESOLVIDO] Ativar Nvidia 8600 GT sem usar o driver "nouveau" ?

Legal Swatquest, pela tua paciência comigo… Mas não querendo abusar dela, gostaria que por favor analisasse o resultado da minha nova tentativa, e se puder, me dar ainda alguma sugestão (talvez até mesmo um passo-a-passo, se for possível), porque continuo sem solução:

a) Primeira tentativa:
Criei o arquivo /etc/X11/xorg.conf.d/20-nvidia.conf colando nele a configuração que você me passou, reiniciei o PC e a tela congelou logo após o Grub.
Então: Segundo terminal (Ctrl+F2) = apaguei o arquivo 20-nvidia.conf   Obs: Após deletar, o computador abriu o ambiente gráfico.

b) Segunda tentativa:
Criei o arquivo /etc/X11/xorg.conf.d/20-nvidia.conf outra vez, depois deletei o arquivo xf86-video-nouveau, e executei o comando “mkinitcpio” (não sei se é necessário executar, mas li em algum lugar que após atualização da placa nvidia, deveria executá-lo outra vez). Reiniciei o PC e a tela congelou outra vez. Então apaguei o arquivo 20-nvidia.conf
Aí o monitor continuou com tela negra e a mensagem: “Fora de sincronia”. Então voltei ao segundo terminal e reinstalei o xf86-video-nouveau. Após isso, o PC abriu a interface gráfica.

Tenho impressão que os comandos que configuram o driver nouveau estão “enraizado” em algum lugar que não tenho acesso, porque nem mesmo instalando o driver “nvidia-340xx” e “nvidia-340xx-utils” e deletando “xf86-video-nouveau”, meu PC teima em querer abrir a interface usando a nouveau...

Obs: Gerei um arquivo TXT com o comando dmesg, e em certo lugar tenho isso aqui:
Se puder me ajudar resolver, fico imensamente agradecido:

[    7.963736] fb: switching to nouveaufb from VESA VGA
[    7.963790] Console: switching to colour dummy device 80x25
[    7.964079] nouveau 0000:02:00.0: NVIDIA G84 (084100a2)
[    8.084268] nouveau 0000:02:00.0: bios: version 60.84.43.00.81
[    8.111294] nouveau 0000:02:00.0: bios: M0203T not found
[    8.111301] nouveau 0000:02:00.0: bios: M0203E not matched!
[    8.111304] nouveau 0000:02:00.0: fb: 512 MiB DDR2
[    8.172438] nouveau 0000:02:00.0: PCI: Disallowing DAC for device
[    8.175923] [TTM] Zone  kernel: Available graphics memory: 1026148 kiB
[    8.175928] [TTM] Initializing pool allocator
[    8.175937] [TTM] Initializing DMA pool allocator
[    8.175960] nouveau 0000:02:00.0: DRM: VRAM: 512 MiB
[    8.175962] nouveau 0000:02:00.0: DRM: GART: 1048576 MiB
[    8.175970] nouveau 0000:02:00.0: DRM: TMDS table version 2.0
[    8.175973] nouveau 0000:02:00.0: DRM: DCB version 4.0
[    8.175977] nouveau 0000:02:00.0: DRM: DCB outp 00: 02000300 00000028
[    8.175981] nouveau 0000:02:00.0: DRM: DCB outp 01: 04011310 00020030
[    8.175984] nouveau 0000:02:00.0: DRM: DCB outp 02: 02011312 00020030
[    8.175986] nouveau 0000:02:00.0: DRM: DCB outp 03: 010223f1 00c0c080
[    8.175989] nouveau 0000:02:00.0: DRM: DCB conn 00: 1000
[    8.175991] nouveau 0000:02:00.0: DRM: DCB conn 01: 2130
[    8.175993] nouveau 0000:02:00.0: DRM: DCB conn 02: 0210
[    8.175995] nouveau 0000:02:00.0: DRM: DCB conn 03: 0211
[    8.175997] nouveau 0000:02:00.0: DRM: DCB conn 04: 0213
[    8.183039] nouveau 0000:02:00.0: DRM: failed to create encoder 0/1/0: -19
[    8.183046] nouveau 0000:02:00.0: DRM: TV-1 has no encoders, removing
[    8.183094] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    8.183096] [drm] Driver supports precise vblank timestamp query.
[    8.310723] powernow_k8: fid 0xe (2200 MHz), vid 0x8
[    8.310730] powernow_k8: fid 0xc (2000 MHz), vid 0x8
[    8.310732] powernow_k8: fid 0xa (1800 MHz), vid 0xa
[    8.310733] powernow_k8: fid 0x2 (1000 MHz), vid 0x12
[    8.310778] powernow_k8: Found 1 AMD Athlon(tm) 64 Processor 3700+ (1 cpu cores) (version 2.20.00)
[    8.447399] nouveau 0000:02:00.0: DRM: MM: using CRYPT for buffer copies
[    8.481649] ppdev: user-space parallel port driver
[    8.514281] systemd[1]: Reached target Sound Card.
[    8.526953] nouveau 0000:02:00.0: DRM: allocated 1024x768 fb: 0x70000, bo ffff88007be5d400
[    8.527177] fbcon: nouveaufb (fb0) is primary device
[    8.644386] Console: switching to colour frame buffer device 128x48
[    8.644745] nouveau 0000:02:00.0: fb0: nouveaufb frame buffer device
[    8.653373] [drm] Initialized nouveau 1.3.1 20120801 for 0000:02:00.0 on minor 0
[    8.689985] EDAC MC: Ver: 3.0.0
[    8.713450] MCE: In-kernel MCE decoding enabled.
[    8.718047] AMD64 EDAC driver v3.4.0
[    8.718116] EDAC amd64: DRAM ECC disabled.
[    8.718121] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)

Última edição por MLagoa (29/07/2016 15:08:51)


Ao trocar dois pães, cada um voltará pra casa com um pão. Mas ao trocar ideias, cada um voltará pra casa com duas ideias...

Offline

#6 30/07/2016 00:19:53

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [RESOLVIDO] Ativar Nvidia 8600 GT sem usar o driver "nouveau" ?

Amigo

Se você criar o arquivo /etc/X11/xorg.conf.d/20-nvidia.conf
E adicione o básico

Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
EndSection

Ele trava..
Não tenho ideia do que pode ser.

Já tentou remover este pacote e instalar de novo

pacman -Rsn nvidia nvidia-340xx
find /var/cache/pacman/pkg/ -iname nvidia-340xx*

o resultado você apaga
rm /var/cache/pacman/pkg/nvidia-340xx****

pacman -S nvidia-340xx

Você também pode tentar fazer um downgrade
Talvez seja esta versão
Instale o pacote downgrade
https://aur.archlinux.org/packages/downgrade/

Dai tente um versão mais anterior
downgrade nvidia-340xx

Qual a sua placa de video onboard?

Última edição por swatquest (30/07/2016 00:21:04)

Offline

#7 30/07/2016 23:27:15

MLagoa
Membro
De: Mundo Novo - MS
Registrado: 13/05/2016
Mensagens: 33

Re: [RESOLVIDO] Ativar Nvidia 8600 GT sem usar o driver "nouveau" ?

A minha Motherboard é Asus modelo A8V-E SE, ou seja, uma placa-mãe SEM placa de vídeo on-board...
Antes de instalar o xorg, eu procurei alguma informação sobre o melhor driver para minha placa Nvidia 8600-GT:
Entrei na página Wiki do Arch Linux e de lá eu fui direcionado ao site da Nvidia e peguei essas informações sobre o driver apropriado: http://www.nvidia.com/object/IO_32667.html e foi justamente aí que eu vi que o driver para minha placa é "nvidia 340.xx". Sendo assim, decidi instalar o xorg com o suporte da nvidia-340xx (na hora de instalar, o pacman pede pra escolher uma das opções, né?). Por isso, tenho quase certeza que é esse o driver correto, apenas não sei ainda como inibir a nouveau e ativar a nvidia-340xx!

Swatquest, ainda não fiz o downgrade porque nunca usei o AUR, mas se não houver outra solução menos drástica, vou tentar fazê-lo, se esse for o único caminho para instalar o driver correto da minha placa de vídeo...
De qualquer forma, sou muito grato pela atenção smile
Já conheci muitas distribuições Linux, algumas até bem fáceis de instalar, mas sempre procurei por uma que fizesse a instalação bem enxuta, com somente aquilo que eu quisesse. Aceitei o desafio de instalar o Arch + XFCE, mesmo sabendo que é uma distro para veteranos... Apesar da dificuldade inicial, estou adorando a leveza do Sistema, que deixou minha velha máquina "mais esperta".
Vou continuar na tentativa de deixá-lo redondo. Estou registrando tudo. E se eu conseguir (e houver espaço aqui), futuramente quero postar um tutorial passo-a-passo para que outras pessoas tão leigas quanto eu possam também fazer sua instalação personalizada do Arch.
Obrigado por tudo!


Ao trocar dois pães, cada um voltará pra casa com um pão. Mas ao trocar ideias, cada um voltará pra casa com duas ideias...

Offline

#8 02/08/2016 15:28:12

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [RESOLVIDO] Ativar Nvidia 8600 GT sem usar o driver "nouveau" ?

Você pode remover o nouveau, mas não adiantaria pois o nvidia está dando erro.

Offline

#9 05/08/2016 14:58:02

MLagoa
Membro
De: Mundo Novo - MS
Registrado: 13/05/2016
Mensagens: 33

Re: [RESOLVIDO] Ativar Nvidia 8600 GT sem usar o driver "nouveau" ?

Olá a todos, especialmente ao Swatquest que me acompanhou no fórum (configuração da placa Nvidia GeForce 8600 GT):
Hoje consegui resolver o problema, e vou deixar aqui o procedimento (bem simples, mas eu infelizmente não sabia disso):

a) Instale o driver (para minha placa de vídeo, é o driver "nvidia-340xx", mas existe também o "nvidia-304xx")
# pacman -S nvidia-340xx

b) Reinicie o PC em modo texto. Ou estando na tela gráfica, combine as teclas Ctrl F2 para acessar um terminal virtual.

c) Como root, crie um arquivo chamado "nouveau.conf" dentro da pasta /etc/modprobe.d/
# nano /etc/modprobe.d/nouveau.conf

c) Digite essas duas linhas dentro do arquivo e salve-o:
     blacklist nouveau
     options nouveau modeset=0

d) Agora, rode o comando de configuração:
# X -configure
(será gerado um arquivo "xorg.conf.new" na pasta /root/ )

e) Faça uma cópia do segurança do seu arquivo xorg.conf, se ele existir (para você reativá-lo, caso dê tudo errado):
Não se esqueça de verificar primeiro se ele realmente existe:
# ls /etc/X11/

Se o comando lhe informar que ele existe, então agora faça a cópia:
# cp /etc/X11/xorg.conf  /etc/X11/backup.xorg.conf

f) Agora, copie o arquivo "xorg.conf.new" para a pasta /etc/X11/
# cp /root/xorg.conf.new  /etc/X11/xorg.conf.new

g) Abra esse arquivo com o editor de textos:
# nano /etc/X11/xorg.conf.new

e procure pela linha:   Driver    "nouveau"

Comente essa linha com um "#", e digite na linha logo abaixo:   Driver     "nvidia"

Vai ficar assim:
#Driver    "nouveau"
Driver       "nvidia"

h) Salve o arquivo, em seguida renomeie-o para "xorg.conf":
# cp /etc/X11/xorg.conf.new  /etc/X11/xorg.conf

i) Agora pode reiniciar o Sistema (# reboot now)
Se vocề instalou o driver correto para sua placa de vídeo (não se esqueça de verificar isso antes!!),
teu Sistema já reiniciará com a placa funcionando 100%.

Desfazendo:
Se tudo deu errado, combine as teclas ( Ctrl F2 ) para acessar um terminal, e como root você apaga o arquivo:
# rm /etc/modprobe.d/nouveau.conf

Depois, se você fez uma cópia de segurança do antigo arquivo "xorg.conf", restaure-o:
# rm /etc/X11/xorg.conf  (este comando é para apagar o NOVO arquivo xorg.conf)
# cp /etc/X11/backup.xorg.conf  /etc/X11/xorg.conf

Obs: se não existia antes nenhum arquivo "xorg.conf", basta apenas apagar o existente, seu sistema voltará a funcionar como era antes.

Reinicie o sistema e pronto.

Obs: Tem uma forma mais inteligente de usar os comandos rm, cp, ls etc, etc, etc, mas eu sou novato no Linux
e por isso não conheço ainda todos os atalhos.
Porém, esse foi o procedimento que eu fiz, e agora estou finalmente, com minha placa GeForce 8600-GT 100% funcional.

Também mencionei o editor de textos. Eu uso o "nano", porém fique à vontade para usar seu editor preferido.
Não coloquei acima os comandos para salvar o arquivo com o nano;
Mas é:
Ctrl O = salva o arquivo
Ctrl X = sai do editor de textos.

Última edição por MLagoa (07/08/2016 17:00:08)


Ao trocar dois pães, cada um voltará pra casa com um pão. Mas ao trocar ideias, cada um voltará pra casa com duas ideias...

Offline

Rodapé do site