Você não está autenticado.

#1 26/02/2012 06:06:26

JosephDaemon
Membro
Registrado: 26/02/2012
Mensagens: 9

RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

Galera,

Eu estaou com problemas no relógio do arch.

Colocanso "localtime" ao invés de "UTC" no campo HARDWARECLOCK em "/etc/rc.conf" resolve-se o problema caso vc esteja usando init padrão do arch.

Só que eu estou usando o famoso systemd. E o systemd ignora o campo HARDWARECLOCK do rc.conf

Ou seja, alterar para localtime não adianta mais. Adiantava quando eu usava o init padrão (mais lento do que o systemd).

O arch wiki diz que o systemd não trabalha mais com localtime mesmo...

Eu tô usando uma solução " muito porca": adiantei o relógio da bios em 1h... Aí o relógio fica certo no arch... usando UTC.

Alguma outra sugestão pra acertar o relógio?


Sds

Offline

#2 26/02/2012 20:49:52

sistematico
Moderador
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.008
Website

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

Tentou isso?

Offline

#3 26/02/2012 22:04:31

rdfreitas
Membro
De: São Paulo - SP
Registrado: 06/07/2009
Mensagens: 436

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

Por que não usa ntp ?


Email : [email protected]
arch x64 + Openbox

Offline

#4 01/03/2012 19:39:27

JosephDaemon
Membro
Registrado: 26/02/2012
Mensagens: 9

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

sistematico escreveu:

Tentou isso?

Sim... Aí ele só explica que localtime é algo em extinção... até para windows.

Ele recomenda UTC.

Estou usando UTC e só o arch instalado com o kde 4.8 e systemd... Mais nada!

O systemd não suporta mais localtime...

Tô sem solução até agora

Offline

#5 01/03/2012 19:45:51

JosephDaemon
Membro
Registrado: 26/02/2012
Mensagens: 9

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

rdfreitas escreveu:

Por que não usa ntp ?

Eu instalei o "ntp" e adicionei o ntpd aos "daemons array" em /etc/rc.conf


A situação ficou a seguinte:

Relógio da bios perfeito...
Relógio do arch inicia doidão e depois de meia hora acerta-se sozinho... Mas pq esse delay todo do ntpd? Esquisito...

Outra parada esquisita é a mensagem de erro na "configuração do sistema do kde" > "data e hora" quando eu habilito "pool.ntp.org"

Alguma idéia?

Offline

#6 01/03/2012 21:31:38

rutgerr
Membro
Registrado: 02/03/2011
Mensagens: 52
Website

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

Acho mais prático tirar o daemon do array, e acrecentar esta instrução ao /etc/rc.local:

{ ntpd -qg; hwclock -w; } &

assim ele sincroniza no boot, e grava na bios, feito isso voce pode esquecer o relógio do kde (acho que é bugado aqui ocorre o mesmo).

Para usar apenas  os servers brasileiros, retire os que vem por padrão no /etc/ntp.conf e deixe apenas este:
server 0.pool.ntp.br iburst.

Offline

#7 02/03/2012 00:45:08

sistematico
Moderador
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.008
Website

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

JosephDaemon escreveu:

Sim... Aí ele só explica que localtime é algo em extinção... até para windows.

Quando eu usava UTC meu relógio ficava mudando de horário sempre, aí eu mudei pra localtime e parou.

A respeito do NTP, ele é MUITO bom pra manter sempre seu relógio ajustado, mas usa-lo para corrigir o que seu sistema está quebrando, eu acho errado.
Isso seria combater o sintoma e deixar de lado a doença, IMHO.

Abraço.

Offline

#8 02/03/2012 00:55:22

sistematico
Moderador
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.008
Website

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

HARDWARECLOCK (use 'hwclock --systohc --utc' to set your hardware clock to utc, localtime is not supported, see FAQ)
Achei isso no Wiki.

Talvez o daemon hwclock nos DAEMONS=()?

Abraço.

Offline

#9 02/03/2012 13:22:50

rutgerr
Membro
Registrado: 02/03/2011
Mensagens: 52
Website

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

sistematico escreveu:

HARDWARECLOCK (use 'hwclock --systohc --utc' to set your hardware clock to utc, localtime is not supported, see FAQ)
Achei isso no Wiki.

Talvez o daemon hwclock nos DAEMONS=()?

Abraço.



Sim, mas o hwclock é incompatível com o systemd citado no primeiro post, aí está o porque dessa manobra toda, mas ainda assim, acho mais vantojoso, porque o tempo de boot despenca com o uso do systemd .

Offline

#10 02/03/2012 14:37:03

rafael_kenichi
Membro
De: Florianópolis, SC
Registrado: 25/02/2011
Mensagens: 71

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

Para usar UTC seu relogio da bios deve estar com horario de Greenwich e no rc.conf em HARDWARECLOCK deve estar com UTC e TIMEZONE deve estar configurado o seu fuso horario, como moro em florianópolis o meu esta assim TIMEZONE="America/Sao_Paulo".

Se você configurar o relogio da bios para o de brasilia e colocar para usar UTC o relogio vai atrasar 03:00 horas pq brasilia fica no fuso horaio -03:00 de Greenwich...


Notebook intel core i7 620M, 6gb ram ddr3, 500gb de hd, intel hd graphics, Arch Linux x86_64 Adeus Gnome! Ola KDE!

Offline

#11 20/04/2012 23:18:47

willianholtz
Membro
De: Três Barras - SC
Registrado: 23/08/2009
Mensagens: 375

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

Estou com o mesmo problema, porém nada funciona... ja tentei tudo citado aqui mas nada .. sempre tenho de ajustar o relógio!


Vostro 1520 = CPU:Core 2 Duo P8600 2.4GHz 3MB | GPU:NVidia GeForce 9300M GS de 512MB | HD: 360GB | RAM:4GB | Arch-Linux

Offline

#12 25/11/2012 19:52:48

deusdara
Membro
De: Vila Velha, ES
Registrado: 25/11/2009
Mensagens: 13

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

Olá

Tenho instalado o Arch Linux KDE com systemd puro.

O relógio funciona sem problemas.

A configuração é esta

Configurar o timezone
#ln -s /usr/share/zoneinfo/America/Sao_Paulo /etc/localtime

Notar que foi usado “Sao_Paulo”. Para verificar as cidades disponíveis usar “ls /usr/share/zoneinfo/America/”.

Relógio de Hardware

Configurar o modo de relógio de hardware uniformemente entre seus sistemas operacionais instalados.

Pode-se gerar o arquivo /etc/adjtime  automaticamente usando o seguinte comando:

UTC (recomendado)

Nota: Usar UTC para o relógio de hardware não significa que o sistema mostrará a hora em UTC.

#hwclock --systohc --utc


[Mobo: Asus B85M-E/BR   ][CPU: Intel Core i7 [email protected] GHz][RAM 2x4 GB 1333 MHz DDR3 Kingston][GPU: nVidia GTX 570][HD:Seagate 1,0 TB SATA II][Fonte: ThermalTake TR2 RX 750 W ][ArchLinux]

Offline

#13 25/11/2012 20:01:55

hotvic
Membro
De: Remígio - PB
Registrado: 25/07/2012
Mensagens: 475
Website

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

segundo esse tuto.  /etc/adjtime é pra está:

0.0 0.0 0.0
0
LOCAL

no case de está usando systemd.

outra porque ainda está com /etc/rc.conf ?, use o metodo nativo do systemd.

depois:

# systemctl enable ntpd

ou pode ativar "Hora da Rede", se estiver usando gnome-shell que dá do mesmo do comando acima.

aqui demora +/- 1 min. pra atualizar depois do DE já iniciado.


Google + | Twitter
“A mente que se abre a uma nova idéia jamais voltará ao seu tamanho original.” (Albert Einstein)

Offline

#14 25/11/2012 21:05:21

danilo21
Membro
De: Rio de Janeiro, Rio de janeiro
Registrado: 19/04/2009
Mensagens: 193

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

No kde sempre ficava 2 horas a menos, mas se eu passa-se o mouse aparecia UTC corretamente,então aproveitei e coloquei para ele exibir em UTC logo, nem mando atualizar, agora ele começa certo sempre. Como não tenho windows não encontrei problemas.


Desenvolvedor de Software e Estudante de Ciência da Computação na PUC Rio desde 2012

Offline

#15 11/08/2016 19:31:46

david0511
Membro
Registrado: 18/06/2016
Mensagens: 48

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

A Solução é simples e definitiva. Não prexisa instalar NTC nem nada. Isso realmente soluciona o problema, não maqueia.
É só ir no  /etc/adjtime e trocar o UTC pelo Local. (Nesse exemplo já está trocado)

0.0 0.0 0.0
0
LOCAL

Offline

#16 11/08/2016 19:32:16

david0511
Membro
Registrado: 18/06/2016
Mensagens: 48

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

A Solução é simples e definitiva. Não precisa instalar NTC nem nada. Isso realmente soluciona o problema, não maqueia.
É só ir no  /etc/adjtime e trocar o UTC pelo Local. (Nesse exemplo já está trocado)

0.0 0.0 0.0
0
LOCAL

Última edição por david0511 (12/08/2016 11:25:56)

Offline

#17 18/08/2016 13:15:26

sistematico
Moderador
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.008
Website

Re: RELÓGIO maluco no arch com o SYSTEMD - localtime não funciona

Utilize o timedatectl:

man timedatectl

Offline

Rodapé do site