Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 09/12/2016 09:54:32

vitorthegreat
Membro
Registrado: 09/12/2016
Mensagens: 7

Deepin Desktop não inicia

Ola pessoal, o problema é o seguinte, meu Arch funciona normalmente com GNOME, porem eu instalei o Deepin Desktop e funcionou por um tempo normalmente e achei muito bonito, mas ja fazem 3 dias que ele não inicia mais, eu seleciono o Deepin no login e a tela fica preta e volta para login, ja procurei aqui no forum e em todo canto na internet uma solução, ja fiz de tudo que encontrei porem não resolveu o Deepin Desktop apenas não inicia mais, o GNOME esta tudo ok.

quando eu executo o startdde:

# startdde
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x80 pc=0x5f3e3f]

goroutine 1 [running]:
panic(0x7acee0, 0xc42000c150)
	/usr/lib/go/src/runtime/panic.go:500 +0x1a1
github.com/BurntSushi/xgb/xproto.InternAtom(0x0, 0x30000, 0x804172, 0x3, 0xc42000c990)
	/build/startdde/src/build/src/github.com/BurntSushi/xgb/xproto/xproto.go:10975 +0x20f
pkg.deepin.io/dde/startdde/display.getAtom(0x0, 0x804172, 0x3, 0x80d75d)
	/build/startdde/src/startdde/gopath/src/pkg.deepin.io/dde/startdde/display/utils.go:68 +0x49
pkg.deepin.io/dde/startdde/display.init()
	/build/startdde/src/startdde/gopath/src/pkg.deepin.io/dde/startdde/display/detect_output.go:144 +0x180
main.init()
	_/build/startdde/src/startdde/_obj/_cgo_import.go:29 +0x49

quando executo xhost +:

# xhost +
Invalid MIT-MAGIC-COOKIE-1 keyxhost:  unable to open display ":0"

Em questão ao "display :0", ja tentei tambem resolver mas nada (creio que seja isso, sera?)

Tenho uma placa de video NVIDIA : 3D controller: NVIDIA Corporation GM108M [GeForce 840M] (rev a2) e Intel: VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

Bom, com certeza eu fucei em algo(como sou noob e muito noob em Linux) que deu pau. Alguem tem uma luz??

Offline

#2 09/12/2016 23:41:47

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: Deepin Desktop não inicia

Dê uma olhada aqui
https://wiki.archlinux.org/index.php/De … nvironment

Para iniciar a desktop você não usa o comando startdde

Você tem que escolher se quer iniciar atravês de um gerenciador de login ou pelo startx

Caso escolha o startx

No arquivo ~/.xinitrc

Adicione

exec startdde

Sobre o xinitrc
https://wiki.archlinux.org/index.php/Xinit#xinitrc

Para iniciar no boot sem um gerenciador de login
https://wiki.archlinux.org/index.php/Xi … X_at_login

Por exemplo:
~/.bash_profile

[[ -z $DISPLAY && $XDG_VTNR -eq 1 ]] && exec startx -- -keeptty -nolisten tcp > ~/.xorg.log 2>&1

E para ter um autologin via console
https://wiki.archlinux.org/index.php/Ge … al_console

Por exemplo:
Para não mostrar o login no console virtual
/etc/systemd/system/[email protected]/override.conf

[Service]
ExecStart=
ExecStart=-/usr/bin/agetty --skip-login --login-options "-f seu_usuário" %I 38400 linux

Perguntar a senha

[Service]
ExecStart=
ExecStart=-/usr/bin/agetty --skip-login --login-options seu_usuário --noclear %I 38400 linux

Última edição por swatquest (09/12/2016 23:50:48)

Offline

#3 10/12/2016 12:30:30

vitorthegreat
Membro
Registrado: 09/12/2016
Mensagens: 7

Re: Deepin Desktop não inicia

Então, eu ja mudei o ~/.xinitirc e mesmo assim não funcionou, fiz isso e nada do DDE rodar novamente.

Quando instalei o DDE segui o - https://wiki.archlinux.org/index.php/De … nvironment tambem e funcionou de primeira.

ainda sem iniciar o DDE.

precisa de alguma outra informação que eu não passei?

Offline

#4 10/12/2016 22:00:59

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: Deepin Desktop não inicia

qual a saída do comando startx?

Você tem o drive de video instalado?

Última edição por swatquest (10/12/2016 22:01:10)

Offline

#5 11/12/2016 12:18:08

vitorthegreat
Membro
Registrado: 09/12/2016
Mensagens: 7

Re: Deepin Desktop não inicia

Saida do comando startx:

# startx


X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.5.4-1-ARCH x86_64 
Current Operating System: Linux localhost.localdomain 4.8.12-2-ARCH #1 SMP PREEMPT Fri Dec 2 20:17:06 CET 2016 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=5f8d2be9-4aef-4571-b956-5d8b3a42d812 rw quiet
Build Date: 19 July 2016  05:54:24PM
 
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Sun Dec 11 12:14:50 2016
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Failed to connect to bus: Operation not permitted
dbus-update-activation-environment: error: unable to connect to D-Bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
/etc/X11/xinit/xinitrc: line 55: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 54: xterm: command not found
/etc/X11/xinit/xinitrc: line 53: xterm: command not found
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

Sim tenho os drivers de video instalados: intel e nouveau(nvidia).

Sera que é por conta do display?

Offline

#6 11/12/2016 22:09:13

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: Deepin Desktop não inicia

O dbus não está iniciando direito

Como está o seu .xinitrc?

Última edição por swatquest (11/12/2016 22:53:43)

Offline

#7 12/12/2016 14:16:47

vitorthegreat
Membro
Registrado: 09/12/2016
Mensagens: 7

Re: Deepin Desktop não inicia

xinitrc:

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login

Offline

#8 12/12/2016 22:02:26

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: Deepin Desktop não inicia

Oi amigo não é o /etc/X11/xinit/xinitrc

e sim o ~/.xinitrc no diretório home

Caso não tenha crie um no diretório

touch  ~/.xinitrc

e depois edite

nano ~/.xinitrc


e adicione o seguinte conteúdo

#!/bin/sh
# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?* ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

exec startdde

depois execute o startx

Offline

#9 13/12/2016 09:45:11

vitorthegreat
Membro
Registrado: 09/12/2016
Mensagens: 7

Re: Deepin Desktop não inicia

Amigo, obrigado a paciência (hehehe) mas criei o arquivo ~/.xinitrc e executei startx

# startx


X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.5.4-1-ARCH x86_64 
Current Operating System: Linux localhost.localdomain 4.8.12-2-ARCH #1 SMP PREEMPT Fri Dec 2 20:17:06 CET 2016 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=5f8d2be9-4aef-4571-b956-5d8b3a42d812 rw quiet
Build Date: 19 July 2016  05:54:24PM
 
Current version of pixman: 0.34.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Dec 13 09:40:00 2016
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) 
Fatal server error:
(EE) no screens found(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

configuração do xorg.conf

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/misc/"
	FontPath     "/usr/share/fonts/TTF/"
	FontPath     "/usr/share/fonts/OTF/"
	FontPath     "/usr/share/fonts/Type1/"
	FontPath     "/usr/share/fonts/100dpi/"
	FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
	Load  "glx"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "VideoKey"           	# <i>
        #Option     "WrappedFB"          	# [<bool>]
        #Option     "GLXVBlank"          	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "PageFlip"           	# [<bool>]
        #Option     "SwapLimit"          	# <i>
        #Option     "AsyncUTSDFS"        	# [<bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "DRI"                	# <i>
	Identifier  "Card0"
	Driver      "nouveau"
	BusID       "PCI:10:0:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

sera que é uma configuração no xorg.conf em relação a screen que eu não estou vendo (noob!)?

Offline

#10 13/12/2016 14:52:20

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: Deepin Desktop não inicia

Fala cara..

O xorg.conf não é mais necessário.

Recomendo você fazer um teste.

apague o /etc/X11/xorg.conf

e reinicie a máquina
e teste o startx

Caso não funcione ou queira usar o nouveau
Crie um arquivo
/etc/X11/xorg.conf.d/20-nouveau.conf

com o seguinte conteúdo

Section "Device"
    Identifier "Nvidia card"
    Driver "nouveau"
EndSection

mais informaçào https://wiki.archlinux.org/index.php/Nouveau

Última edição por swatquest (13/12/2016 14:52:48)

Offline

#11 13/12/2016 16:59:39

vitorthegreat
Membro
Registrado: 09/12/2016
Mensagens: 7

Re: Deepin Desktop não inicia

Cara, tentei os dois deletei o xorg.conf e executei startx porem ficou uma tela preta e não saiu disso depois eu segui os passos que você falou sobre o nouveau tambem nada

talvez o log ajude a entender algo

/var/log/Xorg.1.log

[   106.064] (EE) No devices detected.
[   106.064] (EE) 
Fatal server error:
[   106.064] (EE) no screens found(EE) 
[   106.064] (EE) 

Offline

#12 14/12/2016 00:29:29

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: Deepin Desktop não inicia

Tem pouca informação
veja se resolve
https://bbs.archlinux.org/viewtopic.php?id=207424

I had to do that also, using in .bash_profile:

[[ -z $DISPLAY && $XDG_VTNR == 1 ]] && startx -- -keeptty &> $HOME/xsession.log

Veja também em
https://www.google.com.br/search?q=+No+ … hlinux.org

https://bbs.archlinux.org/viewtopic.php?id=180097

Offline

#13 19/12/2016 15:31:46

vitorthegreat
Membro
Registrado: 09/12/2016
Mensagens: 7

Re: Deepin Desktop não inicia

Boa tarde, desculpe a demora para dar uma resposta, mas eu fiz todos os procedimentos de novo, instalei e desinstalei tudo, mas mesmo assim não funcionou, creio que eu devo ter feito alguma besteira com os drivers da placa de video e o xorg que não pegavam mais, e como precisava meio rapido do notebook pois só tenho ele para trabalhar, acabei reinstalando o Arch (pois não consigo largar mais ele hehe) do zero e agora esta tudo ok, rodando com o Deepin Desktop liso.

Obrigado a força e a paciência, mais para frente eu fuço de novo o que pode ter sido.

Muito obrigado de novo!!!

Offline

Rodapé do site