Você não está autenticado.

#1 29/09/2016 03:47:00

MLagoa
Membro
De: Mundo Novo - MS
Registrado: 13/05/2016
Mensagens: 21

[Resolvido] Multifuncional Epson Wireless

Olá amigos.
Pesquisei no fórum assuntos semelhantes, mas não encontrei resposta para o meu problema:
Tenho multifuncional Epson L375, que consigo imprimir/escanear via witeless a partir de um notebook
com Windows Seven instalado.
Porém, tenho abandonado gradualmente esse sistema, e hoje minha máquina principal de trabalho
é um PC com o Arch Linux + XFCE instalado (enxuto e eficiente,  além de seguro).
E eu preciso muito detectar a multifuncional nessa máquina.
Claro que se for possível via wireless, será bem melhor.
Mas se não,  uma configuração via cabo USB já é suficiente pra mim.

Agradeço a atenção de vocês.

Última edição por MLagoa (30/09/2016 22:47:51)


Ao trocar dois pães, cada um voltará pra casa com um pão. Mas ao trocar ideias, cada um voltará pra casa com duas ideias...

Offline

#2 29/09/2016 23:40:31

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.376

Re: [Resolvido] Multifuncional Epson Wireless

Offline

#3 30/09/2016 02:17:49

MLagoa
Membro
De: Mundo Novo - MS
Registrado: 13/05/2016
Mensagens: 21

Re: [Resolvido] Multifuncional Epson Wireless

Ainda sem solução...

Consegui instalar CUPS e Avahi, seguindo o link que swatquest deixou aqui. Muito obrigado por isto!! smile
Instalei também as dependências: ghostscript (esse, com o comando pacman - antes do pacote epson)
Seguindo o link que me levou à página do AUR, também instalei o pacote "epson-inkjet-printer-escpr"
Depois, habilitei meu usuário comum para acessar Avahi, adicionando-o no Grupo.

Porém, quando tento adicionar uma impressora usando o aplicativo de configuração no Menu, vou até a opção: "Escolher Driver" e "Fornecer arquivo PPD", então escolho o modelo da minha impressora, que está na pasta descompactada daquele pacote que baixei do AUR: "Epson-L375_Series-epson-escpr-en.ppd"

E nessa hora, o gerenciador me retorna um erro assim:
"Driver faltando: A impressora EPSON-L375 requer o programa usr/lib/cups/filter/epson-escpr-wrapper, mas ele não está instalado. Por favor, instale-o antes de usar a impressora"

Já procurei por esse programa, não tenho a menor ideia de onde encontrar.
Creio que só me falta isso pro gerenciador de impressoras reconhecer a Epson L375.

Estou quase lá, e espero uma ajudinha de vocês.
Obrigado!

Última edição por MLagoa (30/09/2016 18:05:06)


Ao trocar dois pães, cada um voltará pra casa com um pão. Mas ao trocar ideias, cada um voltará pra casa com duas ideias...

Offline

#4 30/09/2016 22:42:29

MLagoa
Membro
De: Mundo Novo - MS
Registrado: 13/05/2016
Mensagens: 21

Re: [Resolvido] Multifuncional Epson Wireless

Quero agradecer a ajuda recebida nesse fórum, e quero também compartilhar minha experiência para que outras pessoas possam ser ajudadas, assim como eu fui:

1) acessei o link fornecido por Swatquest e instalei o CUPS + ghostscript:
# pacman -S cups ghostscript

2) Instalei o “yaourt” para baixar pacotes necessários que só encontrei no AUR (veja no fórum como instalar essa ferramenta):
# pacman -S yaourt

3) Acessei outro link fornecido por Swatquest (drivers da Impressora), copiei o nome do pacote,
e como usuário COMUM solicitei a instalação do pacote: “epson-inkjet-printer-escpr” pelo yaourt:
$ yaourt -S epson-inkjet-printer-escpr

4) Naveguei no site do AUR (Arch User Repository) e escolhi um pacote adequado para minha impressora: “epson-inkjet-printer-201401w” - Obs: esse pacote contém o driver de vários modelos de Impressora Epson, inclusive a L-365, que é muito parecida com a minha (tenho uma L-375):
$ yaourt -S epson-inkjet-printer-201401w

5) Instalei também a ferramenta de scanner “simple scan” (dessa vez como super-usuário):
# pacman -S simple-scan

6) Conectei a impressora com o cabo USB no Computador e liguei a impressora.

7) No computador eu acessei a ferramenta: “Menu / Sistema / Gerenciador de Impressão”  e selecionei minha impressora em “Adding Printers and Classes” (talvez solicite a senha de administrador)

E pronto! Tenho a impressora funcionando, imprimindo documentos inclusive no Libreoffice.
Tenho o Scanner funcionando também, e agora posso capturar imagens diretamente no Libreoffice.

Uma observação: precisei calibrar a captura de imagens quando usei pela primeira vez no Libreoffice.
Se eu não fizesse isto, a imagem capturada sairia apenas em preto-e-branco.
Para calibrar no Libreoffice, eu fui até:
Inserir => Multimídia => Digitalizar => Selecionar Origem... (aqui demora alguns segundos pra abrir a janela).
Dentro da caixa de diálogo, eu selecionei:
Mostrar Opções Avançadas => Scan Mode => Mode => Color (como default, vai estar “Lineart” - troque por “Color”)
Nessa caixa de diálogos você ainda pode trocar a resolução para uma qualidade melhor (vai estar em 75 DPI), etc.
Só não achei um modo de deixar essa configuração de “color” permanente. Tenho de ajustar toda vez que vou usar o scanner.

E isso é tudo! Feliz da vida com minha Multifuncional... funcionando!! (desculpem o trocadilho).

Última edição por MLagoa (30/09/2016 23:01:16)


Ao trocar dois pães, cada um voltará pra casa com um pão. Mas ao trocar ideias, cada um voltará pra casa com duas ideias...

Offline

#5 30/09/2016 22:44:25

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.376

Re: [Resolvido] Multifuncional Epson Wireless

Você tem que iniciar o serviço

systemctl enabled cups-browsed.service
systemctl start  cups-browsed.service

Caso precise ou queira iniciar o avahi
systemctl enable avahi-daemon.service
systemctl start avahi-daemon.service

Assim você vai acessar o cups

Caso tenha instalado system-config-printer

crie um grupo

groupadd lpadmin

Adicione o seu usuário no grupo

gpasswd -a lpadmin usuário


Vá no arquivo /etc/cups/cups-files.conf

Em

# Administrator user group, used to match @SYSTEM in cupsd.conf policy rules...
# This cannot contain the Group value for security reasons...
SystemGroup sys root 

Adicione o grupo lpadmin depois do grupo root

# Administrator user group, used to match @SYSTEM in cupsd.conf policy rules...
# This cannot contain the Group value for security reasons...
SystemGroup sys root lpadmin

Reicie o serviço cups
systemctl restart  cups-browsed.service

Agora o system-config-printe irá acessar o cups

Offline

#6 30/09/2016 22:52:59

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.376

Re: [Resolvido] Multifuncional Epson Wireless

Funcionou?

Offline

#7 30/09/2016 22:56:16

MLagoa
Membro
De: Mundo Novo - MS
Registrado: 13/05/2016
Mensagens: 21

Re: [Resolvido] Multifuncional Epson Wireless

Swatquest, não sei bem o que fiz, mas eu tenho o usuário comum no grupo "LP" desde a instalação do S.O. e hoje eu acrescentei o usuário no grupo "AVAHI" somente depois disso é que eu consegui abrir a página do cups no browse de internet.
O yaourt fez boa parte do serviço pra mim, porque quando eu descompactei pastas, fiz ./configure, make, make config, etc etc eu acabei me perdendo no meio da instalação, e a impressora me dava erro "faltando instalação de filtros".
Instalei as dependencias: cups, ghostscript e avahi, baixei dois pacotes no AUR (deixei o nome deles logo acima) e executei a instalação com o yaourt.
Muitíssimo obrigado pelas instruções. Creio que nunca chegaria aos pacotes sem a ajuda desse fórum. smile


Ao trocar dois pães, cada um voltará pra casa com um pão. Mas ao trocar ideias, cada um voltará pra casa com duas ideias...

Offline

#8 30/09/2016 23:09:12

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.376

Re: [Resolvido] Multifuncional Epson Wireless

blz..

Não vejo a necessidade de pertencer ao grupo LP , e nem ao AVAHI

Mas se funcionou

Última edição por swatquest (30/09/2016 23:10:01)

Offline

#9 02/10/2016 12:15:32

MLagoa
Membro
De: Mundo Novo - MS
Registrado: 13/05/2016
Mensagens: 21

Re: [Resolvido] Multifuncional Epson Wireless

Swatquest, você tem toda a razão...
A multifuncional de fato funcionou, mas apenas na primeira vez que fiz a configuração, visto que ao proceder tal configuração, habilitei o serviço de cups e system-config-print usando a senha de super-usuário.

A partir da segunda vez que liguei o PC, não consegui acessar o cups.
Então fiz o procedimento acima - que você sugeriu - e as configurações voltaram a funcionar.

Obs: somente duas pequenas modificações nas instruções que você me passou:
"systemctl enabled cups-browsed.service" = precisei digitar "enable" no lugar de "enabled".
"gpasswd -a lpadmin usuário" = alterei a ordem do comando, colocando usuário ANTES de lpadmin.

Mais uma vez, obrigado! smile


Ao trocar dois pães, cada um voltará pra casa com um pão. Mas ao trocar ideias, cada um voltará pra casa com duas ideias...

Offline

#10 07/01/2017 15:09:27

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 151

Re: [Resolvido] Multifuncional Epson Wireless

Olá,

Na Kalunga o vendedor me disse que a autonomia de impressão dela é para cerca de 4.500 folhas, alguém sabe quantas folhas imprime com cada bisnaga, pois acho que seja conversa de vendedor está 4.500 folhas.

Desde já agradeço.

Offline

Rodapé do site