Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 18/02/2017 20:45:34

yzak
Membro
De: hellcife
Registrado: 01/12/2010
Mensagens: 67
Website

[Resolvido] Erro no libvdpau depois de hibernar

Olá.

Estou encontrando este erro aqui ao tentar executar vídeos no VLC (tentei no mpv também) formatos .avi, .mkv, .mp4.

VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[00000000020fc148] core libvlc: Executando o VLC com a interface padrão. Use 'cvlc' para usar o VLC sem interface.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: Arquivo ou diretório não encontrado
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: Arquivo ou diretório não encontrado
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: Arquivo ou diretório não encontrado
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: Arquivo ou diretório não encontrado

Eu consigo rodar os vídeos tranquilamente e esse erro aparece depois que eu "acordo" o computador depois de hibernar. Reiniciando o notebook, dá certo.

Minha conf de vídeo:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
08:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 830M] (rev a2)

Eu não tenho a NVIDIA instalada, apenas uso o xf86-intel. Ah, e tenho o:

local/libvdpau 1.1.1-2
    Nvidia VDPAU library
local/libvdpau-va-gl 0.4.2-1
    VDPAU driver with OpenGL/VAAPI backend

Alguém já passou por isso? Grato!

Última edição por yzak (24/02/2017 19:52:02)


=)=

Offline

#2 18/02/2017 23:07:47

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [Resolvido] Erro no libvdpau depois de hibernar

Se você usa intel então não use vdpau, e sim vaapi

Mas precisa de algumas configurações manuais

No ~/.bash_profile

adicione
export LIBVA_DRIVER_NAME=i965
export VDPAU_DRIVER=va_gl

Mais informação
https://wiki.archlinux.org/index.php/Ha … ing_VA-API
https://wiki.archlinux.org/index.php/Ha … ring_VDPAU

Última edição por swatquest (21/02/2017 00:12:12)

Offline

#3 20/02/2017 13:16:29

yzak
Membro
De: hellcife
Registrado: 01/12/2010
Mensagens: 67
Website

Re: [Resolvido] Erro no libvdpau depois de hibernar

Opa swatquest. Mais uma vez obrigado pela ajuda.

Fiz essas alterações e, aparentemente, está funcionando depois que eu hiberno. Porém, ao usar o computador, aparecem algumas falhas (tipo interferências) na tela. Pelo que eu notei dá no chromium.

As "interferências" são assim: https://share.riseup.net/#65WDVOZVevKWdH5euUTxRQ

O interessante é que eu estava tendo problema com o chromium, chrome e spotify aqui no i3wm e depois que passei esse parâmetro:

Option      "DRI"	"false"

no 20-intel.conf, tinha ficado ok.



Vou testar sem ele pra ver se tudo funciona bem.

Última edição por yzak (20/02/2017 13:24:01)


=)=

Offline

#4 21/02/2017 00:11:58

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [Resolvido] Erro no libvdpau depois de hibernar

Fala cara..

Então...

Tente mudar o método de aceleração

Em vez de sna use uxa

Option      "AccelMethod"  "uxa"

O dri em vez de 3 use o 2

Option "DRI" "2"

Caso tenha problema de congelamento

use

Option "TearFree" "true"

Um outra opção em vez de user o drive intel use o modesetting

Alguns usuário falam que é bem melhor, mas pode encontrar bugs em alguns programas.

Por exemplo

Caso use libreoffice-fresh 5.3.0-2
Pode ter problemas na visualização na opções do programa em exibir.
No libreoffice 5.2 funciona normal.

Caso queira testar

Crie o arquivo /etc/X11/xorg.conf.d/20-modesetting.conf e apague o 20-intel.conf

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "modesetting"
    Option      "AccelMethod"    "glamor"
    Option      "DRI"            "3"
EndSection

Offline

#5 24/02/2017 19:51:33

yzak
Membro
De: hellcife
Registrado: 01/12/2010
Mensagens: 67
Website

Re: [Resolvido] Erro no libvdpau depois de hibernar

Opa swatquest obrigado mais uma vez.

Sobre os problemas que eu citei, tudo resolvido. Estou tendo outros problemas com o uso de dois monitores, mas vou testando as configurações de vídeo. Vou marcar como resolvido.

Abraços


=)=

Offline

Rodapé do site