Você não está autenticado.

#1 19/06/2016 22:18:05

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

[RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

[Resolvido]

Pessoal, sou novo no Arch, fiz ontem minha primeira instalação pra valer no PC!

O problema se refere a inicialização, onde aparece uma mensagem referente ao wi-fi, fica buscando algo por 1 minuto e meio.
Apesar de na pratica estar funcionando a Internet
Pelo que entendi preciso instalar um arquivo do wi fi ou configurar algo, mas não sei como proceder...

A mensagem:

[OK] start automatically generated profile by wifi-menu
[TIME]timed out waiting for device sys-subsystem-net-devices-interface_wifi.device.
[DEPEND] depend dependency failed for automatic wireless network connection using netctl profiles.

sudo dmesg | grep firmware
[sudo] senha para eduardo:
[   13.475698] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
[   13.483402] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.36

Última edição por eduardo.tromer (02/07/2016 21:02:16)

Offline

#2 20/06/2016 23:11:58

sistematico
Moderador
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.008
Website

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

Dá um:

systemctl list-unit-files | grep enabled 

Pra saber quais unidades estão ativas no seu sistema, depois disso dê um:

systemctl status [UNIDADE]

Pra tentar ter uma ideia de que erro está ocorrendo com a unidade.

Mais informações: https://wiki.archlinux.org/index.php/Wi … figuration

Abraço..

Offline

#3 21/06/2016 00:10:35

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

Obrigado pela resposta! seguem os dados...

[[email protected] ~]$ systemctl list-unit-files | grep enabled
org.cups.cupsd.path                        enabled 
autovt@.service                            enabled 
display-manager.service                    enabled 
getty@.service                             enabled 
lightdm.service                            enabled 
netctl-auto@.service                       enabled 
[email protected]\x2dadmin.service        enabled 
org.cups.cupsd.service                     enabled 
org.cups.cupsd.socket                      enabled 
remote-fs.target                           enabled 
[[email protected] ~]$ systemctl status wlp0s29f7u2
Failed to dump process list, ignoring: Unit wlp0s29f7u2.service not found.
● wlp0s29f7u2.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

Offline

#4 21/06/2016 10:24:36

phillipe
Moderador
De: Novo Gama - GO
Registrado: 23/03/2008
Mensagens: 1.327
Website

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

Está parecendo que esse profile não existe mais no seu sistema... Pode estar com outro nome.

Aconselho desabilitá-lo:

netctl disable wlp0s29f7u2

"NÃO HÁ NADA COMO A LIBERDADE." (Nelson Mandela)

Offline

#5 21/06/2016 12:56:38

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

Pior que parece que a Internet esta funcionando por esse profile, o comando solicitado retornou essa mensagem:

[[email protected] ~]$ sudo netctl disable wlp0s29f7u2
[sudo] senha para eduardo:
No regular unit file found for profile 'wlp0s29f7u2'

[[email protected] ~]$ iwconfig
lo        no wireless extensions.

wlp0s29f7u2  IEEE 802.11bgn  ESSID:"admin" 
          Mode:Managed  Frequency:2.452 GHz  Access Point: 70:62:B8:C0:41:BC   
          Bit Rate=30 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=41/70  Signal level=-69 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:264  Invalid misc:2167   Missed beacon:0

Offline

#6 24/06/2016 01:20:48

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.422

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

eduardo.tromer escreveu:

[[email protected] ~]$ systemctl list-unit-files | grep enabled
org.cups.cupsd.path                        enabled 
autovt@.service                            enabled 
display-manager.service                    enabled 
getty@.service                             enabled 
lightdm.service                            enabled 
netctl-auto@.service                       enabled 
[email protected]\x2dadmin.service        enabled 
org.cups.cupsd.service                     enabled 
org.cups.cupsd.socket                      enabled 
remote-fs.target                           enabled



O seu profile
[email protected]\x2dadmin.service

Seria

wlp0s29f7u2-x2dadmin

netctl disable wlp0s29f7u2-x2dadmin


Quando você executa

netctl start  wlp0s29f7u2-x2dadmin

Apresenta algum erro.

Veja aqui a configuração
https://forum.archlinux-br.org/viewtopi … 494#p30494
https://wiki.archlinux.org/index.php/Ne … WPA-PSK.29

Última edição por swatquest (24/06/2016 01:29:06)

Offline

#7 24/06/2016 18:18:05

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

[[email protected] ~]# wifi-menu
Interface 'wlp0s29f7u2' is controlled by netctl-auto
[[email protected] ~]# netctl disable wlp0s29f7u2-x2dadmin
No regular unit file found for profile 'wlp0s29f7u2-x2dadmin'
[[email protected] ~]# netctl start  wlp0s29f7u2-x2dadmin
Job for [email protected]\x2dx2dadmin.service failed because the control process exited with error code.
See "systemctl status "[email protected]\\x2dx2dadmin.service"" and "journalctl -xe" for details.

Offline

#8 24/06/2016 18:20:20

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

[[email protected] ~]# systemctl status "[email protected]\\x2dx2dadmin.service"
[email protected]\x2dx2dadmin.service - Networking for netctl profile wlp0s29
   Loaded: loaded (/usr/lib/systemd/system/netctl@.service; static; vendor prese
   Active: failed (Result: exit-code) since Sex 2016-06-24 17:17:11 BRT; 2min 26
     Docs: man:netctl.profile(5)
  Process: 1783 ExecStart=/usr/lib/network/network start %I (code=exited, status
Main PID: 1783 (code=exited, status=1/FAILURE)

Jun 24 17:17:11 localhost systemd[1]: Starting Networking for netctl profile wlp
Jun 24 17:17:11 localhost network[1783]: Profile 'wlp0s29f7u2-x2dadmin' does not
Jun 24 17:17:11 localhost systemd[1]: [email protected]\x2dx2dadmin.service: Ma
Jun 24 17:17:11 localhost systemd[1]: Failed to start Networking for netctl prof
Jun 24 17:17:11 localhost systemd[1]: [email protected]\x2dx2dadmin.service: Un
Jun 24 17:17:11 localhost systemd[1]: [email protected]\x2dx2dadmin.service: Fa
lines 1-13/13 (END)...skipping...
[email protected]\x2dx2dadmin.service - Networking for netctl profile wlp0s29f7u2-x2dadmin
   Loaded: loaded (/usr/lib/systemd/system/netctl@.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sex 2016-06-24 17:17:11 BRT; 2min 26s ago
     Docs: man:netctl.profile(5)
  Process: 1783 ExecStart=/usr/lib/network/network start %I (code=exited, status=1/FAILURE)
Main PID: 1783 (code=exited, status=1/FAILURE)

Jun 24 17:17:11 localhost systemd[1]: Starting Networking for netctl profile wlp0s29f7u2-x2dadmin...
Jun 24 17:17:11 localhost network[1783]: Profile 'wlp0s29f7u2-x2dadmin' does not exist or is not readable
Jun 24 17:17:11 localhost systemd[1]: [email protected]\x2dx2dadmin.service: Main process exited, code=exited, status=1/FAILURE
Jun 24 17:17:11 localhost systemd[1]: Failed to start Networking for netctl profile wlp0s29f7u2-x2dadmin.
Jun 24 17:17:11 localhost systemd[1]: [email protected]\x2dx2dadmin.service: Unit entered failed state.
Jun 24 17:17:11 localhost systemd[1]: [email protected]\x2dx2dadmin.service: Failed with result 'exit-code'.

Offline

#9 24/06/2016 18:21:04

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

[[email protected] ~]# journalctl -xe
Jun 24 17:16:19 localhost dhcpcd[1398]: wlp0s29f7u2: soliciting a DHCP lease
Jun 24 17:16:20 localhost dhcpcd[1398]: wlp0s29f7u2: offered 192.168.0.2 from 192.168.0.1
Jun 24 17:16:20 localhost dhcpcd[1398]: wlp0s29f7u2: probing address 192.168.0.2/24
Jun 24 17:16:25 localhost dhcpcd[1398]: wlp0s29f7u2: leased 192.168.0.2 for 7200 seconds
Jun 24 17:16:25 localhost dhcpcd[1398]: wlp0s29f7u2: adding route to 192.168.0.0/24
Jun 24 17:16:25 localhost dhcpcd[1398]: wlp0s29f7u2: adding default route via 192.168.0.1
Jun 24 17:16:25 localhost dhcpcd[1398]: forked to background, child pid 1483
Jun 24 17:16:57 localhost systemd[1]: Reloading.
Jun 24 17:16:58 localhost systemd[1]: Reloading.
Jun 24 17:17:11 localhost systemd[1]: Created slice system-netctl.slice.
-- Subject: Unidade system-netctl.slice concluiu a inicialização
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/li … temd-devel
--
-- A unidade system-netctl.slice concluiu a inicialização.
--
-- The start-up result is done.
Jun 24 17:17:11 localhost systemd[1]: Starting Networking for netctl profile wlp0s29f7u2-x2dadmin...
-- Subject: Unidade [email protected]\x2dx2dadmin.service sendo iniciado
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/li … temd-devel
--
-- A unidade [email protected]\x2dx2dadmin.service está sendo iniciada.
Jun 24 17:17:11 localhost network[1783]: Profile 'wlp0s29f7u2-x2dadmin' does not exist or is not readable
Jun 24 17:17:11 localhost systemd[1]: [email protected]\x2dx2dadmin.service: Main process exited, code=exited, status=1/FAILURE
Jun 24 17:17:11 localhost systemd[1]: Failed to start Networking for netctl profile wlp0s29f7u2-x2dadmin.
-- Subject: A unidade [email protected]\x2dx2dadmin.service falhou
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/li … temd-devel
--
-- A unidade [email protected]\x2dx2dadmin.service falhou.
--
-- O resultado é failed.
Jun 24 17:17:11 localhost systemd[1]: [email protected]\x2dx2dadmin.service: Unit entered failed state.
Jun 24 17:17:11 localhost systemd[1]: [email protected]\x2dx2dadmin.service: Failed with result 'exit-code'.

Offline

#10 25/06/2016 00:40:02

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.422

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

Qual a saída do comando

netctl list

Como está configurado o seu profile
/etc/netctl/wireless-wpa

POr enquanto desabilite manualmente

netctl-auto@.service                       enabled
[email protected]\x2dadmin.service        enabled 

systemctl stop netctl-auto@.service [email protected]\x2dadmin.service
systemctl disable netctl-auto@.service [email protected]\x2dadmin.service

Tente habilitar o netctl-auto@.service   como [email protected]

systemctl start [email protected]

Veja o nome do perfil em  netctl list

e tente habilitá-lo

netctl enable wlp0s29f7u2-teste

Última edição por swatquest (25/06/2016 01:00:21)

Offline

#11 27/06/2016 21:19:54

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

[[email protected] ~]$ netctl list
  wlp0s29f7u2-admin

[[email protected] ~]$ cd /etc/netctl/
examples/          hooks/             interfaces/        wlp0s29f7u2-admin



[[email protected] ~]$ cd /etc/netctl/

[[email protected] netctl]$ sudo cat wlp0s29f7u2-admin
[sudo] senha para eduardo:
Description='Automatically generated profile by wifi-menu'
Interface=wlp0s29f7u2
Connection=wireless
Security=wpa
ESSID=admin
IP=dhcp
Key=*****

Offline

#12 27/06/2016 21:23:57

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

[[email protected] netctl]$ su -
Senha:
[[email protected] ~]# netctl-auto@.service enabled
-bash: netctl-auto@.service: comando não encontrado
[[email protected] ~]# systemctl disable [email protected]
Removed [email protected]u2.service.
[[email protected] ~]# [email protected]\x2dadmin.service disable
-bash: [email protected]: comando não encontrado
[[email protected] ~]# systemctl stop netctl-auto@.service [email protected]\x2dadmin.service
Failed to stop netctl-auto@.service: Unit name netctl-auto@.service is missing the instance name.
See system logs and 'systemctl status netctl-auto@.service' for details.
Failed to get load state of netctl-auto@.service: Unit name netctl-auto@.service is missing the instance name.
[[email protected] ~]# systemctl disable netctl-auto@.service [email protected]\x2dadmin.service
Removed [email protected]_wifi.service.
[[email protected] ~]# [email protected]
-bash: [email protected]: comando não encontrado
[[email protected] ~]# systemctl start [email protected]
[[email protected] ~]# netctl enable wlp0s29f7u2-admin
ln -s '[email protected]\x2dadmin.service' '[email protected]\x2dadmin.service'

Offline

#13 27/06/2016 21:32:23

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

swatquest Agora deu tudo certo! o sistema iniciou direto sem aguardar 1 minuto e meio! Resolvido!
Só gostaria de entender melhor o que aconteceu! e como eu devo proceder caso um dia precise reinstalar o sistema novamente pra não cair no mesmo erro.
Eu não sei em qual parte da configuração eu errei (acho que fiz algo de errado depois de conectar o wi-fi menu e usar o comando systemctl enable [email protected] pro wifi conectar automaticamente)... Entendi, que deu problema com esses nomes de profiles...

Offline

#14 27/06/2016 23:54:31

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.422

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

Para você saber os profiles

netctl list

Você habilitou errado o netctl.
O profile que você habilitou foi wlp0s29f7u2-x2dadmin e não o wlp0s29f7u2-admin
Este comando faz o trabalho
https://wiki.archlinux.org/index.php/Ne … WPA-PSK.29
netctl start wireless-wpa

Mas pode ter ocorrido alguma coisa

Então você habilitou direto no perfil
netctl enable wlp0s29f7u2-admin
netctl start wlp0s29f7u2-admin

O systemctl start [email protected] não precisa e acho que não funciona.

Para verificar
systemctl status [email protected]

Desatibilite e veja se funciona
systemctl stop [email protected]
systemctl disable [email protected]

Última edição por swatquest (27/06/2016 23:54:54)

Offline

#15 28/06/2016 02:29:45

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

(deixa ver se eu entendi smile rs)

1- Então esse comando netctl start wireless-wpa deixara o wifi automatico independente do nome que eu tiver no profile? se sim é mais prudente do que habilitar direto no profile como eu fiz usando o  netctl enable wlp0s29f7u2-admin?

2-Valeria a pena desabilitar o netctl e usar um networkmanager ou melhor deixar como está?

Última edição por eduardo.tromer (28/06/2016 18:51:39)

Offline

#16 29/06/2016 00:27:51

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.422

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

1-
O comando  netctl start wireless-wpa lê o arquivo /etc/netctl/wireless-wpa, detecta o perfil e cria os serviços.
Por exemplo

/etc/netctl/wireless-wpa

Description='A simple WPA encrypted wireless connection using 256-bit PSK'
Interface=wlp2s2
Connection=wireless
Security=wpa
IP=dhcp
ESSID=teste
Key=\"64cf3ced850ecef39197bb7b7b301fc39437a6aa6c6a599d0534b16af578e04a

Interface=wlp2s2
ESSID=teste
o perfil seria wlp2s2-teste

Assim ele cria o perfil e conecta
Não sei se você conectar direto funciona sem executar  o comando netctl start wireless-wpa
O que a gente fez foi conectar um perfil já existente
Visto pelo comando

[[email protected] ~]$ cd /etc/netctl/
examples/          hooks/             interfaces/        wlp0s29f7u2-admin

2- Depende .
Acho o networkmanager e Wicd são mais práticos no uso do dia a dia. Facil visualização para ver se a rede está conectada ou não. Você habilita, desabilita e edita com alguns cliques.Mas são mais pesados..., depende do computador.
Por exemplo:
Eu uso o networkmanager e o tempo de carregamengo visto com o comando systemd-analyze

systemd-analyze blame
   53ms NetworkManager.service

Com o netctl é necessário editar o perfil e reiniciar ou iniciar o serviço.
sudo nano  /etc/netctl/wlp0s29f7u2-admin
e depois 
systemctl restart [email protected]\x2dadmin.service

para ver o status

systemctl status [email protected]\x2dadmin.service

Offline

#17 29/06/2016 02:30:36

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

Muito obrigado swatquest, e a todos os membros que me ajudaram! Obrigado pelas dicas também!

Offline

#18 02/07/2016 18:27:27

sistematico
Moderador
De: Campo Grande / MS
Registrado: 13/06/2008
Mensagens: 1.008
Website

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

Se resolveu, coloque [RESOLVIDO] antes do título do tópico.

Offline

#19 02/07/2016 21:03:03

eduardo.tromer
Membro
Registrado: 19/06/2016
Mensagens: 32

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

Feito! Muito obrigado!

sistematico escreveu:

Se resolveu, coloque [RESOLVIDO] antes do título do tópico.

Offline

#20 11/04/2017 23:05:31

nandumoura
Membro
Registrado: 09/04/2017
Mensagens: 7

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

nao entendi como foi resolvido estou com o mesmo problema

Offline

#21 12/04/2017 00:11:16

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.422

Re: [RESOLVIDO] Sistema demora pra iniciar devido ao Wi-Fi.

veja aqui
Para você saber os profiles
netctl list
Você habilitou errado o netctl.
O profile que você habilitou foi wlp0s29f7u2-x2dadmin e não o wlp0s29f7u2-admin
Este comando faz o trabalho
https://wiki.archlinux.org/index.php/Ne … WPA-PSK.29
netctl start wireless-wpa
Mas pode ter ocorrido alguma coisa
Então você habilitou direto no perfil
netctl enable wlp0s29f7u2-admin
netctl start wlp0s29f7u2-admin
O systemctl start [email protected] não precisa e acho que não funciona.
Para verificar
systemctl status [email protected]
Desatibilite e veja se funciona
systemctl stop [email protected]
systemctl disable [email protected]

Offline

Rodapé do site