Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 16/08/2017 18:15:56

LuizAlexandreLins
Membro
Registrado: 25/05/2017
Mensagens: 20

Nâo consigo instalar o pacote Yaourt[Resolvido]

Ola Amigo,

Quando tento instalar o pacote yaourt dá o seguinte erro:

[[email protected] ~]$ sudo pacman -S yaourt
[sudo] senha para luizlin13:
atenção: arquivo de configuração /etc/pacman.conf, linha 103: diretiva "SigLever" na seção "archlinuxfr" não foi reconhecida.
resolvendo dependências...
procurando por pacotes conflitantes...

Pacotes (3) package-query-1.9-1  yajl-2.1.0-1  yaourt-1.9-1

Tamanho total instalado:  1,06 MiB

:: Continuar a instalação? [S/n]
(3/3) verificando chaves no chaveiro                 [############################] 100%
(3/3) verificando integridade do pacote              [############################] 100%
erro: package-query: faltando assinatura exigida
erro: yaourt: faltando assinatura exigida
erro: falha em submeter a transação (pacote sem a assinatura exigida)
Ocorreram erros e, portanto, nenhum pacote foi atualizado.

E como se ver acima, também estou observando que "archlinuxfr" não foi reconhecida.

atenção: arquivo de configuração /etc/pacman.conf, linha 103: diretiva "SigLever" na seção "archlinuxfr" não foi reconhecida.

Agradeço Atenciosamente,

Luiz Alexandre

Última edição por LuizAlexandreLins (23/08/2017 10:45:51)

Offline

#2 17/08/2017 01:03:35

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: Nâo consigo instalar o pacote Yaourt[Resolvido]

Oi luiz,
  Como está o arquivo /etc/pacman.conf?

Você pode instalar manualmente.
Para isso faça o download do snapshot

O yaourt tem um dependência package-query

Procedimento

Cria uma pasta na home, por exemplo, AUR

mkdir -p ~/AUR

Baixe os arquivos para dentro desta pasta AUR

Downloads:
yaourt: https://aur.archlinux.org/cgit/aur.git/ … urt.tar.gz
package-query: https://aur.archlinux.org/cgit/aur.git/ … ery.tar.gz

Extraia os arquivos

Instale o package-query antes do yaourt
Entre na pasta package-query e execute o comando

makepkg -sci

Depois entra na pasta yaourt e execute

makepkg -sci

Pronto. Yaourt instalado

Última edição por swatquest (17/08/2017 01:06:42)

Offline

#3 19/08/2017 22:40:23

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: Nâo consigo instalar o pacote Yaourt[Resolvido]

A própria mensagem de erro está te informando o erro. O certo é SigLevel e não Siglever como está acusando o erro.

Caso tenha maiores dúvidas basta verificar aqui https://wiki.archlinux.fr/Depot_archlinuxfr

Abraços

LuizAlexandreLins escreveu:

Ola Amigo,

Quando tento instalar o pacote yaourt dá o seguinte erro:

[[email protected] ~]$ sudo pacman -S yaourt
[sudo] senha para luizlin13:
atenção: arquivo de configuração /etc/pacman.conf, linha 103: diretiva "SigLever" na seção "archlinuxfr" não foi reconhecida.
resolvendo dependências...
procurando por pacotes conflitantes...

Pacotes (3) package-query-1.9-1  yajl-2.1.0-1  yaourt-1.9-1

Tamanho total instalado:  1,06 MiB

:: Continuar a instalação? [S/n]
(3/3) verificando chaves no chaveiro                 [############################] 100%
(3/3) verificando integridade do pacote              [############################] 100%
erro: package-query: faltando assinatura exigida
erro: yaourt: faltando assinatura exigida
erro: falha em submeter a transação (pacote sem a assinatura exigida)
Ocorreram erros e, portanto, nenhum pacote foi atualizado.

E como se ver acima, também estou observando que "archlinuxfr" não foi reconhecida.

atenção: arquivo de configuração /etc/pacman.conf, linha 103: diretiva "SigLever" na seção "archlinuxfr" não foi reconhecida.

Agradeço Atenciosamente,

Luiz Alexandre


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

#4 22/08/2017 21:10:39

LuizAlexandreLins
Membro
Registrado: 25/05/2017
Mensagens: 20

Re: Nâo consigo instalar o pacote Yaourt[Resolvido]

Ola Swatquest,

Em primeiro lugar agradeço pela a grande ajuda que você e o Administrador denominado corvolino tem me dado uma assistência imensa.

Em relação ao erro acusado no archlinuxfr, eu já consegui resolver com a informação dada através do Administrador. Apenas tinha um erro de ortografia no nome SigLever, na qual eu modifiquei para Siglevel, no arquivo /etc/pacman.conf, que estava acusando na linha 103.   

Agora, em relação ao Yaourt , eu já criei a pasta e baixei os dois arquivos.

Mas ainda tem uma pendências que eu gostaria de mencionar

Como eu faço para extrair os dois arquivos pois não tem esta opção no Dolphin.

Agradeço Atenciosamente,

Luiz

Offline

#5 22/08/2017 23:08:47

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.861

Re: Nâo consigo instalar o pacote Yaourt[Resolvido]

sobre o yaourt se funcionou pode instalar pelo pacman

pacman -S yaourt

KDE não conheço. Não sei qual o programa para esta tarefa, mas acho que é o ark

pacman -S ark

para descomprimir por linha de comando

pode usar o tar

tar xvzf yaourt.tar.gz

Última edição por swatquest (23/08/2017 12:45:58)

Offline

Rodapé do site