Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 13/10/2017 14:10:43

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

[resolvido] Não consigo mais atualizar meu Arch

Olá, estou tendo problema para atualizar meu arch, ele da a seguinte erro;

:: Sincronizando a base de dados de pacotes...
core                         124,6 KiB   213K/s 00:01 [############################] 100%
extra                       1660,5 KiB   164K/s 00:10 [############################] 100%
community                      4,1 MiB   379K/s 00:11 [############################] 100%
multilib                     173,3 KiB   452K/s 00:00 [############################] 100%
archlinuxfr está atualizado
:: Iniciando atualização completa do sistema...
:: Substituir flatpak por extra/flatpak-builder? [S/n] S
:: Substituir ttf-overpass por community/otf-overpass? [S/n] S
resolvendo dependências...
procurando por pacotes conflitantes...
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: gstreamer0.10-good-plugins: instalando libsoup (2.60.1-1) dependências 'libsoup-gnome'

ja procurei por este libsoup-gnome mas não acha, não sei como resolver este problema, para poder voltar atualizar meu arch.

desde já agradeço a atenção de todos.

Última edição por riesdra (17/10/2017 16:20:26)

Offline

#2 13/10/2017 21:31:37

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [resolvido] Não consigo mais atualizar meu Arch

Offline

#3 13/10/2017 22:08:43

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: [resolvido] Não consigo mais atualizar meu Arch

deu este erro peloo yaourt

==> Compilando e instalando pacote
==> Instalar ou compilar dependências que faltam para libsoup-gnome:
resolvendo dependências...
procurando por pacotes conflitantes...
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: imagemagick: instalando perl (5.26.1-1) dependências 'perl<5.25'
==> Reiniciar a compilação de libsoup-gnome ? [s/N]

Offline

#4 13/10/2017 22:38:27

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [resolvido] Não consigo mais atualizar meu Arch

instale só o perl e veja se o erro persiste

pacman -S perl

teria que saber que dependência é essa no qual determina que o perl<5.25

o pkgbuild do libsoup-gnome não informa isso

tente atualizar ignorando os pacotes que dão erro

--ignore <package>
           Directs pacman to ignore upgrades of package even if there is one
           available. Multiple packages can be specified by separating them
           with a comma.

       --ignoregroup <group>
           Directs pacman to ignore upgrades of all packages in group, even if
           there is one available. Multiple groups can be specified by
           separating them with a comma.


pacman -Syu --ignore pacotes

Offline

#5 14/10/2017 09:06:43

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: [resolvido] Não consigo mais atualizar meu Arch

tentando instalar o perl, deu o mesmo erro do <5.25

ignorando o libsoup esta indo, mas deu que precisa baixar 1294 mb, vou esperar para ver como vai ser

obrigado por enquanto.

________________________________________
deu este erro

(631/631) verificando chaves no chaveiro                                                   [####################################################] 100%
(631/631) verificando integridade do pacote                                                [####################################################] 100%
erro: alsa-lib: signature from "Anatol Pomozov <[email protected]>" is unknown trust
:: Arquivo /var/cache/pacman/pkg/alsa-lib-1.1.4.1-2-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] n
erro: apr: signature from "Anatol Pomozov <[email protected]>" is unknown trust
:: Arquivo /var/cache/pacman/pkg/apr-1.6.2-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] n
erro: apr-util: signature from "Anatol Pomozov <[email protected]>" is unknown trust
:: Arquivo /var/cache/pacman/pkg/apr-util-1.6.0-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] n
erro: fuse-common: signature from "Anatol Pomozov <[email protected]>" is unknown trust
:: Arquivo /var/cache/pacman/pkg/fuse-common-3.2.0-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] n
erro: fuse2: signature from "Anatol Pomozov <[email protected]>" is unknown trust
:: Arquivo /var/cache/pacman/pkg/fuse2-2.9.7-4-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] n
erro: ethtool: signature from "Anatol Pomozov <[email protected]>" is unknown trust
:: Arquivo /var/cache/pacman/pkg/ethtool-1:4.11-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] n
erro: lua: signature from "Anatol Pomozov <[email protected]>" is unknown trust
:: Arquivo /var/cache/pacman/pkg/lua-5.3.4-2-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] n
erro: talloc: signature from "Anatol Pomozov <[email protected]>" is unknown trust
:: Arquivo /var/cache/pacman/pkg/talloc-2.1.10-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] n
erro: falha em submeter a transação (pacote inválido ou corrompido)
Ocorreram erros e, portanto, nenhum pacote foi atualizado.

Última edição por riesdra (14/10/2017 11:22:37)

Offline

#6 15/10/2017 19:50:23

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [resolvido] Não consigo mais atualizar meu Arch

você viu isso
https://www.archlinux-br.org/noticias/258/

execute
pacman -Qqo '/usr/lib/perl5/vendor_perl'`


e veja se tem algum pacote que precisa ser recompilado

Última edição por swatquest (15/10/2017 20:01:49)

Offline

#7 15/10/2017 19:57:21

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: [resolvido] Não consigo mais atualizar meu Arch

Estou fora agora, depois faço o teste.

__________________________________________
este é o resultado
sudo pacman -Qqo '/usr/lib/perl5/vendor_perl'
[sudo] senha para ricardo:
graphviz
imagemagick
libproxy
subversion
xfconf

Última edição por riesdra (15/10/2017 20:43:07)

Offline

#8 15/10/2017 21:09:33

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [resolvido] Não consigo mais atualizar meu Arch

você terá que recompilar estes pacotes.

Tanto pacotes do aur quanto dos repositórios

Para pacotes de repositórios não sei se reinstalar já soluciona o caso..

você terá que testar.

para recompilar você pode usar o asp para os repositórios e para aur é só reinstlar novamente os pacotes.

feito isso execute o comando novamente.

e depois tente atualizar.

para utilizar o asp

crie um  pasta
por exemplo asp

dentro dela execute

asp export imagemagick

entre na pasta imagemagick

makepkg -sci

Offline

#9 15/10/2017 21:11:39

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: [resolvido] Não consigo mais atualizar meu Arch

eu fiz a reinstalação e agora ao rodar o comando anterior ocorre isto

pacman -Qqo '/usr/lib/perl5/vendor_perl'
erro: falha na leitura o arquivo "/usr/lib/perl5/vendor_perl": Arquivo ou diretório não encontrado

Offline

#10 15/10/2017 21:13:42

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [resolvido] Não consigo mais atualizar meu Arch

blz..

não tem mais problemas com os aplicativos..

está tudo ok

tente atualizar

Offline

#11 15/10/2017 21:25:51

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: [resolvido] Não consigo mais atualizar meu Arch

faz todo o processo, e deu aquele mesmo erro de ontem do PGP.

Offline

#12 15/10/2017 21:42:12

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [resolvido] Não consigo mais atualizar meu Arch

pacman-key --populate archlinux
pacman-key --refresh-keys

e veja se funciona

ou

tente reinstalar
archlinux-keyring

pacman -S  archlinux-keyring

e veja se funciona

ou

https://www.archlinux.org/master-keys/

Anatol Pomozov     0x753E0F1F     Yes    Yes    Yes    Yes    No    No

pacman-key --lsign-key 753E0F1F
pacman-key -r 753E0F1F

ou

pacman-key --list-sigs Anatol

veja a chave do anatol

pacman-key -d chave

e
pacman-key --lsign-key 753E0F1F
pacman-key -r 753E0F1F

Última edição por swatquest (15/10/2017 21:45:10)

Offline

#13 15/10/2017 22:20:12

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: [resolvido] Não consigo mais atualizar meu Arch

depois destes comandos ficou dando dois erros de chave agora

(625/625) verificando chaves no chaveiro               [############################] 100%
(625/625) verificando integridade do pacote            [############################] 100%
erro: hdf5: signature from "Bruno Pagani <[email protected]>" is marginal trust
:: Arquivo /var/cache/pacman/pkg/hdf5-1.10.1-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] S
erro: netcdf: signature from "Bruno Pagani <[email protected]>" is marginal trust
:: Arquivo /var/cache/pacman/pkg/netcdf-4.4.1.1-1-x86_64.pkg.tar.xz está corrompido (pacote inválido ou corrompido (assinatura PGP)).
Deseja apagá-lo? [S/n] S
erro: falha em submeter a transação (pacote inválido ou corrompido)
Ocorreram erros e, portanto, nenhum pacote foi atualizado.
[[email protected] ~]$

Offline

#14 15/10/2017 22:30:25

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.951

Re: [resolvido] Não consigo mais atualizar meu Arch

pacman-key --refresh-keys

e

https://www.archlinux.org/master-keys/
Bruno Pagani     0xDAAF9129     Yes    Yes    No    Yes    Yes    No

pacman-key --lsign-key DAAF9129
pacman-key -r DAAF9129

ou

pacman-key --list-sigs "Bruno Pagani"


veja a chave do bruno
a

pacman-key -d chave
ou caso não funcione
pacman-key -d DAAF9129

e
pacman-key --lsign-key DAAF9129
pacman-key -r DAAF9129


uma outra solução se continar o erro com outra chave

resetar todas as chaves

remove a pasta /etc/pacman.d/gnupg
e depois execute
pacman-key --init
pacman-key --populate archlinux
pacman-key --refresh-keys

Última edição por swatquest (15/10/2017 23:04:47)

Offline

#15 15/10/2017 22:54:32

riesdra
Membro
De: Assaí - Pr
Registrado: 29/06/2008
Mensagens: 167

Re: [resolvido] Não consigo mais atualizar meu Arch

agora foi, atualizou usando a função --ignore e depois baixei o libsoup-gnome com o yaourt,
muito obrigado.

Offline

Rodapé do site