Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via [email protected]

Para mais informações: [email protected]

#1 27/10/2017 17:30:46

Strangiato
Membro
Registrado: 27/10/2017
Mensagens: 11

[Resolvido] Internet cabeada lenta quando inicio o Arch

Minha placa de rede:
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

O problema ocorre qdo o pc tá ligado direto no modem ou no roteador (tp-link 740n).
É resolvido qdo desligo e ligo o roteador de novo, mas volta qdo o sistema é reiniciado.
Tenho dual boot com o win 7 e nele esse problema não ocorre.

O que tentei pra resolver o problema:
Testei o pc ligado direto no modem com outro cabo de rede.
Troquei o driver padrão r8169 pelo r8168 disponível nos repositórios oficiais.
Testei diferentes kernels (default, lts, zen).

Quando executo o comando
ethtool enp4s0
o parâmetro "Duplex" está em "Half" quando o correto é "Full".
Tentei forçar "Full" com o comando
ethtool -s enp4s0 autoneg off speed 100 duplex full
Funciona, mas de novo o problema volta ao reiniciar.

Alguma ideia do q fazer pra arrumar isso?

Última edição por Strangiato (28/10/2017 00:56:22)

Offline

#2 27/10/2017 22:05:41

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.643

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

sua placa é GA-990FXA-UD3

pode tentar fazer este procedimento
https://wiki.archlinux.org/index.php/Ne … 168.2F8411

Adicione o parâmetro iommu=soft  na linha do kernel no grub.

vá no arquivo /etc/default/grub

na linha GRUB_CMDLINE_LINUX_DEFAULT="quiet" adicione iommu=soft

GRUB_CMDLINE_LINUX_DEFAULT="quiet  iommu=soft"

depois execute o comando grub-mkconfig

grub-mkconfig -o /boot/grub/grub.cfg

Offline

#3 27/10/2017 22:24:21

Strangiato
Membro
Registrado: 27/10/2017
Mensagens: 11

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

Muito obrigado por responder, swatquest.

Eu já tinha visto essa dica na wiki, mas não tinha tentado pq a minha placa mãe é outra.
Experimentei agora como vc indicou, mas continua do mesmo jeito.

Offline

#4 27/10/2017 22:39:20

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.643

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

ok..

tenta este outro procedmento

https://wiki.archlinux.org/index.php/Ne … 11.2F8168B

baixe o  r8168

pacman -S  r8168

E se o r8168 não rodar automaticamente

coloque em blacklist o r8169

crie o /etc/modprobe.d/network.conf

e adicione

# não carregar o módulo 'r8169' no boot.
blacklist r8169

uma outra opção é desativar o ipv6

https://wiki.archlinux.org/index.php/IPv6#Disable_IPv6

Última edição por swatquest (27/10/2017 22:46:59)

Offline

#5 27/10/2017 22:59:35

Strangiato
Membro
Registrado: 27/10/2017
Mensagens: 11

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

Muito obrigado mais uma vez.

Como citei no início do tópico, o driver r8168 já foi testado.
Desativei o ipv6 usando o parâmetro "ipv6.disable_ipv6=1", mas também não deu certo.

Offline

#6 27/10/2017 23:34:51

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.643

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

como está seu /etc/hostname
e o /etc/hosts



vocÊ pode colocar no /etc/profile.d

na pasta cria o network.sh

ethtool -s enp4s0 autoneg off speed 100 duplex full

uma outra sugestào é usar networkmanager

nele você pode definir a negociação de link

Offline

#7 27/10/2017 23:41:30

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.643

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

ou usa o r8168

cria um arquivo  /etc/modprobe.d/r8168.conf

e adiciona

options r8168 speed=100 duplex=1 autoneg=1

Offline

#8 28/10/2017 00:15:40

Strangiato
Membro
Registrado: 27/10/2017
Mensagens: 11

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

no arquivo etc/hostname tenho só o nome do computador.
O /etc/hosts está assim
#
# /etc/hosts: static lookup table for host names
#

#<ip-address>    <hostname.domain.org>    <hostname>
127.0.0.1    localhost.localdomain    localhost
::1        localhost.localdomain    localhost
127.0.0.1       Arch-pc.localdomain     Arch-pc
# End of file

A dica do arquivo network.sh não funcionou também.

Troquei de novo pro driver r8168, não funcionou mesmo com o arquivo /etc/modprobe.d/r8168.conf
e a internet ficou um pouco mais lenta.


Eu já uso o networkmanager, me diga como configurar a negociação com ele.
Numa pesquisa rápida aqui não achei nada.

Offline

#9 28/10/2017 00:23:45

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.643

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

ok..

se o hostname for Arch-pc

/etc/hosts mude para

#<ip-address>    <hostname.domain.org>    <hostname>
127.0.0.1    localhost.localdomain    localhost      Arch-pc
::1        localhost.localdomain    localhost          Arch-pc
127.0.0.1       Arch-pc.localdomain     Arch-pc
# End of file

e veja se funciona

------------------------------------------------------------


Sobre networkmanager

vai conexões de rede
e depois na aba  Ethernet

negociação de link

mude para manual

e modifique

Última edição por swatquest (28/10/2017 00:26:22)

Offline

#10 28/10/2017 00:31:08

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.643

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

se usar gnome, cinnamon xfce

clique com botão direito do mouse e escolha editar a conexão do networkmanager caso não funcione a mudança no arquivo /etc/hosts

Offline

#11 28/10/2017 00:45:06

Strangiato
Membro
Registrado: 27/10/2017
Mensagens: 11

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

A alteração no arquivo hosts não surtiu efeito.
Eu estava no Gnome, mas tenho o KDE Plasma também.
Como não tem nenhuma aba "Ethernet" nas configurações do Gnome, entrei no KDE Plasma.
No painel de configurações dele entrei em "Conexões".
Na aba "Com fio" da conexão, não sei por qual motivo estava selecionado "Metade" no item "Duplex".
Alterei pra "Completo", reiniciei e agora a internet está normal. \o/
Acho que alguma das atualizações recentes do KDE Plasma alterou isso, já que eu não mexi.

Enfim, problema resolvido! E muuuuuito obrigado!
Eu já estava pensado que ia ter que trocar de distro kkkkk.

Última edição por Strangiato (28/10/2017 01:01:43)

Offline

#12 28/10/2017 00:51:38

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.643

Re: [Resolvido] Internet cabeada lenta quando inicio o Arch

blz..

gnome deve ter também como editar, mas não sei o caminho


se puder coloque a tag [resolvido] no título do tópico

Última edição por swatquest (28/10/2017 00:52:21)

Offline

Rodapé do site