Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via [email protected]

Para mais informações: [email protected]

#1 04/01/2018 16:23:10

gamma
Membro
Registrado: 10/12/2017
Mensagens: 28

erro de versao o automake

==> Iniciando build()...

You must have automake 1.7.x installed to compile .
Install the appropriate package for your distribution,
or get the source tarball at http://ftp.gnu.org/gnu/automake/
==> ERRO: Uma falha ocorreu em build().
    Abortando...
:: falha ao construir pacote(s) gtk-engine-murrine-git

[[email protected]~]$ automake --version
automake (GNU automake) 1.15.1
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl-2.0.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Tom Tromey <[email protected]>
       and Alexandre Duret-Lutz <[email protected]>.
[[email protected] ~]$


essa eu nao entendi, alguem saberia me  explicar esse erro pfv?

Última edição por gamma (04/01/2018 16:23:43)

Offline

#2 04/01/2018 20:22:07

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.816

Re: erro de versao o automake

Offline

#3 05/01/2018 00:32:11

gamma
Membro
Registrado: 10/12/2017
Mensagens: 28

Re: erro de versao o automake

Não posso, o do repositorio é só x86_64, meu note é i686,
não entendi pq ele pediu 1.7 e não reconheceu meu automake versão 1.15

Offline

#4 05/01/2018 16:08:02

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.816

Re: erro de versao o automake

Parece que o pacote está abandonado

Contudo um usuário mandou os arquivos atualizados no comentários

https://aur.archlinux.org/packages/gtk- … rrine-git/

artemh commented on 2016-02-03 20:51

Updated for automake-1.15:

newer-automakes.patch: http://pastebin.com/psX9Q0jd
PKGBUILD: http://pastebin.com/CYx0c4Ku

baixe os pacotes para uma pasta, por exemplo, gtk-engine-murrine

mkdir -p gtk-engine-murrine

acesse a pasta

cd gtk-engine-murrine

baixe os arquivos para esta pasta

e execute

makepkg -sci

Offline

#5 05/01/2018 21:54:26

gamma
Membro
Registrado: 10/12/2017
Mensagens: 28

Re: erro de versao o automake

=> Iniciando build()...

You must have automake 1.7.x installed to compile .
Install the appropriate package for your distribution,
or get the source tarball at http://ftp.gnu.org/gnu/automake/
==> ERRO: Uma falha ocorreu em build().
    Abortando...
[[email protected] gtk-engine-murrine-git]$

mesmo erro, mano,
náo sei pq ele ta me pedindo o automake 1.7 se eu tenho o 1.15, náo vou fazer downgrade só por causa disso

Última edição por gamma (05/01/2018 22:00:04)

Offline

#6 05/01/2018 23:01:07

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.816

Re: erro de versao o automake

acabei de testar aqui e funcionou

newer-automakes.patch: http://pastebin.com/psX9Q0jd
PKGBUILD: http://pastebin.com/CYx0c4Ku

acesse e clique em download

Alguns procedimentos

ao salvar na pasta salve com os nomes

newer-automakes.patch
PKGBUILD

execute

updpkgsums

e depois makepkg -sci

Última edição por swatquest (05/01/2018 23:04:10)

Offline

#7 07/01/2018 16:06:09

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.816

Re: erro de versao o automake

funcionou?

Offline

Rodapé do site