Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via [email protected]

Para mais informações: [email protected]

#1 17/02/2018 10:23:55

vbarros
Membro
Registrado: 26/10/2016
Mensagens: 31

Sites do BB e CEF não são mais acessados

Amigos, para atualizar o Arch, há quatro dias mais ou menos, foi necessário remover o pacote "fonstproto" requerido pelo módulo de segurança do BB e da Caixa. no lugar foi instalado o "xorgproto". A partir não estou mais conseguindo acessar as instituições financeira supracitadas. Agradeço orientação.

Offline

#2 17/02/2018 23:01:51

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.819

Re: Sites do BB e CEF não são mais acessados

acho que você instalou este
https://aur.archlinux.org/packages/warsaw/

Não sei a solução.

Espere ou adicone á o erro para ver se encontra a solução

Offline

#3 18/02/2018 06:10:57

vbarros
Membro
Registrado: 26/10/2016
Mensagens: 31

Re: Sites do BB e CEF não são mais acessados

Instalei simplesmente com o comando "yaourt warsaw"

Offline

#4 18/02/2018 12:42:06

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.819

Re: Sites do BB e CEF não são mais acessados

vc viu isso

esauvisky commented on 2018-02-15 13:59

Pessoal, para evitar que esta porcaria reescreva as bibliotecas, é só definir o diretório do warsaw como append-only.

Retirado do passo-a-passo que eu postei anteriormente:

3: Defina o atributo do diretório /usr/lib/warsaw como append-only:

# chattr +a /usr/lib/warsaw/

gabrielmagno commented on 2018-02-15 13:53

@xyko, sua solução funcionou perfeitamente depois de algumas tentativas.

Percebi que o daemon do warsaw (não sei qual processo exatamente) reescreve os arquivos de biblioteca dentro de /usr/local/lib/warsaw depois de um tempo.

O que eu fiz foi logar no meu banco rapidinho, antes que o daemon desfizesse os links criados manualmente. Muito desagradável esse tal de warsaw.
gerson commented on 2018-02-09 20:18

@xyko, não precisei remover e relinkar estas bibliotecas...

Instalei o warsaw, rodei o systemctl para ativar e iniciar o serviço e executei manualmente o /usr/local/bin/warsaw/core.

Funcionando.
macielr commented on 2018-02-06 01:00

xyko, perfeito! funfou redondinho!

Valeu e grande abraço,
xyko commented on 2018-02-02 12:05

Quando o /usr é montado read-only o warsaw não funciona. Para resolver o problema eu tive que mover e lincar o /usr/lib/warsaw para /var/lib/warsaw:

sudo mount -oremount,rw /usr
sudo mkdir -p /var/lib/warsaw
sudo mv /usr/lib/warsaw/* /var/lib/warsaw
sudo rm -rf /usr/lib/warsaw
sudo ln -s /var/lib/warsaw /usr/lib/warsaw

@rafaelff, sugiro que o pkgbuild seja alterado para refletir essa alteração.

Por questão de completude, para os usuários que estão apenas tentando usar, seguem os outros passos (apenas pessoa física):

cd /usr/local/lib/warsaw
sudo bash -c "rm ld-linux-x86-64.so.2; ln -s /usr/lib/ld-linux-x86-64.so.2 .
rm libc.so.6; ln -s /usr/lib/libc.so.6 .
rm libpthread.so.0; ln -s /usr/lib/libpthread.so.0 .
rm libdl.so.2; ln -s /usr/lib/libdl.so.2 ."
sudo systemctl enable warsaw
sudo systemctl stop warsaw
sudo systemctl start warsaw
/usr/local/bin/warsaw/core

E finalmente acessar a URL de diagnóstico para configurar para os bancos específicos:

<http://www.dieboldnixdorf.com.br/warsaw>

E finalmente consigo usar APENAS PELO FIREFOX (não funciona com google-chrome, não testei com chromium).

Offline

Rodapé do site