Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via [email protected]

Para mais informações: [email protected]

#1 18/07/2018 15:42:13

LucasGossen
Membro
De: Porto Alegre, RS
Registrado: 13/03/2017
Mensagens: 5

[RESOLVIDO] GDM não inicia automaticamente

Olá, recentemente fiz uma instalação do Arch com gnome. Tudo correu bem, e o sistema não apresenta bugs a não ser isto: ele dificilmente inicia o GDM automaticamente.
Por isso, logo que inicia, o sistema fica travado no boot. O que estou fazendo para iniciar o computador em modo gráfico é abrir um segundo terminal, logar em modo texto e reiniciar o serviço GDM por systemctl.
É estranho que isso às vezes funciona e às vezes não, de modo que tenho que fazer

# systemctl restart gdm.service

várias vezes até ele iniciar. Algumas vezes até o GDM inicia automaticamente no boot, sem precisar logar em modo texto.
Logo que instalei o gnome e gdm, já habilitei o serviço com

# systemctl enable gdm.service

Já reinstalei o gdm e habilitei novamente o serviço, e continua a mesma coisa.
Alguma ideia do que pode estar acontecendo?
Obrigado!

Última edição por LucasGossen (19/07/2018 14:29:42)

Offline

#2 19/07/2018 01:43:51

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.819

Re: [RESOLVIDO] GDM não inicia automaticamente

Quando ocorrer o problema rode o comando
systemctl status --full gdm.service

Ou
systemd -l status gdm.service


Cole aqui a saída para verificarmos o problema

Última edição por swatquest (19/07/2018 01:44:18)

Offline

#3 19/07/2018 01:59:48

LucasGossen
Membro
De: Porto Alegre, RS
Registrado: 13/03/2017
Mensagens: 5

Re: [RESOLVIDO] GDM não inicia automaticamente

Saída de "# systemctl status --full gdm.service":

 gdm.service - GNOME Display Manager
   Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2018-07-19 00:49:06 -03; 2min 10s ago
 Main PID: 321 (gdm)
    Tasks: 3 (limit: 4915)
   Memory: 4.4M
   CGroup: /system.slice/gdm.service
           └─321 /usr/bin/gdm

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable. 

Última edição por LucasGossen (19/07/2018 14:26:19)

Offline

#4 19/07/2018 14:29:07

LucasGossen
Membro
De: Porto Alegre, RS
Registrado: 13/03/2017
Mensagens: 5

Re: [RESOLVIDO] GDM não inicia automaticamente

Consegui resolver o bug!
O que fiz foi editar o arquivo /etc/grub/custom.conf e descomentar "WaylandEnable=false". Depois de fazer "# systemctl restart gdm.service", está tudo bem.
Obrigado pela disposição!

Offline

Rodapé do site