Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 18/07/2019 20:20:22

lebahevel
Membro
Registrado: 15/07/2019
Mensagens: 10

não foi possível satisfazer as dependências:

quando tento atualizar pelo gerenciador de pacotes ou instalar um programa dá esse erro:

falha ao preparar a transação, não foi possível satisfazer as dependências:
instalar dunst (1.4.1-1) quebra a dependência 'dunstify' requerida por update-notifier

isso tá acontecendo também no terminal:

[abel-pc abel]# pacman -Su
erro: não foi possível registrar a base de dados "archlinuxfr" (base de dados já registrada)
:: Iniciando atualização completa do sistema...
atenção: cryptsetup: local (2.1.0-1.1) é mais novo que core (2.1.0-1)
atenção: dbus: local (1.12.16-1.2) é mais novo que core (1.12.16-1)
atenção: glibc: local (2.29-3.1) é mais novo que core (2.29-3)
atenção: lib32-glibc: local (2.29-3.1) é mais novo que core (2.29-3)
atenção: os-prober: local (1.76-2) é mais novo que community (1.76-1)
atenção: procps-ng: local (3.3.15-1.2) é mais novo que core (3.3.15-1)
atenção: tlp: local (1.2.2-1.1) é mais novo que community (1.2.2-1)
resolvendo dependências...
procurando por pacotes conflitantes...
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: a instalação de dunst (1.4.1-1) quebra a dependência "dunstify" necessária por update-notifier

o que fazer nesse caso? ajuda por favor!!

Offline

#2 19/07/2019 18:55:40

lebahevel
Membro
Registrado: 15/07/2019
Mensagens: 10

Re: não foi possível satisfazer as dependências:

pessoal, voltei pra falar que resolvi já:

Abra como root:
/etc/pacman.conf

pode ser com o gedit, mousepad, ou qq outro editor de texto, como em:

$ sudo mousepad /etc/pacman.conf

E delete:

[archlinuxfr]
Server = http://repo.archlinux.fr/$arch

depois disso pude rodar # pacman -Syyuu e funcionou tudo perfeito

no meu caso, é porque estava em duplicata, assim:

[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/x86_64
[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/x86_64

eu deletei tudo, mas possivelmente deletando somente um já voltaria a funcionar

Última edição por lebahevel (19/07/2019 18:57:46)

Offline

#3 20/07/2019 00:11:44

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.940

Re: não foi possível satisfazer as dependências:

Offline

Rodapé do site