Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 05/11/2019 11:11:36

davicb
Membro
Registrado: 05/11/2019
Mensagens: 7

[RESOLVIDO] Problemas com teclado ABNT2 KDE

Olá pessoal.

Primeiro de tudo eu me sinto um pouco constrangido de ter que adicionar uma pergunta dessas no forum. Eu já pewquisei bastante e não sei o que eu posso estar fazendo de errado.

Acabei de instalar Arch com KDE no Virtual Box.
Problemas com teclado ABNT2.
Já pesquisei bastante mas não encontro o problema.
O teclado funciona no tty, não funciona dentro do KDE. A menos que eu digite 'setxkbmap br'.

O que eu fiz até agora...

#vim /locale/gen         (descomentei estas duas linhas)
pt_BR.uft-8 UTF-8
pt_BR ISO-8859-1

Rodei o comando
#locale-gen

#vim /etc/locale.conf
LANG=pt_BR-UTF-8

Eu não sei se o 'timezone' interfere em alguma coisa.
De qualquer forma eu setei o timezone para 'Brazil/East' no '/etc/localtime' o relogio funciona melhor do que 'America/Sao_Paulo'.


#vim /etc/vconsole.conf
KEYMAP=br-abnt2
#FONT=lat0-16
#FONT_MAP=
Estas linhas comentadas abaixo eu cheguie a usar mas agora eu deixei comentadas para não precisar apagar.

Adicionei o seguinte script
#vim /etc/X11/xorg.conf.d/10-keyboard.conf

Section "InputClass"
        Identifier "keyboard default"
        MatchIsKeyboard "yes"
        Option "XkbLayout" "br"
        Option "XkbVariant" "abnt2"
EndSection


reparei que já havia o script /etc/X11/xorg.conf.d/00-keyboard.conf com o seguinte conteúdo.

# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "br"
        Option "XkbModel" "abnt2"
EndSection


Então eu tenho 00-keyboard.conf e 10-keyboard.conf dentro de /etc/X11/xorg.conf.d/



Ja tentei adicionando esta linha no ~/.xinitrc

setxkbmap -model abnt2 -layout br -variant abnt2


#vim /etc/rc.conf
LOCALE="pt_BR.utf8"

#locale-gen


Estou há uns dois dias jogando com estas configurações sem sucesso. Talvez eu tenha feito algo mais que tenha esquecido de comentar.


Obrigado

Última edição por davicb (06/11/2019 08:37:11)

Offline

#2 05/11/2019 17:44:38

swatquest
Moderador
Registrado: 05/10/2010
Mensagens: 1.949

Re: [RESOLVIDO] Problemas com teclado ABNT2 KDE

O kde, gnome e outras interfaces terá que configurar dentro da DE.

No kde, altere o layout smile
xkeyboard-layouts.png.pagespeed.ic.IWZRsDkQcF.png

Última edição por swatquest (05/11/2019 17:48:21)

Offline

#3 06/11/2019 08:34:32

davicb
Membro
Registrado: 05/11/2019
Mensagens: 7

Re: [RESOLVIDO] Problemas com teclado ABNT2 KDE

Afffff

Muito obrigado.
Funcionou na hora.
E eu aqui quebrando cabeça no terminal.

Offline

Rodapé do site