Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 18/05/2020 21:59:22

manouchk
Membro
De: Vitória
Registrado: 30/08/2010
Mensagens: 12

[alsa/pulseaudio] problema de som com o microfone zoom H1

Boa noite,

Eu estou tentando usar um microphone zoom H1 como entrada som. Tenho diversos problemas "aleatórios", mas em particular com audacity qui segundo vi no pavucontrol joga a saída de som no microfone! Infelizmente, eu tive que configurar o microfone como entrada e saída. Quando configuro ele somente como entrada, ele não grava. Preciso mudar isso manualmente cada vez que toca, parando audacity para trocar no pavucontrol? Não existe um jeito de deixar isso gravado? (et que seja independente da ordem das placas de som?)

Na configuração alsa tenho isso (saída hdmi):

$ more .asoundrc
pcm.!default {
    type asym
    playback.pcm "plughw:0,3"
    capture.pcm  "plughw:1,0"
}

#defaults.pcm.card 0
#defaults.pcm.device 3
#defaults.ctl.card 0

(os comentários são da antiga configuração com somente a saída som via hdmi)

Eu uso essa config alsa asym para tentar ter a saída via hdmi e a entrada via o zoom H1 em todos os aplicativos que uso (obs, chrme, audacity...)



J'utilise cette config alsa asym pour essayer d'avoir le HDMI et le zoom H1 par défaut dans les différents logiciels (obs, google chrome, audacity etc...). Uma solução seria configurar o microfone zoom H1 somente na função entrada de som mas dessa forma, ele não funciona. Eu estou forçado a deixar ele no modo entrada e saída. Talvez isso seja a causa dos meus problemas mas não sei resolver isso

$ lspci | grep Audio
00:1f.3 Multimedia audio controller: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xdc240000 irq 132
 1 [H1             ]: USB-Audio - H1
                      ZOOM Corporation H1 at usb-0000:00:14.0-3, full speed
$ more /etc/asound.conf
# Use PulseAudio by default
pcm.!default {
  type pulse
  fallback "sysdefault"
  hint {
    show on
    description "Default ALSA Output (currently PulseAudio Sound Server)"
  }
}

ctl.!default {
  type pulse
  fallback "sysdefault"
}

# vim:set ft=alsaconf:

Descobri agora que posso fixar a entrada e saída. E assim:

$ pacmd list-sources | grep -e 'index:' -e device.string -e 'name:'
    index: 0
	name: <alsa_output.usb-ZOOM_Corporation_H1-00.analog-stereo.monitor>
		device.string = "1"
  * index: 1
	name: <alsa_input.usb-ZOOM_Corporation_H1-00.iec958-stereo>
		device.string = "iec958:1"
    index: 2
	name: <alsa_output.pci-0000_00_1f.3.hdmi-stereo.monitor>
		device.string = "0"

Acrecentei isso no final de

$ tail  /etc/pulse/default.pa
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
set-default-sink alsa_output.pci-0000_00_1f.3.hdmi-stereo.monitor
set-default-source alsa_input.usb-ZOOM_Corporation_H1-00.iec958-stereo

#set-default-source alsa_output.pci-0000_00_1f.3.hdmi-stereo.monitor

Mesmo assim, a leitura de audio não funciona no audacity e agora a gravação de som no obs não funciona mais. Estou perdido.

Alguém tem uma idea?

Offline

Rodapé do site