Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 28/08/2008 14:18:29

edupersoft
Membro
Registrado: 22/04/2008
Mensagens: 140

[resolvido] Wireless não funciona no vmware windows xp

Estou experimentando o vmware player. Já instalei o windows XP, ele roda, só a placa de rede não funciona. O meu note tem uma placa wireless funcionando bem, escrevo este tópico conectado por ela. Mas dentro do vmware não consegue pegar o ip e aparece a mensagem dizendo que a placa tem limitações.

Encontrei duas dicas na net resolvendo este problema, em uma, o usuário dizia que usou o MAC da sua placa de rede na placa de rede virtual e passou a funcionar, tentei alterar o arquivo .vmx (peguei um exemplo na net), para ajustar meu MAC, mas não adiantou, ele continua com o MAC antigo e quando saio do vmware ele ainda altera o .vmx para o MAC antigo. Acho que ele faz isso, porque quando subo o vmware ele carrega a instalação do XP e como a placa está lá com o MAC antigo, ele mão faz uma re-instalação da placa. Não sei se o MAC tem que ser igual, mas se tiver como procedo para alterar o MAC da minha placa virutal.
Se não for, qual é a saída.

Uma outra pessoa falava para substituir eth0, por wlan0 uma entrada no arquivo /etc/vmware/locations, mas isto já está correto.

Também vi que parece que existe um esquema diferente, onde fazemos um nat, pelo que pude entender a placa de rede física funcionaria como nat, mas também não sei se é este o caminho.

Alguém pode me ajudar?

Abaixo vai meu .mvx:

#!/usr/bin/vmware
config.version = "8"
virtualHW.version = "3"
ide0:0.present = "TRUE"
ide0:0.filename = "winxppro.vmdk"
memsize = "1664"
MemAllowAutoScaleDown = "FALSE"
ide1:0.present = "TRUE"
ide1:0.fileName = "auto detect"
ide1:0.deviceType = "cdrom-raw"
ide1:0.autodetect = "TRUE"
floppy0.present = "FALSE"
ethernet0.present = "TRUE"
usb.present = "TRUE"
sound.present = "TRUE"
sound.virtualDev = "es1371"
displayName = "Windows XP Pro"
guestOS = "winxppro"
nvram = "winxppro.nvram"
MemTrimRate = "-1"

ide0:0.redo = ""
ethernet0.addressType = "generated"
uuid.location = "56 4d e4 67 65 38 ee de-d7 ae 99 5b 0a 14 9f 9c"
uuid.bios = "56 4d e4 67 65 38 ee de-d7 ae 99 5b 0a 14 9f 9c"
ethernet0.generatedAddress = "00:0c:29:14:9f:9c"
ethernet0.generatedAddressOffset = "0"


tools.syncTime = "TRUE"
ide1:0.startConnected = "TRUE"

uuid.action = "create"

checkpoint.vmState = ""

extendedConfigFile = "winxppro.vmxf"
virtualHW.productCompatibility = "hosted"
tools.upgrade.policy = "manual"

fileSearchPath = "/home/eduardoandrade/vmware;."

ide0:0.autodetect = "TRUE"

ide1:0.redo = ""

tools.remindInstall = "TRUE"

usb.autoConnect.device0 = "path:1/1 autoclean:1"

Última edição por edupersoft (29/08/2008 08:21:46)

Offline

#2 28/08/2008 22:01:20

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: [resolvido] Wireless não funciona no vmware windows xp

Geralmente se usa o método de NAT. O método de Bridge, que você está usando, é complicação à toa com o VMware.

Acrescente essa linha ao arquivo .vmx para usar o modo NAT:

ethernet0.connectionType = "nat"

No modo NAT o seu pc funciona como router para o pc virtual. O VMware já se encarrega de configurar dhcp e tudo o mais sozinho.

Offline

#3 29/08/2008 08:21:17

edupersoft
Membro
Registrado: 22/04/2008
Mensagens: 140

Re: [resolvido] Wireless não funciona no vmware windows xp

Obrigado thotypous, resolveu. Só precisei reconfigurar o vmware porque o nat não estava habilitado.

Offline

Rodapé do site