Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 31/08/2008 03:46:23

lhbrito
Membro
Registrado: 19/08/2008
Mensagens: 27

[Resolvido] Pequenos problemas

Pessoal,

Estou concluindo a instalacao do ArchLinux e ja tenho quase tudo 100%. Ate agora estou gostando bastante do sistema mas estou com os pequenos problemas  :

1) No mplayer, nao consigo abrir um arquivo .avi ou .mpg, mas se tento no totem abre normalmente. A unica mensagem é "Failed to open <filename>".

2) Instalei o Splashy para ver como funciona, mas ao executar o mkinitcpio, deu alguns erros de lib nao encontrada, pesquisei na documentacao e vi sobre a alteracao que tinha que fazer no script do splashy que usava a versao anterior dessas libs, alterei, executei novamente o mkinitcpio e passou sem erro. Mas nao esta funcionando 100% : durante o boot, fica em modo grafico para com todas as mensagens, e o splashy test, nao aparece nada, e da um erro "Caught signal 11"

3) O teclado fora do ambiente grafico funciona 100%, mas no gnome, algumas teclas nao funcionam, tentei ir na preferencias e alterar o modelo do teclado ( que estava como Generic 105-Key(intl) PC" para "Brazillian ABNT2" para da um erro "Error activating XKB configuration. It can happen under various circumstances: ..." ( uma mensagem padrao, pelo que observei )

4)  tenho uma placa de tv, que usa o chip conexant CX23880, ja vi que tem uma entrada /dev/video0 mas o tvtime nao reconhece praticamente nada.

5) O mais simples, mas nao encontrei onde configura isso...rs... No gnome, o Nautilus sempre esta abrindo a pasta selecionada em nova janela, alguem sabe dizer onde configuro para abrir sempre na mesma janela...

Desculpem o tamanho da mensagem, mas esses sao apenas os ultimos detalhes que nao consegui resolver...

Luis

Última edição por lhbrito (01/09/2008 23:48:32)

Offline

#2 31/08/2008 04:12:05

RickMura
Membro
De: S.B.Campo-SP
Registrado: 08/01/2008
Mensagens: 216
Website

Re: [Resolvido] Pequenos problemas

1) No mplayer, nao consigo abrir um arquivo .avi ou .mpg, mas se tento no totem abre normalmente. A unica mensagem é "Failed to open <filename>".

Abra o Mplayer, va em preferences
Va na aba Video e selecione xv X11/xv

3) O teclado fora do ambiente grafico funciona 100%, mas no gnome, algumas teclas nao funcionam, tentei ir na preferencias e alterar o modelo do teclado ( que estava como Generic 105-Key(intl) PC" para "Brazillian ABNT2" para da um erro "Error activating XKB configuration. It can happen under various circumstances: ..." ( uma mensagem padrao, pelo que observei )

No xorg.conf altere para ficar assim:

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "abnt2"
    Option         "XkbLayout" "br"
EndSection

4)  tenho uma placa de tv, que usa o chip conexant CX23880, ja vi que tem uma entrada /dev/video0 mas o tvtime nao reconhece praticamente nada.

Veja se isto te ajuda:

Faça as alterações que achar necessário, tem links que podem te levar a outras configurações, não é dificil instalar placas de TV, mas requer bastante atenção.

Offline

#3 01/09/2008 21:45:17

lhbrito
Membro
Registrado: 19/08/2008
Mensagens: 27

Re: [Resolvido] Pequenos problemas

Obrigado pela resposta!


1)No Mplayer:
ja havia testado isso que passou, tentei todas as opções que tinha e não adiantou, não sei se é isso, mas notei que só ocorreo erro quando há espaço no nome do arquivo ou no path dele, e mesmo assim, somente se tento abri-lo através do duplo-clique no nautilus. Ex :se o video for "/home/luis/video 1.mpg", no duplo-clique via nautilus da "Failed to open file:///home/luis/video%201.mpg", mas se renomear para "/home/luis/video1.mpg" o duplo-clique funciona normalmente, ou se via terminal, digitar "mplayer /home/luis/video\ 1.mpg" também funciona... E mais uma informação, se depois que da o erro, não fecho o mplayer e arrasto e solto o mesmo arquivo em cima do mplayer, também funciona. O problema, pelo que notei, é só se dou um clique-duplo nele mesmo.

Achei que a causa fosse a configuração "Locale" dentro do rc.conf, mas testei com Locale=pt_BR , pt_BR.utf8 e pt_BR.iso88591 e em todas ocorre o erro no duplo-clique...

2) Splashy... me arrependi de testa-lo... por enquanto apenas desativei do boot , mas vou excluir depois...rs

3) O teclado no xorg funcionou 100%, valeu!

4) Nao vi todas as informacoes do link ainda, mas acho que ajudara sim...

Offline

#4 01/09/2008 21:51:20

heldersr
Membro
Registrado: 08/04/2008
Mensagens: 315

Re: [Resolvido] Pequenos problemas

Mplayer : #vi /usr/share/applications/mplayer.desktop

Altere a linha   Exec=gmplayer %U
para
Exec=gmplayer %F

Salva e se estiver com o Nautilus feche e abre novamente.

Os demais problemas não li tongue

Última edição por heldersr (01/09/2008 22:57:33)

Offline

#5 01/09/2008 23:49:37

lhbrito
Membro
Registrado: 19/08/2008
Mensagens: 27

Re: [Resolvido] Pequenos problemas

Obrigado heldersr, alterei o arquivo citado e funcionou 100%.

Offline

#6 01/09/2008 23:57:22

heldersr
Membro
Registrado: 08/04/2008
Mensagens: 315

Re: [Resolvido] Pequenos problemas

Só uma dica, instala o gnome-mplayer #pacman -S gnome-mplayer . É uma GUI para o Mplayer porém está em português, tem algumas facilidades fáceis de serem usadas rapidamente. Vale a pena dar uma olhada nele, tenho certeza que irá gostar, e se não gostar é só remover wink blz

Nos demais problemas que descreveu ainda não li, só vi do mplayer que bati o olho rapidamente e como já sabia a solução rapidamente escrevi, depois vou dar uma olhada nos outros problemas que escreveu.

Última edição por heldersr (02/09/2008 11:59:55)

Offline

Rodapé do site