Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 31/08/2008 10:29:27

Açoriano
Membro
Registrado: 12/06/2008
Mensagens: 129

[resolvido]Não tenho som

hello
Comprei um laptop, asus m70, e não consigo por o som a funcionar.
A placa acho que é uma dolby home theater pelo menos é o que diz aqui na caixa do laptop, no alsamixer tenho o master e o pcm unmuted e a 100, já testei ascultadores e colunas externas e nada, o aplay não dá assim como o amarok e o mplayer.
O deamon alsa dá fail no boot. Podem dar uma ajuda? Plzzzzzzzzzz

[[email protected] ~]$ lsmod|grep ^snd
snd_hda_intel         357048  0
snd_seq_oss            31872  0
snd_seq_midi_event      8192  1 snd_seq_oss
snd_seq                49968  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          8332  2 snd_seq_oss,snd_seq
snd_hwdep               8964  1 snd_hda_intel
snd_pcm_oss            40192  0
snd_pcm                69636  2 snd_hda_intel,snd_pcm_oss
snd_timer              21384  2 snd_seq,snd_pcm
snd_page_alloc          9608  2 snd_hda_intel,snd_pcm
snd_mixer_oss          16512  1 snd_pcm_oss
snd                    50724  9 snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_hwdep,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss

[[email protected] ~]$ ls -l /dev/snd/
total 0
crw-rw---- 1 root audio 116, 9 Ago 31 10:49 controlC0
crw-rw---- 1 root audio 116, 8 Ago 31 10:49 hwC0D0
crw-rw---- 1 root audio 116, 7 Ago 31 10:49 hwC0D1
crw-rw---- 1 root audio 116, 6 Ago 31 10:49 hwC0D2
crw-rw---- 1 root audio 116, 5 Ago 31 10:49 pcmC0D0c
crw-rw---- 1 root audio 116, 4 Ago 31 12:20 pcmC0D0p
crw-rw---- 1 root audio 116, 3 Ago 31 10:49 seq
crw-rw---- 1 root audio 116, 2 Ago 31 10:49 timer

Última edição por Açoriano (03/09/2008 15:41:36)

Offline

#2 31/08/2008 12:51:38

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: [resolvido]Não tenho som

Sua placa é HDA (atualmente praticamente todos os notebooks usam placas HDA). Essas placas não possuem somente controles de volume no mixer, mas também possuem controladores para modificar a direção do sinal (entrada ou saída) em cada pino, e às vezes também o caminho que o sinal toma dentro do chip.

Isso permite bastante flexibilidade para controlar o som, mas tem a desvantagem de ser impossível fazer uma configuração de mixer padrão que funcione de cara com todos os notebooks.

No alsamixer não aparece nenhum outro controle, que permita escolher múltiplas opções, ou algo do tipo? Esses controles tem de ser testados posição por posição até conseguir que o som funcione.

Offline

#3 31/08/2008 15:39:08

Açoriano
Membro
Registrado: 12/06/2008
Mensagens: 129

Re: [resolvido]Não tenho som

obrigado por responder já ajudou um pouco.
Infelismente não, só tenho mesmo o master e o PCM. No meu computador velho tenho o ubuntu e uma placa sound blaster 5.1 e tenho muitas opções, penso que tenho de instalar um driver no laptop para o som funcionar mas onde vou buscá-lo
é o problema de ter tecnologia recente, só funca bem no ruindows

Offline

#4 31/08/2008 18:40:19

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: [resolvido]Não tenho som

Tente trocar o sistema de som para o OSS. Baixe o pacote http://aur.archlinux.org/packages.php?ID=17029

O OSS costuma fornecer mais opções de mixer que o ALSA, e é mais provável que você consiga ajustar as coisas no mixer dele.

O mixer do OSS é o ossxmix, e já vem nesse pacote. Chame-o depois de instalar.

Mais informações no blog do Sryche: http://sryche.archlinux-br.org/blog/200 … rch-linux/

Offline

#5 31/08/2008 20:10:41

Açoriano
Membro
Registrado: 12/06/2008
Mensagens: 129

Re: [resolvido]Não tenho som

Tive googlando e vi este muita gente com este problema tentei algumas sugestões mas não funcionou

vou tentar a sua amanha aqui em portugal já é tarde

para não abrir mais um tópico ao acaso eu tenho uma pergunta, o meu laptop tem muitos extras, blueray, frimewire, infravermelhos bluethout wireless porta hdmi porta e-sata leitor de cartões expressgate e um placa tv que encaixa na expressgate, há algum jeito de por todas ou pelo menos a maior parte desses dispositivos a funcionar? Só de pensar nesse trablho todo bahhhhhhhhhhhhhhh a preguiça mata.

acho que não deveria ter usado o openbox para a minha primeira experiência com o arch, são horas que passo configurando mas no fina vale a pena, mais tarde devo mudar para o kde que nunca testei.

obrigado, amanha digo se funcionou

Offline

#6 01/09/2008 12:34:01

Açoriano
Membro
Registrado: 12/06/2008
Mensagens: 129

Re: [resolvido]Não tenho som

yay funciona
que deus seja generoso contigo thotypous

fiz muitas alterações no meu arch(cpufreq, deamons e modules) e ele deu muitos erros no boot(pena que ele dá o boot tão rápido que nem dá pra ver onde estão os erros tongue) mas isso fica para depois agora vou desfrutar do meu som HD

obrigadissimo, estou a gostar muito tanto do arch como da comunidade arch foi uma feliz mudança ubuntu->archlinux espero aprender muito mais sobre linux

edit:O ossmix ou é muito mau ou eu não mexer nele eu dou ossmix e ele retorna:
Selected mixer 0/High Definition Audio 0x10ec0663
Known controls are:
codec1.jack.int-speaker.mode <mix2|mix3|input> (currently mix2)
codec1.jack.int-speaker.mute ON|OFF (currently OFF)
codec1.jack.green.mode <mix2|mix3|input> (currently mix2)
codec1.jack.green.mute ON|OFF (currently OFF)
codec1.jack.pink.mode <mix4|input> (currently mix4)
codec1.jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
codec1.jack.pink.mute ON|OFF (currently OFF)
codec1.jack.pink.pcm3 [<leftvol>:<rightvol>] (currently 57.9:57.9 dB)
codec1.jack.pink.pcm3-mute ON|OFF (currently OFF)
codec1.jack.pink.mix1-mute ON|OFF (currently OFF)
codec1.jack.int-mic.mode <mix2|mix3|mix4|input> (currently mix2)
codec1.jack.int-mic [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
codec1.jack.int-mic.mute ON|OFF (currently OFF)
codec1.jack.black.mode <mix2|mix3|mix4> (currently mix2)
codec1.jack.black.mute ON|OFF (currently OFF)
codec1.record.mix6.mute.mix4 ON|OFF (currently OFF)
codec1.record.mix6.mute.int-mic ON|OFF (currently OFF)
codec1.record.mix6.mute.int-spe ON|OFF (currently OFF)
codec1.record.mix6.mute.headpho ON|OFF (currently OFF)
codec1.record.mix6.mute.mix1 ON|OFF (currently OFF)
codec1.record.mix6 [<leftvol>:<rightvol>] (currently 43.4:43.4 dB)
codec1.record.mix5.mute.mix4 ON|OFF (currently OFF)
codec1.record.mix5.mute.int-mic ON|OFF (currently OFF)
codec1.record.mix5.mute.int-spe ON|OFF (currently OFF)
codec1.record.mix5.mute.headpho ON|OFF (currently OFF)
codec1.record.mix5.mute.mix1 ON|OFF (currently OFF)
codec1.record.mix5 [<leftvol>:<rightvol>] (currently 43.4:43.4 dB)
codec1.misc.pcm1 [<leftvol>:<rightvol>] (currently 57.9:57.9 dB)
codec1.misc.pcm2 [<leftvol>:<rightvol>] (currently 57.9:57.9 dB)
codec1.misc.mix4 [<leftvol>:<rightvol>] (currently 43.4:43.4 dB)
codec1.misc.int-mic [<leftvol>:<rightvol>] (currently 43.4:43.4 dB)
codec1.misc.int-speaker [<leftvol>:<rightvol>] (currently 43.4:43.4 dB)
codec1.misc.headphone1 [<leftvol>:<rightvol>] (currently 43.4:43.4 dB)
codec1.misc.mix1 <mix4|int-mic> (currently mix4)
codec1.misc.pcm1-mute ON|OFF (currently OFF)
codec1.misc.mix1-mute1 ON|OFF (currently OFF)
codec1.misc.mix2 <pcm1|mix1> (currently pcm1)
codec1.misc.pcm2-mute ON|OFF (currently OFF)
codec1.misc.mix1-mute2 ON|OFF (currently OFF)
codec1.misc.mix3 <pcm2|mix1> (currently pcm2)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|Low|Medium|High|High+|Production|OFF> (currently Fast)
vmix0-vol <monovol> (currently 25.0 dB)
vmix0-out1 [<leftVU>:<rightVU>] (currently 123:123) (Read-only)
vmix0-in [<leftVU>:<rightVU>] (currently 0:0) (Read-only)
vmix0-out.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0-out2 [<leftVU>:<rightVU>] (currently 123:123) (Read-only)
vmix0-out.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0-out3 [<leftVU>:<rightVU>] (currently 0:0) (Read-only)
vmix0-out.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0-out4 [<leftVU>:<rightVU>] (currently 0:0) (Read-only)
vmix0-out.pcm13 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0-out5 [<leftVU>:<rightVU>] (currently 0:0) (Read-only)

como se mexe nisto? tem alguma gui ou um programa tipo alsamixer, dei um man ossmix e parece muito confuso de configurar o mixer

Última edição por Açoriano (01/09/2008 12:38:28)

Offline

#7 01/09/2008 12:40:17

thotypous
Membro
Registrado: 21/05/2008
Mensagens: 650

Re: [resolvido]Não tenho som

É ossxmix, com o x no meio wink

Offline

#8 01/09/2008 13:26:47

Açoriano
Membro
Registrado: 12/06/2008
Mensagens: 129

Re: [resolvido]Não tenho som

thotypous escreveu:

É ossxmix, com o x no meio wink

ups erro meu

Offline

#9 03/09/2008 14:02:42

corvolino
Admin
De: Bahia
Registrado: 19/08/2007
Mensagens: 1.659
Website

Re: [resolvido]Não tenho som

coloca [RESOLVIDO] no topic x]


corvolino ~  archlinux i686

* http://corvolinopunk.wordpress.com  / @corvolinopunk

Offline

Rodapé do site