Você não está autenticado.

Anúncio

Arch Linux Brasil está precisando de sua colaboração para realizar o pagamento do domínio e do host, para colaborar, realizar doações via paypal.

Para mais informações: contato at archlinux-br.org.

#1 14/09/2008 00:01:59

willianrm
Membro
Registrado: 25/08/2008
Mensagens: 40

Ajuda na instalação do Rubberband

Srs,
peço ajuda para resolver uma das minhas última dependencias do windows, preciso instalar o plugin Rubberband para ser usado com o Ardour.

Encontrei ele no AUR http://aur.archlinux.org/packages.php?ID=15349, mais parece que esta meio desatualizado e esta dando uns erros. Com muita luta consegui desenrrolar os erros alterando o PKGBUILD e corrigindo as versões e caminhos corretos para download.

Logo depois "makepkg --asroot"
Ele começa a compilar e dá o seguinte erro:

g++ -DHAVE_FFTW3 -DFFTW_DOUBLE_ONLY -DNO_THREAD_CHECKS -g -O2 -fPIC -Wall       -I/tmp/yaourt-tmp-root/aur-vamp-plugin-sdk/vamp-plugin-sdk/pkg/usr/include   -Irubberband -Isrc    -c -o src/sysutils.o src/sysutils.cpp
src/sysutils.cpp: In function 'float* RubberBand::allocFloat(float*, int)':
src/sysutils.cpp:108: error: 'free' was not declared in this scope
src/sysutils.cpp:111: error: 'posix_memalign' was not declared in this scope
src/sysutils.cpp:113: error: 'malloc' was not declared in this scope
src/sysutils.cpp: In function 'void RubberBand::freeFloat(float*)':
src/sysutils.cpp:125: error: 'free' was not declared in this scope
src/sysutils.cpp: In function 'double* RubberBand::allocDouble(double*, int)':
src/sysutils.cpp:130: error: 'free' was not declared in this scope
src/sysutils.cpp:133: error: 'posix_memalign' was not declared in this scope
src/sysutils.cpp:135: error: 'malloc' was not declared in this scope
src/sysutils.cpp: In function 'void RubberBand::freeDouble(double*)':
src/sysutils.cpp:147: error: 'free' was not declared in this scope
make: *** [src/sysutils.o] Error 1

Daih então resolvi baixar no site do projeto http://www.breakfastquay.com/rubberband … 2.tar.bz2. Descompactei e segui com o velho "./configure, make, make install"

Então o erro foi o mesmo.


Alguém poderia me ajudar ?

Grato,
Willian - São Luís MA

Offline

#2 14/09/2008 17:23:14

abraaoalcantara
Membro
Registrado: 01/09/2008
Mensagens: 12

Re: Ajuda na instalação do Rubberband

E ai cara?
Tentei instalar aqui, e deu o mesmo erro sad
Mas,la no site onde você baixou, existe o binario do programa, e ta rodando bem.
So tenho duas duvidas... como integro ele com o ardour? Não seria melhor usar o pitch do audacity nao?

Offline

#3 14/09/2008 17:58:54

willianrm
Membro
Registrado: 25/08/2008
Mensagens: 40

Re: Ajuda na instalação do Rubberband

Tentei pelo binário e não rodou não...deu o mesmo erro como vc pode ver na msg acima

Offline

#4 15/09/2008 01:06:35

abraaoalcantara
Membro
Registrado: 01/09/2008
Mensagens: 12

Re: Ajuda na instalação do Rubberband

Estranho.
O binario rodou sem eu ter que instalar nada.
Você pode reportar o erro la no :
http://aur.archlinux.org/packages.php?ID=15349
Um cara falou que so conseguiu instala-lo  depois de instalar o ladspa, mas aqui tambem nao rolou com o ladspa instalado.

Offline

#5 15/09/2008 17:00:10

Memphyx
Membro
De: Jandira/SP
Registrado: 28/06/2007
Mensagens: 169
Website

Re: Ajuda na instalação do Rubberband

Com certeza deve ter mais dependencias ai.

Offline

Rodapé do site